From: Andrew Lunn <andrew@lunn.ch>
To: Sean Nyekjaer <sean.nyekjaer@prevas.dk>
Cc: netdev@vger.kernel.org
Subject: Re: [PATCH v1] net: phy: micrel: add KSZ8795 ethernet switch
Date: Mon, 23 Jan 2017 16:12:19 +0100 [thread overview]
Message-ID: <20170123151219.GE10895@lunn.ch> (raw)
In-Reply-To: <20170123075846.12888-1-sean.nyekjaer@prevas.dk>
On Mon, Jan 23, 2017 at 08:58:46AM +0100, Sean Nyekjaer wrote:
> This is add support for the PHYs in the KSZ8795 5port managed switch.
>
> It will allow to detect the link between the switch and the soc
> and uses the same read_status functions as the KSZ8873MLL switch.
>
> This ethernet switch have unfortunately the same phy id as KSZ8051.
>
> Signed-off-by: Sean Nyekjaer <sean.nyekjaer@prevas.dk>
> ---
> drivers/net/phy/micrel.c | 14 ++++++++++++++
> include/linux/micrel_phy.h | 2 ++
> 2 files changed, 16 insertions(+)
>
> diff --git a/drivers/net/phy/micrel.c b/drivers/net/phy/micrel.c
> index ea92d524d5a8..fa158ae5115b 100644
> --- a/drivers/net/phy/micrel.c
> +++ b/drivers/net/phy/micrel.c
> @@ -1014,6 +1014,20 @@ static struct phy_driver ksphy_driver[] = {
> .get_stats = kszphy_get_stats,
> .suspend = genphy_suspend,
> .resume = genphy_resume,
> +}, {
> + .phy_id = PHY_ID_KSZ8795,
> + .phy_id_mask = MICREL_PHY_ID_MASK,
> + .name = "Micrel KSZ8795 Switch",
This name is confusing. You are adding support for the PHYs embedded
in the switch, not the switch itself. The phylib has no idea these
PHYs are inside a switch. It does not matter. It is just a PHY. Please
drop the word "Switch".
Thanks
Andrew
next prev parent reply other threads:[~2017-01-23 15:12 UTC|newest]
Thread overview: 6+ messages / expand[flat|nested] mbox.gz Atom feed top
2017-01-23 7:58 [PATCH v1] net: phy: micrel: add KSZ8795 ethernet switch Sean Nyekjaer
2017-01-23 15:12 ` Andrew Lunn [this message]
2017-01-26 17:51 ` Sean Nyekjær
2017-01-26 18:12 ` Andrew Lunn
2017-01-27 7:42 ` Sean Nyekjær
2017-01-26 18:36 ` Florian Fainelli
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20170123151219.GE10895@lunn.ch \
--to=andrew@lunn.ch \
--cc=netdev@vger.kernel.org \
--cc=sean.nyekjaer@prevas.dk \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox