From mboxrd@z Thu Jan 1 00:00:00 1970 From: David Miller Subject: Re: [PATCH net-next] tcp/dccp: avoid one atomic operation for timewait hashdance Date: Wed, 13 Dec 2017 14:33:49 -0500 (EST) Message-ID: <20171213.143349.404602503188166520.davem@davemloft.net> References: <1513056312.25033.49.camel@gmail.com> Mime-Version: 1.0 Content-Type: Text/Plain; charset=us-ascii Content-Transfer-Encoding: 7bit Cc: netdev@vger.kernel.org To: eric.dumazet@gmail.com Return-path: Received: from shards.monkeyblade.net ([184.105.139.130]:43554 "EHLO shards.monkeyblade.net" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1753197AbdLMTdv (ORCPT ); Wed, 13 Dec 2017 14:33:51 -0500 In-Reply-To: <1513056312.25033.49.camel@gmail.com> Sender: netdev-owner@vger.kernel.org List-ID: From: Eric Dumazet Date: Mon, 11 Dec 2017 21:25:12 -0800 > From: Eric Dumazet > > First, rename __inet_twsk_hashdance() to inet_twsk_hashdance() > > Then, remove one inet_twsk_put() by setting tw_refcnt to 3 instead > of 4, but adding a fat warning that we do not have the right to access > tw anymore after inet_twsk_hashdance() > > Signed-off-by: Eric Dumazet Applied, thanks Eric.