From mboxrd@z Thu Jan 1 00:00:00 1970 From: David Miller Subject: Re: [PATCH net-next v5 0/5] Introduce NETIF_F_GRO_HW Date: Sat, 30 Dec 2017 10:45:35 -0500 (EST) Message-ID: <20171230.104535.2291382569309825655.davem@davemloft.net> References: <20171229124332.GA20090@bistromath.localdomain> Mime-Version: 1.0 Content-Type: Text/Plain; charset=us-ascii Content-Transfer-Encoding: 7bit Cc: alexander.duyck@gmail.com, sd@queasysnail.net, netdev@vger.kernel.org, andrew.gospodarek@broadcom.com To: michael.chan@broadcom.com Return-path: Received: from shards.monkeyblade.net ([184.105.139.130]:45872 "EHLO shards.monkeyblade.net" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1751243AbdL3Ppl (ORCPT ); Sat, 30 Dec 2017 10:45:41 -0500 In-Reply-To: Sender: netdev-owner@vger.kernel.org List-ID: From: Michael Chan Date: Fri, 29 Dec 2017 21:20:02 -0800 > I think the name GRO_HW is perfectly fine. It is GRO aggregation done > in hardware, and hardware providing extra information to the driver to > setup the SKB just like GRO. I don't know what better name to call it > than GRO_HW. Agreed.