From mboxrd@z Thu Jan 1 00:00:00 1970 From: Alexei Starovoitov Subject: Re: [bpf-next v2 8/9] bpf: Provide helper to do forwarding lookups in kernel FIB table Date: Wed, 9 May 2018 14:49:42 -0700 Message-ID: <20180509214941.p2vuroxmgu6spfib@ast-mbp> References: <20180504025432.23451-1-dsahern@gmail.com> <20180504025432.23451-9-dsahern@gmail.com> <433c2320-ed9b-446e-6e29-92075f947251@iogearbox.net> <69063df2-8987-b5f1-ced2-b2443139b5a5@gmail.com> <88bd5281-2fa6-41d1-98f3-33c3d4a95674@iogearbox.net> Mime-Version: 1.0 Content-Type: text/plain; charset=us-ascii Cc: Daniel Borkmann , netdev@vger.kernel.org, borkmann@iogearbox.net, ast@kernel.org, davem@davemloft.net, shm@cumulusnetworks.com, roopa@cumulusnetworks.com, brouer@redhat.com, toke@toke.dk, john.fastabend@gmail.com To: David Ahern Return-path: Received: from mail-pf0-f193.google.com ([209.85.192.193]:45778 "EHLO mail-pf0-f193.google.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S965436AbeEIVtq (ORCPT ); Wed, 9 May 2018 17:49:46 -0400 Received: by mail-pf0-f193.google.com with SMTP id c10-v6so12161pfi.12 for ; Wed, 09 May 2018 14:49:46 -0700 (PDT) Content-Disposition: inline In-Reply-To: Sender: netdev-owner@vger.kernel.org List-ID: On Wed, May 09, 2018 at 03:39:52PM -0600, David Ahern wrote: > On 5/9/18 3:29 PM, David Ahern wrote: > > On 5/9/18 2:44 PM, Daniel Borkmann wrote: > >> Generally, no objection. However, could we get rid of the two extra includes altogether > >> to avoid running into any such dependency issue? Right now the only includes we have in > >> the bpf uapi header is linux/types.h and linux/bpf_common.h (latter has no extra deps > >> by itself). Both the ETH_ALEN and struct in6_addr are in uapi and therefore never allowed > >> to change so we can e.g. avoid to use ETH_ALEN and just have the value instead. In the > >> other places of the header we use __u32 remote_ipv6[4], __u32 src_ip6[4] etc to denote > >> a v6 address, we could do the same here and should be all good then. > > > > I was able to drop the include of linux/in6.h and still use in6_addr. I > > would prefer to keep in6_addr since it works and avoid the need to add > > typecasts. > > Never mind; that was working because if_ether.h was pulling in skbuff.h > which included in6.h. > > > > As for ETH_ALEN, I could redefine it but it just kicks the can down the > > road. If if_ether.h is included after bpf.h, it will cause redefinition > > warnings. > > > > I guess I will continue the open coded magic numbers for mac and ipv6 > addresses. That's the only way. Adding +#include +#include to uapi/bpf.h is no-go. It will cause all sorts of breakage not only to kernel build as we realized, but to various user space apps too. Please use be32 ipv6[4] and hard coded mac instead.