From mboxrd@z Thu Jan 1 00:00:00 1970 From: Jiri Pirko Subject: Re: [PATCH net-next] net: rename ndo_setup_tc to ndo_setup_offload Date: Wed, 18 Jul 2018 18:30:54 +0200 Message-ID: <20180718163054.GF2184@nanopsycho.orion> References: <20180718161404.24198-1-pablo@netfilter.org> Mime-Version: 1.0 Content-Type: text/plain; charset=us-ascii Cc: netdev@vger.kernel.org, thomas.lendacky@amd.com, f.fainelli@gmail.com, ariel.elior@cavium.com, michael.chan@broadcom.com, santosh@chelsio.com, madalin.bucur@nxp.com, yisen.zhuang@huawei.com, salil.mehta@huawei.com, jeffrey.t.kirsher@intel.com, tariqt@mellanox.com, saeedm@mellanox.com, jiri@mellanox.com, idosch@mellanox.com, ganeshgr@chelsio.com, jakub.kicinski@netronome.com, linux-net-drivers@solarflare.com, peppe.cavallaro@st.com, alexandre.torgue@st.com, joabreu@synopsys.com, grygorii.strashko@ti.com, andrew@lunn.ch, vivien.didelot@savoirfairelinux.com To: Pablo Neira Ayuso Return-path: Received: from mail-wm0-f67.google.com ([74.125.82.67]:53216 "EHLO mail-wm0-f67.google.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1730110AbeGRRLo (ORCPT ); Wed, 18 Jul 2018 13:11:44 -0400 Received: by mail-wm0-f67.google.com with SMTP id o11-v6so3403844wmh.2 for ; Wed, 18 Jul 2018 09:33:02 -0700 (PDT) Content-Disposition: inline In-Reply-To: <20180718161404.24198-1-pablo@netfilter.org> Sender: netdev-owner@vger.kernel.org List-ID: Wed, Jul 18, 2018 at 06:14:04PM CEST, pablo@netfilter.org wrote: >One of the recurring complaints is that we do not have, as a driver >writer, a central location from which we would be fed offloading rules >into a NIC. This was brought up again during Netconf'18 in Boston. > >This patch just renames ndo_setup_tc to ndo_setup_offload as a very >early initial work to prepare for follow up patches that discuss/propose >unified flow representation for the existing offload programming APIs: >ethtool_rxnfc, cls_flower, cls_u32 and (probably, not yet upstream) >conntrack. > >Signed-off-by: Pablo Neira Ayuso Acked-by: Jiri Pirko It would make sense to also rename following enum: enum tc_setup_type { TC_SETUP_QDISC_MQPRIO, TC_SETUP_CLSU32, TC_SETUP_CLSFLOWER, TC_SETUP_CLSMATCHALL, TC_SETUP_CLSBPF, TC_SETUP_BLOCK, TC_SETUP_QDISC_CBS, TC_SETUP_QDISC_RED, TC_SETUP_QDISC_PRIO, TC_SETUP_QDISC_MQ, TC_SETUP_QDISC_ETF, }; Maybe "enum setup_offload_type" and "SETUP_OFFLOAD_TC_*"? Could you please do it in a follow-up? Thanks!