From: Martin Blumenstingl <martin.blumenstingl@googlemail.com>
To: netdev@vger.kernel.org, devicetree@vger.kernel.org,
f.fainelli@gmail.com, andrew@lunn.ch, mark.rutland@arm.com,
robh+dt@kernel.org, davem@davemloft.net
Cc: linux-kernel@vger.kernel.org,
Martin Blumenstingl <martin.blumenstingl@googlemail.com>
Subject: [PATCH v2 0/7] IP101GR: devicetree based configuration of SEL_INTR32
Date: Sun, 18 Nov 2018 22:23:52 +0100 [thread overview]
Message-ID: <20181118212359.32414-1-martin.blumenstingl@googlemail.com> (raw)
The IP101GR is a 32-pin QFN package variant of the IP101G/IP101GA
Ethernet PHY. Due to it's limited amount of pins the RXER (receive
error) and INTR32 (interrupt) functions share pin 21.
The goal of this series is:
- some small cleanups in patches 3, 4 and 5
- allowing the kernel to detect IRQ floods on boards where the IP101GR
is configured in RXER mode but the RXER line is configured on the
host SoC as interrupt line (patch 6)
- configuration of the SEL_INTR32 register so we can use the interrupt
function on boards where the RXER/INTR32 pin (pin 21) is routed to
one of the host SoC's interrupt inputs (patches 1, 2, 7)
A use-case where this is needed is the Endless Mini (EC-100). I have
tested my changes on that board. This also confirms that Heiner
Kallweit's recent icplus.c PHY driver changes are working (at least on
my setup).
This series is based on net-next commit 7c460cf9cd1a ("net: aquantia:
fix spelling mistake "specfield" -> "specified"")
Changes since v1 at [0]:
- collected Andrew's Reviewed-by's (thank you!)
- updated description of patch #2 to explain why two properties were
added instead of adding an "this is a IP101GR" property
- validate that there's no conflicting configuration in patch #7
- rebased on top of latest net-next
[0] https://patchwork.ozlabs.org/cover/999371/
Martin Blumenstingl (7):
dt-bindings: vendor-prefix: add prefix for IC Plus Corp.
dt-bindings: net: phy: add bindings for the IC Plus Corp. IP101A/G
PHYs
net: phy: icplus: keep all ip101a_g functions together
net: phy: icplus: use the BIT macro where possible
net: phy: icplus: rename IP101A_G_NO_IRQ to IP101A_G_IRQ_ALL_MASK
net: phy: icplus: implement .did_interrupt for IP101A/G
net: phy: icplus: allow configuring the interrupt function on IP101GR
.../bindings/net/icplus-ip101ag.txt | 19 +++
.../devicetree/bindings/vendor-prefixes.txt | 1 +
drivers/net/phy/icplus.c | 135 +++++++++++++++---
3 files changed, 135 insertions(+), 20 deletions(-)
create mode 100644 Documentation/devicetree/bindings/net/icplus-ip101ag.txt
--
2.19.1
next reply other threads:[~2018-11-18 21:23 UTC|newest]
Thread overview: 9+ messages / expand[flat|nested] mbox.gz Atom feed top
2018-11-18 21:23 Martin Blumenstingl [this message]
2018-11-18 21:23 ` [PATCH v2 1/7] dt-bindings: vendor-prefix: add prefix for IC Plus Corp Martin Blumenstingl
2018-11-18 21:23 ` [PATCH v2 2/7] dt-bindings: net: phy: add bindings for the IC Plus Corp. IP101A/G PHYs Martin Blumenstingl
2018-11-18 21:23 ` [PATCH v2 3/7] net: phy: icplus: keep all ip101a_g functions together Martin Blumenstingl
2018-11-18 21:23 ` [PATCH v2 4/7] net: phy: icplus: use the BIT macro where possible Martin Blumenstingl
2018-11-18 21:23 ` [PATCH v2 5/7] net: phy: icplus: rename IP101A_G_NO_IRQ to IP101A_G_IRQ_ALL_MASK Martin Blumenstingl
2018-11-18 21:23 ` [PATCH v2 6/7] net: phy: icplus: implement .did_interrupt for IP101A/G Martin Blumenstingl
2018-11-18 21:23 ` [PATCH v2 7/7] net: phy: icplus: allow configuring the interrupt function on IP101GR Martin Blumenstingl
2018-11-19 0:16 ` [PATCH v2 0/7] IP101GR: devicetree based configuration of SEL_INTR32 David Miller
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20181118212359.32414-1-martin.blumenstingl@googlemail.com \
--to=martin.blumenstingl@googlemail.com \
--cc=andrew@lunn.ch \
--cc=davem@davemloft.net \
--cc=devicetree@vger.kernel.org \
--cc=f.fainelli@gmail.com \
--cc=linux-kernel@vger.kernel.org \
--cc=mark.rutland@arm.com \
--cc=netdev@vger.kernel.org \
--cc=robh+dt@kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox