Netdev List
 help / color / mirror / Atom feed
From: Jiri Pirko <jiri@resnulli.us>
To: Vasundhara Volam <vasundhara-v.volam@broadcom.com>
Cc: davem@davemloft.net, michael.chan@broadcom.com,
	jiri@mellanox.com, jakub.kicinski@netronome.com,
	mkubecek@suse.cz, netdev@vger.kernel.org
Subject: Re: [PATCH net-next v3 RFC 0/8] devlink: Add configuration parameters support for devlink_port
Date: Fri, 14 Dec 2018 14:08:18 +0100	[thread overview]
Message-ID: <20181214130818.GA30755@nanopsycho> (raw)
In-Reply-To: <1544782194-17694-1-git-send-email-vasundhara-v.volam@broadcom.com>

Fri, Dec 14, 2018 at 11:09:46AM CET, vasundhara-v.volam@broadcom.com wrote:
>This patchset adds support for configuration parameters setting through
>devlink_port.  Each device registers supported configuration parameters
>table.
>
>The user can retrieve data on these parameters by
>"devlink port param show" command and can set new value to a
>parameter by "devlink port param set" command.
>All configuration modes supported by devlink_dev are supported
>by devlink_port also.
>
>Command examples and output:
>
># devlink port param show
>pci/0000:3b:00.0/0:
>  name wake-on-lan type generic
>    values:
>      cmode permanent value false
>
>pci/0000:3b:00.1/1:
>  name wake-on-lan type generic
>    values:
>      cmode permanent value false
>
>pci/0000:af:00.0/0:
>  name wake-on-lan type generic
>    values:
>      cmode permanent value true
>
># devlink port param show pci/0000:3b:00.0/0 name wake-on-lan
>pci/0000:3b:00.0/0:
>  name wake-on-lan type generic
>    values:
>      cmode permanent value false
>
># devlink port param set pci/0000:3b:00.0/0 name wake-on-lan cmode permanent value true
>
>v2->v3:
>Make following changes as per suggestions from Jiri Pirko and
>Michal Kubecek.
>- Add a helper __devlink_params_register() with common code used by
>  both devlink_params_register() and devlink_port_params_register().
>- Define only WOL types used now and define them as bitfield, so that
>  mutliple WOL types can be enabled upon power on.
>- Modify "wake-on-lan" name to "wake_on_lan" to be symmetric with
>  previous definitions.
>- Rename DEVLINK_PARAM_WOL_XXX to DEVLINK_PARAM_WAKE_XXX to be
>  symmetrical with ethtool WOL definitions.
>- Modify bnxt_dl_wol_validate(), to throw error message when user gives
>  value other than DEVLINK_PARAM_WAKE_MAGIC ot to disable WOL.
>- Use netdev_err() instead of netdev_warn(), when devlink_port_register()
>  and devlink_port_params_register() returns error. Also, don't log rc
>  in this message.

Could you please have this changelog per-patch? The best way is to put
this into under individual patch descriptions. Thanks.


>
>v1->v2:
>Make following changes as per suggestions from Jiri Pirko.
>- Remove separate enum devlink_port_param_generic_id for port params.
>  Instead club it with existing device params. Accordingly refactor
>  remaining patchset.
>- Move INIT_LIST_HEAD of port param_list to devlink_port_register()
>- Add a helper devlink_param_verify() to be used for both
>  devlink_params_register() and devlink_port_params_register().
>- Add a helper __devlink_params_unregister() for common code in
>  devlink_params_unregister() and devlink_port_params_unregister().
>- Move DEVLINK_CMD_PORT_PARAM_XXX definitions to the end of the enum.
>- Split the patches for devlink_port_param_driverinit_value_get() and
>  devlink_port_param_driverinit_value_set() into separate patches.
>- define DEVLINK_PARAM_GENERIC_ID_WOL type as u8 and define enum for
>  different types of WOL. Accordingly modify bnxt_en patch to validate
>  wol type.
>
>Vasundhara Volam (8):
>  devlink: Add devlink_param for port register and unregister
>  devlink: Add port param get command
>  devlink: Add port param set command
>  devlink: Add support for driverinit get value for devlink_port
>  devlink: Add support for driverinit set value for devlink_port
>  devlink: Add devlink notifications support for port params
>  devlink: Add a generic wake_on_lan port parameter
>  bnxt_en: Add bnxt_en initial port params table and register it
>
> drivers/net/ethernet/broadcom/bnxt/bnxt.h         |   1 +
> drivers/net/ethernet/broadcom/bnxt/bnxt_devlink.c |  43 +-
> drivers/net/ethernet/broadcom/bnxt/bnxt_devlink.h |   1 +
> include/net/devlink.h                             |  57 +++
> include/uapi/linux/devlink.h                      |   5 +
> net/core/devlink.c                                | 464 ++++++++++++++++++----
> 6 files changed, 489 insertions(+), 82 deletions(-)
>
>-- 
>1.8.3.1
>

  parent reply	other threads:[~2018-12-14 13:15 UTC|newest]

Thread overview: 11+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2018-12-14 10:09 [PATCH net-next v3 RFC 0/8] devlink: Add configuration parameters support for devlink_port Vasundhara Volam
2018-12-14 10:09 ` [PATCH net-next v3 RFC 1/8] devlink: Add devlink_param for port register and unregister Vasundhara Volam
2018-12-14 10:09 ` [PATCH net-next v3 RFC 2/8] devlink: Add port param get command Vasundhara Volam
2018-12-14 10:09 ` [PATCH net-next v3 RFC 3/8] devlink: Add port param set command Vasundhara Volam
2018-12-14 10:09 ` [PATCH net-next v3 RFC 4/8] devlink: Add support for driverinit get value for devlink_port Vasundhara Volam
2018-12-14 10:09 ` [PATCH net-next v3 RFC 5/8] devlink: Add support for driverinit set " Vasundhara Volam
2018-12-14 10:09 ` [PATCH net-next v3 RFC 6/8] devlink: Add devlink notifications support for port params Vasundhara Volam
2018-12-14 10:09 ` [PATCH net-next v3 RFC 7/8] devlink: Add a generic wake_on_lan port parameter Vasundhara Volam
2018-12-14 10:09 ` [PATCH net-next v3 RFC 8/8] bnxt_en: Add bnxt_en initial port params table and register it Vasundhara Volam
2018-12-14 13:08 ` Jiri Pirko [this message]
2018-12-14 16:44   ` [PATCH net-next v3 RFC 0/8] devlink: Add configuration parameters support for devlink_port Vasundhara Volam

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20181214130818.GA30755@nanopsycho \
    --to=jiri@resnulli.us \
    --cc=davem@davemloft.net \
    --cc=jakub.kicinski@netronome.com \
    --cc=jiri@mellanox.com \
    --cc=michael.chan@broadcom.com \
    --cc=mkubecek@suse.cz \
    --cc=netdev@vger.kernel.org \
    --cc=vasundhara-v.volam@broadcom.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox