Netdev List
 help / color / mirror / Atom feed
From: Alexei Starovoitov <alexei.starovoitov@gmail.com>
To: David Ahern <dahern@digitalocean.com>
Cc: David Ahern <dsahern@kernel.org>,
	netdev@vger.kernel.org, davem@davemloft.net, kuba@kernel.org,
	prashantbhole.linux@gmail.com, jasowang@redhat.com,
	brouer@redhat.com, toke@redhat.com, mst@redhat.com,
	toshiaki.makita1@gmail.com, daniel@iogearbox.net,
	john.fastabend@gmail.com, ast@kernel.org, kafai@fb.com,
	songliubraving@fb.com, yhs@fb.com, andriin@fb.com,
	dsahern@gmail.com
Subject: Re: [PATCH RFC v4 bpf-next 09/11] tun: Support xdp in the Tx path for xdp_frames
Date: Tue, 3 Mar 2020 10:16:01 -0800	[thread overview]
Message-ID: <20200303181559.7xzzyvyy72od4tte@ast-mbp> (raw)
In-Reply-To: <318c0a44-b540-1c7f-9667-c01da5a8ac73@digitalocean.com>

On Mon, Mar 02, 2020 at 09:27:08PM -0700, David Ahern wrote:
> > 
> > I'm worried that XDP_TX is a silent alias to XDP_PASS.
> > What were the reasons to go with this approach?
> 
> As I stated in the cover letter:
> 
> "XDP_TX on Rx means send the packet out the device it arrived
> on; given that, XDP_Tx for the Tx path is treated as equivalent to
> XDP_PASS - ie., continue on the Tx path."

I saw that, but it states the behavior and doesn't answer my "why" question.

> > imo it's less error prone and extensible to warn on XDP_TX.
> > Which will mean that both XDP_TX and XDP_REDICT are not supported for egress atm.
> 
> I personally don't care either way; I was going with the simplest
> concept from a user perspective.

That's not a good sign when uapi is designed as "dont care either way".

> > 
> > Patches 8 and 9 cover tun only. I'd like to see egress hook to be implemented
> > in at least one physical NIC. Pick any hw. Something that handles real frames.
> > Adding this hook to virtual NIC is easy, but it doesn't demonstrate design
> > trade-offs one would need to think through by adding egress hook to physical
> > nic. That's why I think it's mandatory to have it as part of the patch set.
> > 
> > Patch 11 exposes egress to samples/bpf. It's nice, but without selftests it's
> > no go. All new features must be exercised as part of selftests/bpf.
> 
> Patches that exercise the rtnetlink uapi are fairly easy to do on single
> node; anything traffic related requires multiple nodes or namespace
> level capabilities.  Unless I am missing something that is why all
> current XDP tests ride on top of veth; veth changes are not part of this
> set.
> 
> So to be clear you are saying that all new XDP features require patches
> to a h/w nic, veth and whatever the author really cares about before new
> features like this go in?

I didn't say 'veth'. I really meant 'physical nic'.
The patch set implies that XDP_EGRESS is a generic concept and applicable to
physical and virtual netdevs. There is an implementation for tun. But reading
between the lines I don't see that api was thought through on the physical nic.
Hence I'm requesting to see the patches that implement it. When you'll try to
add xdp_egress to a physical nic I suspect there will be challenges that will
force changes to xdp_egress api and I want that to happen before uapi lands in
the tree and becomes frozen.

  parent reply	other threads:[~2020-03-03 18:16 UTC|newest]

Thread overview: 38+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2020-02-27  3:20 [PATCH RFC v4 bpf-next 00/11] Add support for XDP in egress path David Ahern
2020-02-27  3:20 ` [PATCH RFC v4 bpf-next 01/11] net: Add XDP setup and query commands for Tx programs David Ahern
2020-02-27  3:20 ` [PATCH RFC v4 bpf-next 02/11] net: Add BPF_XDP_EGRESS as a bpf_attach_type David Ahern
2020-02-27  3:20 ` [PATCH RFC v4 bpf-next 03/11] xdp: Add xdp_txq_info to xdp_buff David Ahern
2020-02-27  8:00   ` Jesper Dangaard Brouer
2020-02-27 11:58     ` Toke Høiland-Jørgensen
2020-02-28  3:01       ` David Ahern
2020-02-28 10:10         ` Toke Høiland-Jørgensen
2020-02-27 20:44     ` David Ahern
2020-02-28 10:07       ` Toke Høiland-Jørgensen
2020-02-28 10:41         ` Jesper Dangaard Brouer
2020-02-27  3:20 ` [PATCH RFC v4 bpf-next 04/11] net: Add IFLA_XDP_EGRESS for XDP programs in the egress path David Ahern
2020-02-27  3:20 ` [PATCH RFC v4 bpf-next 05/11] net: core: rename netif_receive_generic_xdp to do_generic_xdp_core David Ahern
2020-02-27  3:20 ` [PATCH RFC v4 bpf-next 06/11] net: core: Rename do_xdp_generic to do_xdp_generic_rx and export David Ahern
2020-02-27  3:20 ` [PATCH RFC v4 bpf-next 07/11] tun: set egress XDP program David Ahern
2020-03-02  3:32   ` Jason Wang
2020-03-02  3:52     ` David Ahern
2020-03-10  2:18     ` David Ahern
2020-02-27  3:20 ` [PATCH RFC v4 bpf-next 08/11] tun: Support xdp in the Tx path for skb David Ahern
2020-03-02  3:28   ` Jason Wang
2020-03-02  3:41     ` David Ahern
2020-03-03 10:46   ` Jesper Dangaard Brouer
2020-03-03 15:36     ` David Ahern
2020-02-27  3:20 ` [PATCH RFC v4 bpf-next 09/11] tun: Support xdp in the Tx path for xdp_frames David Ahern
2020-03-02 18:30   ` Alexei Starovoitov
2020-03-03  4:27     ` David Ahern
2020-03-03  9:08       ` Jesper Dangaard Brouer
2020-03-03 18:16       ` Alexei Starovoitov [this message]
2020-03-03 10:40   ` Jesper Dangaard Brouer
2020-03-10  3:06     ` David Ahern
2020-03-10  3:44       ` David Ahern
2020-03-10  9:03         ` Jesper Dangaard Brouer
2020-02-27  3:20 ` [PATCH RFC v4 bpf-next 10/11] libbpf: Add egress XDP support David Ahern
2020-02-27  3:20 ` [PATCH RFC v4 bpf-next 11/11] samples/bpf: xdp1, add " David Ahern
2020-02-27 11:55 ` [PATCH RFC v4 bpf-next 00/11] Add support for XDP in egress path Toke Høiland-Jørgensen
2020-02-27 16:22   ` Alexei Starovoitov
2020-02-27 17:06     ` Toke Høiland-Jørgensen
2020-02-27 18:37       ` Alexei Starovoitov

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20200303181559.7xzzyvyy72od4tte@ast-mbp \
    --to=alexei.starovoitov@gmail.com \
    --cc=andriin@fb.com \
    --cc=ast@kernel.org \
    --cc=brouer@redhat.com \
    --cc=dahern@digitalocean.com \
    --cc=daniel@iogearbox.net \
    --cc=davem@davemloft.net \
    --cc=dsahern@gmail.com \
    --cc=dsahern@kernel.org \
    --cc=jasowang@redhat.com \
    --cc=john.fastabend@gmail.com \
    --cc=kafai@fb.com \
    --cc=kuba@kernel.org \
    --cc=mst@redhat.com \
    --cc=netdev@vger.kernel.org \
    --cc=prashantbhole.linux@gmail.com \
    --cc=songliubraving@fb.com \
    --cc=toke@redhat.com \
    --cc=toshiaki.makita1@gmail.com \
    --cc=yhs@fb.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox