From: Vladimir Oltean <vladimir.oltean@nxp.com>
To: "netdev@vger.kernel.org" <netdev@vger.kernel.org>
Cc: "Florian Fainelli" <f.fainelli@gmail.com>,
"Andrew Lunn" <andrew@lunn.ch>,
"Vivien Didelot" <vivien.didelot@gmail.com>,
"Tobias Waldekranz" <tobias@waldekranz.com>,
"DENG Qingfang" <dqfext@gmail.com>,
"Alvin Šipraga" <alsi@bang-olufsen.dk>
Subject: Re: [RFC PATCH net-next 0/6] Rework DSA bridge TX forwarding offload API
Date: Tue, 2 Nov 2021 10:07:03 +0000 [thread overview]
Message-ID: <20211102100702.72u2abq3mft45svo@skbuf> (raw)
In-Reply-To: <20211026162625.1385035-1-vladimir.oltean@nxp.com>
On Tue, Oct 26, 2021 at 07:26:19PM +0300, Vladimir Oltean wrote:
> This change set replaces struct net_device *dp->bridge_dev with a
> struct dsa_bridge *dp->bridge that contains some extra information about
> that bridge, like a unique number kept by DSA.
>
> Up until now we computed that number only with the bridge TX forwarding
> offload feature, but it will be needed for other features too, like for
> isolation of FDB entries belonging to different bridges. Hardware
> implementations vary, but one common pattern seems to be the presence of
> a FID field which can be associated with that bridge number kept by DSA.
> The idea was outlined here:
> https://patchwork.kernel.org/project/netdevbpf/patch/20210818120150.892647-16-vladimir.oltean@nxp.com/
> (the difference being that with this new proposal, drivers would not
> need to call dsa_bridge_num_find, instead the bridge_num would be part
> of the struct dsa_bridge :: num passed as argument).
>
> No functional change intended.
>
> Vladimir Oltean (6):
> net: dsa: make dp->bridge_num one-based
> net: dsa: assign a bridge number even without TX forwarding offload
> net: dsa: hide dp->bridge_dev and dp->bridge_num behind helpers
> net: dsa: rename dsa_port_offloads_bridge to
> dsa_port_offloads_bridge_dev
> net: dsa: keep the bridge_dev and bridge_num as part of the same
> structure
> net: dsa: eliminate dsa_switch_ops :: port_bridge_tx_fwd_{,un}offload
>
> drivers/net/dsa/b53/b53_common.c | 9 +-
> drivers/net/dsa/b53/b53_priv.h | 5 +-
> drivers/net/dsa/dsa_loop.c | 9 +-
> drivers/net/dsa/hirschmann/hellcreek.c | 5 +-
> drivers/net/dsa/lan9303-core.c | 7 +-
> drivers/net/dsa/lantiq_gswip.c | 25 +++--
> drivers/net/dsa/microchip/ksz_common.c | 5 +-
> drivers/net/dsa/microchip/ksz_common.h | 4 +-
> drivers/net/dsa/mt7530.c | 18 +--
> drivers/net/dsa/mv88e6xxx/chip.c | 145 ++++++++++++-------------
> drivers/net/dsa/ocelot/felix.c | 8 +-
> drivers/net/dsa/qca8k.c | 13 ++-
> drivers/net/dsa/rtl8366rb.c | 9 +-
> drivers/net/dsa/sja1105/sja1105_main.c | 40 +++++--
> drivers/net/dsa/xrs700x/xrs700x.c | 10 +-
> include/linux/dsa/8021q.h | 9 +-
> include/net/dsa.h | 102 +++++++++++++----
> net/dsa/dsa2.c | 57 ++++++----
> net/dsa/dsa_priv.h | 59 ++--------
> net/dsa/port.c | 123 +++++++++++----------
> net/dsa/slave.c | 34 +++---
> net/dsa/switch.c | 20 ++--
> net/dsa/tag_8021q.c | 20 ++--
> net/dsa/tag_dsa.c | 5 +-
> net/dsa/tag_ocelot.c | 2 +-
> net/dsa/tag_sja1105.c | 11 +-
> 26 files changed, 414 insertions(+), 340 deletions(-)
>
> --
> 2.25.1
>
Any feedback?
next prev parent reply other threads:[~2021-11-02 10:07 UTC|newest]
Thread overview: 17+ messages / expand[flat|nested] mbox.gz Atom feed top
2021-10-26 16:26 [RFC PATCH net-next 0/6] Rework DSA bridge TX forwarding offload API Vladimir Oltean
2021-10-26 16:26 ` [RFC PATCH net-next 1/6] net: dsa: make dp->bridge_num one-based Vladimir Oltean
2021-11-11 12:24 ` Alvin Šipraga
2021-11-11 12:45 ` Vladimir Oltean
2021-11-11 13:18 ` Alvin Šipraga
2021-10-26 16:26 ` [RFC PATCH net-next 2/6] net: dsa: assign a bridge number even without TX forwarding offload Vladimir Oltean
2021-11-11 12:27 ` Alvin Šipraga
2021-10-26 16:26 ` [RFC PATCH net-next 3/6] net: dsa: hide dp->bridge_dev and dp->bridge_num behind helpers Vladimir Oltean
2021-10-26 16:26 ` [RFC PATCH net-next 4/6] net: dsa: rename dsa_port_offloads_bridge to dsa_port_offloads_bridge_dev Vladimir Oltean
2021-11-11 12:33 ` Alvin Šipraga
2021-10-26 16:26 ` [RFC PATCH net-next 5/6] net: dsa: keep the bridge_dev and bridge_num as part of the same structure Vladimir Oltean
2021-11-11 13:17 ` Alvin Šipraga
2021-10-26 16:26 ` [RFC PATCH net-next 6/6] net: dsa: eliminate dsa_switch_ops :: port_bridge_tx_fwd_{,un}offload Vladimir Oltean
2021-11-11 13:23 ` Alvin Šipraga
2021-11-19 15:38 ` Tobias Waldekranz
2021-11-02 10:07 ` Vladimir Oltean [this message]
2021-11-04 11:39 ` [RFC PATCH net-next 0/6] Rework DSA bridge TX forwarding offload API Tobias Waldekranz
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20211102100702.72u2abq3mft45svo@skbuf \
--to=vladimir.oltean@nxp.com \
--cc=alsi@bang-olufsen.dk \
--cc=andrew@lunn.ch \
--cc=dqfext@gmail.com \
--cc=f.fainelli@gmail.com \
--cc=netdev@vger.kernel.org \
--cc=tobias@waldekranz.com \
--cc=vivien.didelot@gmail.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox