From: Vladimir Oltean <vladimir.oltean@nxp.com>
To: Andrew Lunn <andrew@lunn.ch>
Cc: netdev@vger.kernel.org, Heiner Kallweit <hkallweit1@gmail.com>,
Russell King <linux@armlinux.org.uk>,
"David S. Miller" <davem@davemloft.net>,
Eric Dumazet <edumazet@google.com>,
Jakub Kicinski <kuba@kernel.org>, Paolo Abeni <pabeni@redhat.com>,
Marek Vasut <marex@denx.de>, Wei Fang <wei.fang@nxp.com>,
Clark Wang <xiaoning.wang@nxp.com>
Subject: Re: [PATCH net-next 1/3] net: phy: realtek: eliminate priv->phycr2 variable
Date: Thu, 6 Nov 2025 16:47:03 +0200 [thread overview]
Message-ID: <20251106144703.wroevzsoyvr7urzf@skbuf> (raw)
In-Reply-To: <07183d23-c766-4ab5-962a-76ed4f5b99f0@lunn.ch>
On Thu, Nov 06, 2025 at 02:51:12PM +0100, Andrew Lunn wrote:
> > +static int rtl8211f_disable_clk_out(struct phy_device *phydev)
> > +{
> > + struct rtl821x_priv *priv = phydev->priv;
> > +
> > + /* The value is preserved if the device tree property is absent */
> > + if (!priv->disable_clk_out)
> > + return 0;
>
> The name rtl8211f_disable_clk_out() suggests that it is going to
> disable the clock output. In fact it is conditional, and might not
> actually do anything. Maybe move the condition outside? Or maybe
> rename it to rtl8211f_config_clk_out()?
>
> Andrew
It was born out of a desire to keep the main control flow simpler.
Among the two alternatives, I would prefer to rename this function to
rtl8211f_config_clk_out().
Thanks for the review.
pw-bot: cr
next prev parent reply other threads:[~2025-11-06 14:47 UTC|newest]
Thread overview: 7+ messages / expand[flat|nested] mbox.gz Atom feed top
2025-11-06 11:10 [PATCH net-next 0/3] Disable CLKOUT on RTL8211F(D)(I)-VD-CG Vladimir Oltean
2025-11-06 11:10 ` [PATCH net-next 1/3] net: phy: realtek: eliminate priv->phycr2 variable Vladimir Oltean
2025-11-06 13:51 ` Andrew Lunn
2025-11-06 14:47 ` Vladimir Oltean [this message]
2025-11-06 11:10 ` [PATCH net-next 2/3] net: phy: realtek: eliminate has_phycr2 variable Vladimir Oltean
2025-11-06 13:52 ` Andrew Lunn
2025-11-06 11:10 ` [PATCH net-next 3/3] net: phy: realtek: allow CLKOUT to be disabled on RTL8211F(D)(I)-VD-CG Vladimir Oltean
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20251106144703.wroevzsoyvr7urzf@skbuf \
--to=vladimir.oltean@nxp.com \
--cc=andrew@lunn.ch \
--cc=davem@davemloft.net \
--cc=edumazet@google.com \
--cc=hkallweit1@gmail.com \
--cc=kuba@kernel.org \
--cc=linux@armlinux.org.uk \
--cc=marex@denx.de \
--cc=netdev@vger.kernel.org \
--cc=pabeni@redhat.com \
--cc=wei.fang@nxp.com \
--cc=xiaoning.wang@nxp.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox