From: Jakub Kicinski <kuba@kernel.org>
To: Andrew Lunn <andrew@lunn.ch>
Cc: "Oleksij Rempel" <o.rempel@pengutronix.de>,
"Linus Walleij" <linusw@kernel.org>,
"Luiz Angelo Daros de Luca" <luizluca@gmail.com>,
"Vladimir Oltean" <olteanv@gmail.com>,
"David S. Miller" <davem@davemloft.net>,
"Eric Dumazet" <edumazet@google.com>,
"Paolo Abeni" <pabeni@redhat.com>,
"Ahmad Fatoum" <a.fatoum@pengutronix.de>,
stable@vger.kernel.org, kernel@pengutronix.de,
linux-kernel@vger.kernel.org,
"Alvin Šipraga" <alvin.sipraga@analog.com>,
netdev@vger.kernel.org
Subject: Re: [PATCH net v1 1/1] net: dsa: realtek: use gpiod_set_value_cansleep for reset GPIO
Date: Fri, 14 Aug 2026 10:00:14 -0700 [thread overview]
Message-ID: <20260814100014.1122e66a@kernel.org> (raw)
In-Reply-To: <e52dcc7b-3545-4e43-888f-7a7b3811af8a@lunn.ch>
On Fri, 14 Aug 2026 16:09:04 +0200 Andrew Lunn wrote:
> On Fri, Aug 14, 2026 at 01:01:02PM +0200, Oleksij Rempel wrote:
> > From: Ahmad Fatoum <a.fatoum@pengutronix.de>
> >
> > rtl83xx_reset_assert() and rtl83xx_reset_deassert() are only called from
> > the probe path, which may sleep and is not timing-critical. When the
> > reset GPIO is provided by a sleeping controller such as an I2C I/O
> > expander, gpiod_set_value() warns:
> >
> > Switch both helpers to gpiod_set_value_cansleep() so such a reset GPIO can
> > be used without triggering the warning.
> >
> > The reset GPIO has been driven with the non-sleeping gpiod_set_value()
> > since the driver was added in v4.19. The call has since been refactored
> > across several files - from realtek-smi.c / realtek-mdio.c into the common
> > rtl83xx.c module and then into the rtl83xx_reset_assert() and
> > rtl83xx_reset_deassert() helpers (both in v6.9). This patch therefore
> > applies as-is only to kernels that carry those helpers (v6.9+); older
> > stable kernels need the same gpiod_set_value_cansleep() conversion at the
> > corresponding open-coded call sites.
>
> This is one of those fuzzy cases. It never worked, so this is not a
> regression. Nobody has needed it up until now. So it probably should
> be considered a new feature, and merged via net-next.
Sounds like it's a false positive, but it's a WARN, so if it hits on
real platforms -- I think it's a real fix?
prev parent reply other threads:[~2026-08-14 17:00 UTC|newest]
Thread overview: 4+ messages / expand[flat|nested] mbox.gz Atom feed top
2026-08-14 11:01 [PATCH net v1 1/1] net: dsa: realtek: use gpiod_set_value_cansleep for reset GPIO Oleksij Rempel
2026-08-14 11:46 ` Alvin Šipraga
2026-08-14 14:09 ` Andrew Lunn
2026-08-14 17:00 ` Jakub Kicinski [this message]
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20260814100014.1122e66a@kernel.org \
--to=kuba@kernel.org \
--cc=a.fatoum@pengutronix.de \
--cc=alvin.sipraga@analog.com \
--cc=andrew@lunn.ch \
--cc=davem@davemloft.net \
--cc=edumazet@google.com \
--cc=kernel@pengutronix.de \
--cc=linusw@kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=luizluca@gmail.com \
--cc=netdev@vger.kernel.org \
--cc=o.rempel@pengutronix.de \
--cc=olteanv@gmail.com \
--cc=pabeni@redhat.com \
--cc=stable@vger.kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox