From: Conor Dooley <conor@kernel.org>
To: Oleksij Rempel <o.rempel@pengutronix.de>
Cc: "Linus Walleij" <linusw@kernel.org>,
"Luiz Angelo Daros de Luca" <luizluca@gmail.com>,
"Andrew Lunn" <andrew@lunn.ch>,
"Vladimir Oltean" <olteanv@gmail.com>,
"David S. Miller" <davem@davemloft.net>,
"Eric Dumazet" <edumazet@google.com>,
"Jakub Kicinski" <kuba@kernel.org>,
"Paolo Abeni" <pabeni@redhat.com>,
"Rob Herring" <robh@kernel.org>,
"Krzysztof Kozlowski" <krzk+dt@kernel.org>,
"Conor Dooley" <conor+dt@kernel.org>,
kernel@pengutronix.de, linux-kernel@vger.kernel.org,
"Ahmad Fatoum" <a.fatoum@pengutronix.de>,
"Alvin Šipraga" <alvin.sipraga@analog.com>,
netdev@vger.kernel.org, devicetree@vger.kernel.org
Subject: Re: [PATCH net-next v3 1/3] dt-bindings: net: dsa: realtek: add RTL8365MB power supplies
Date: Mon, 31 Aug 2026 16:26:58 +0100 [thread overview]
Message-ID: <20260831-awkward-routine-4198a7d5e7e2@spud> (raw)
In-Reply-To: <20260831123637.666457-2-o.rempel@pengutronix.de>
[-- Attachment #1: Type: text/plain, Size: 2935 bytes --]
On Mon, Aug 31, 2026 at 02:36:35PM +0200, Oleksij Rempel wrote:
> Document the RTL8365MB power rails as optional supplies. They are optional
> because the rails are often always-on; some designs break them out for
> granular hwmon monitoring and regulator control.
>
> They are scoped to realtek,rtl8365mb: different Realtek switch families use
> different power-rail naming schemes, so these rails do not apply to other
> families such as realtek,rtl8366rb (VDDA/VDD_CORE/VDDIO/...).
>
> Signed-off-by: Oleksij Rempel <o.rempel@pengutronix.de>
> Reviewed-by: Linus Walleij <linusw@kernel.org>
> Reviewed-by: Luiz Angelo Daros de Luca <luizluca@gmail.com>
Acked-by: Conor Dooley <conor.dooley@microchip.com>
> ---
> Changes since v2:
> - Move the *-supply properties to the top level; if:/then: now only forbids
> them on non-rtl8365mb compatibles (Krzysztof Kozlowski).
> ---
> .../devicetree/bindings/net/dsa/realtek.yaml | 33 +++++++++++++++++++
> 1 file changed, 33 insertions(+)
>
> diff --git a/Documentation/devicetree/bindings/net/dsa/realtek.yaml b/Documentation/devicetree/bindings/net/dsa/realtek.yaml
> index 473facd87a62..b7bb60af623c 100644
> --- a/Documentation/devicetree/bindings/net/dsa/realtek.yaml
> +++ b/Documentation/devicetree/bindings/net/dsa/realtek.yaml
> @@ -8,6 +8,20 @@ title: Realtek switches for unmanaged switches
>
> allOf:
> - $ref: dsa.yaml#/$defs/ethernet-ports
> + - if:
> + not:
> + properties:
> + compatible:
> + contains:
> + const: realtek,rtl8365mb
> + then:
> + properties:
> + avddh-supply: false
> + avddl-supply: false
> + dvddio-supply: false
> + dvddio1-supply: false
> + dvddl-supply: false
> + pllvddl-supply: false
>
> maintainers:
> - Linus Walleij <linusw@kernel.org>
> @@ -62,6 +76,24 @@ properties:
> resets:
> maxItems: 1
>
> + avddh-supply:
> + description: AVDDH high-voltage analog supply.
> +
> + avddl-supply:
> + description: AVDDL low-voltage analog supply.
> +
> + dvddio-supply:
> + description: DVDDIO digital I/O supply.
> +
> + dvddio1-supply:
> + description: DVDDIO_1 secondary digital I/O supply for the RGMII bank.
> +
> + dvddl-supply:
> + description: DVDDL digital core supply.
> +
> + pllvddl-supply:
> + description: PLLVDDL PLL analog supply.
> +
> realtek,disable-leds:
> type: boolean
> description: |
> @@ -243,6 +275,7 @@ examples:
> platform {
> ethernet-switch {
> compatible = "realtek,rtl8365mb";
> + avddh-supply = <&avddh>;
> mdc-gpios = <&gpio1 16 GPIO_ACTIVE_HIGH>;
> mdio-gpios = <&gpio1 17 GPIO_ACTIVE_HIGH>;
> reset-gpios = <&gpio5 0 GPIO_ACTIVE_LOW>;
> --
> 2.47.3
>
[-- Attachment #2: signature.asc --]
[-- Type: application/pgp-signature, Size: 228 bytes --]
next prev parent reply other threads:[~2026-08-31 15:27 UTC|newest]
Thread overview: 7+ messages / expand[flat|nested] mbox.gz Atom feed top
2026-08-31 12:36 [PATCH net-next v3 0/3] net: dsa: realtek: enable RTL8365MB power supplies Oleksij Rempel
2026-08-31 12:36 ` [PATCH net-next v3 1/3] dt-bindings: net: dsa: realtek: add " Oleksij Rempel
2026-08-31 15:26 ` Conor Dooley [this message]
2026-08-31 12:36 ` [PATCH net-next v3 2/3] net: dsa: realtek: rtl83xx: add support for enabling supplies Oleksij Rempel
2026-08-31 12:36 ` [PATCH net-next v3 3/3] net: dsa: realtek: rtl83xx: use dev_err_cast_probe() for reset GPIO Oleksij Rempel
2026-08-31 13:08 ` Luiz Angelo Daros de Luca
2026-09-03 1:40 ` [PATCH net-next v3 0/3] net: dsa: realtek: enable RTL8365MB power supplies patchwork-bot+netdevbpf
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20260831-awkward-routine-4198a7d5e7e2@spud \
--to=conor@kernel.org \
--cc=a.fatoum@pengutronix.de \
--cc=alvin.sipraga@analog.com \
--cc=andrew@lunn.ch \
--cc=conor+dt@kernel.org \
--cc=davem@davemloft.net \
--cc=devicetree@vger.kernel.org \
--cc=edumazet@google.com \
--cc=kernel@pengutronix.de \
--cc=krzk+dt@kernel.org \
--cc=kuba@kernel.org \
--cc=linusw@kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=luizluca@gmail.com \
--cc=netdev@vger.kernel.org \
--cc=o.rempel@pengutronix.de \
--cc=olteanv@gmail.com \
--cc=pabeni@redhat.com \
--cc=robh@kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox