Netdev List
 help / color / mirror / Atom feed
From: zhulei  <zhulei_szu@163.com>
To: "Lorenzo Bianconi" <lorenzo@kernel.org>
Cc: andrew+netdev@lunn.ch, davem@davemloft.net, edumazet@google.com,
	kuba@kernel.org, pabeni@redhat.com, netdev@vger.kernel.org
Subject: Re:Re: [PATCH RESEND net-next] net: airoha: Make use of the helper function dev_err_probe()
Date: Wed, 1 Jul 2026 16:01:16 +0800 (CST)	[thread overview]
Message-ID: <23f58025.6d6d.19f1cb25385.Coremail.zhulei_szu@163.com> (raw)
In-Reply-To: <akOcrmDpfzNUTR2n@lore-desk>

At 2026-06-30 18:38:38, "Lorenzo Bianconi" <lorenzo@kernel.org> wrote:
>> From: Lei Zhu <zhulei@kylinos.cn>
>> 
>> Use dev_err_probe() to reduce code size and simplify the code.
>> 
>> Signed-off-by: Lei Zhu <zhulei@kylinos.cn>
>> ---
>> The last submission was when net-next is closed.Resending it.
>> 
>>  drivers/net/ethernet/airoha/airoha_eth.c | 21 +++++++++------------
>>  1 file changed, 9 insertions(+), 12 deletions(-)
>> 
>> diff --git a/drivers/net/ethernet/airoha/airoha_eth.c b/drivers/net/ethernet/airoha/airoha_eth.c
>> index 31cdb11cd78d..189f64e83a46 100644
>> --- a/drivers/net/ethernet/airoha/airoha_eth.c
>> +++ b/drivers/net/ethernet/airoha/airoha_eth.c
>> @@ -3071,10 +3071,9 @@ static int airoha_probe(struct platform_device *pdev)
>>  	eth->dev = &pdev->dev;
>>  
>>  	err = dma_set_mask_and_coherent(eth->dev, DMA_BIT_MASK(32));
>
>I do not think dma_set_mask_and_coherent() can return -EPROBE_DEFER, so there
>is no point adding dev_err_probe() here.
>
>Regards,
>Lorenzo
>
Hi Lorenzo,

Thanks for your review.

Before making this patch, I referred to the comments of dev_err_probe:
"even if @err is known to never be -EPROBE_DEFER, the benefit compared
to a normal dev_err() is the standardized format of the error code."

In the probe function, I noticed devm_platform_ioremap_resource_byname
already uses dev_err_probe, while other functions still use dev_err.
Replace them with dev_err_probe for consistency, more compact error paths,
and better readability of error codes.

Best regards
Lei


  reply	other threads:[~2026-07-01  8:02 UTC|newest]

Thread overview: 4+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2026-06-30  1:52 [PATCH RESEND net-next] net: airoha: Make use of the helper function dev_err_probe() Lei Zhu
2026-06-30 10:38 ` Lorenzo Bianconi
2026-07-01  8:01   ` zhulei [this message]
2026-07-01  8:17     ` Lorenzo Bianconi

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=23f58025.6d6d.19f1cb25385.Coremail.zhulei_szu@163.com \
    --to=zhulei_szu@163.com \
    --cc=andrew+netdev@lunn.ch \
    --cc=davem@davemloft.net \
    --cc=edumazet@google.com \
    --cc=kuba@kernel.org \
    --cc=lorenzo@kernel.org \
    --cc=netdev@vger.kernel.org \
    --cc=pabeni@redhat.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox