From mboxrd@z Thu Jan 1 00:00:00 1970 From: Joe Perches Subject: Re: [PATCH] Change judgment len position Date: Wed, 24 Oct 2018 10:18:31 -0700 Message-ID: <375561cf08343abbcd4118da2272507c30311788.camel@perches.com> References: <20181024154729.5312-1-wanghaifine@gmail.com> <20181024155739.GA25314@1wt.eu> <60f08664db5751949ddfb34666bfda77f99682f1.camel@perches.com> <20181024163230.GA25382@1wt.eu> Mime-Version: 1.0 Content-Type: text/plain; charset="ISO-8859-1" Content-Transfer-Encoding: 7bit Cc: Willy Tarreau , wanghaifine@gmail.com, David Miller , Alexey Kuznetsov , Hideaki YOSHIFUJI , netdev , LKML To: Eric Dumazet Return-path: In-Reply-To: Sender: linux-kernel-owner@vger.kernel.org List-Id: netdev.vger.kernel.org On Wed, 2018-10-24 at 10:03 -0700, Eric Dumazet wrote: > On Wed, Oct 24, 2018 at 9:54 AM Joe Perches wrote: > > > I think if the point is to test for negative numbers, > > it's clearer to do that before using min_t.and it's > > probably clearer not to use min_t at all. > > > > ... > > > if (len > sizeof(int)) > > len = sizeof(int); > > It is a matter of taste really, Agree and hence my use of 'I think' above. > I know some people (like me) sometimes > mixes min() and max() Not quite sure what you mean here by mixes. mix up? If so, the < > inversions probably have about the same error rate. And I suppose there are cases where the always set of len in uses like len = min(len, 4); are more costly (len being in a slow write speed area of memory or some such) than the other style of if (len < 4) len = 4; I think that min() is easier to read in most cases. > I would suggest that if someones wants to change the current code, a > corresponding test would be added in tools/testing/selftests/net?