From mboxrd@z Thu Jan 1 00:00:00 1970 From: Prashant Bhole Subject: Re: [RFC bpf-next 3/4] tools/bpf: bpftool, split the function do_dump() Date: Thu, 20 Sep 2018 11:49:58 +0900 Message-ID: <57dce5da-2e7d-9a8e-a3b9-945250c71b8d@lab.ntt.co.jp> References: <20180919075143.9308-1-bhole_prashant_q7@lab.ntt.co.jp> <20180919075143.9308-4-bhole_prashant_q7@lab.ntt.co.jp> <20180919082617.0967a1cf@cakuba.netronome.com> Mime-Version: 1.0 Content-Type: text/plain; charset=utf-8; format=flowed Content-Transfer-Encoding: 7bit Cc: Alexei Starovoitov , Daniel Borkmann , Quentin Monnet , "David S . Miller" , netdev@vger.kernel.org To: Jakub Kicinski Return-path: Received: from tama50.ecl.ntt.co.jp ([129.60.39.147]:52775 "EHLO tama50.ecl.ntt.co.jp" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1733110AbeITIbs (ORCPT ); Thu, 20 Sep 2018 04:31:48 -0400 In-Reply-To: <20180919082617.0967a1cf@cakuba.netronome.com> Content-Language: en-US Sender: netdev-owner@vger.kernel.org List-ID: On 9/20/2018 12:26 AM, Jakub Kicinski wrote: > On Wed, 19 Sep 2018 16:51:42 +0900, Prashant Bhole wrote: >> +static int dump_map_elem(int fd, void *key, void *value, >> + struct bpf_map_info *map_info, struct btf *btf, >> + json_writer_t *btf_wtr) >> +{ >> + int num_elems = 0; >> + >> + if (!bpf_map_lookup_elem(fd, key, value)) { >> + if (json_output) { >> + print_entry_json(map_info, key, value, btf); >> + } else { >> + if (btf) { >> + struct btf_dumper d = { >> + .btf = btf, >> + .jw = btf_wtr, >> + .is_plain_text = true, >> + }; >> + >> + do_dump_btf(&d, map_info, key, value); >> + } else { >> + print_entry_plain(map_info, key, value); >> + } >> + num_elems++; >> + } >> + goto out; >> + } >> + >> + /* lookup error handling */ >> + if (map_is_map_of_maps(map_info->type) || >> + map_is_map_of_progs(map_info->type)) >> + goto out; >> + > > nit: why not just return? the goto seems to only do a return anyway, > is this suggested by some coding style? Is it to help the > compiler? I see people do this from time to time.. Thanks for reviewing. I agree, goto and the label isn't needed. I will fix it. -Prashant > > [...] > >> +out: >> + return num_elems; > >