From mboxrd@z Thu Jan 1 00:00:00 1970 From: Daniel Borkmann Subject: Re: [PATCH net-next,v2] net: rename ndo_setup_tc to ndo_setup_offload Date: Fri, 20 Jul 2018 19:28:23 +0200 Message-ID: <6aea27f3-4ce1-135e-e753-66965f50c5cb@iogearbox.net> References: Mime-Version: 1.0 Content-Type: text/plain; charset=utf-8 Content-Transfer-Encoding: 7bit Cc: netdev , =?UTF-8?B?SmnFmcOtIFDDrXJrbw==?= , thomas.lendacky@amd.com, Florian Fainelli , "Elior, Ariel" , Michael Chan , Santosh Rastapur , madalin.bucur@nxp.com, yisen.zhuang@huawei.com, salil.mehta@huawei.com, Jeff Kirsher , tariqt@mellanox.com, Saeed Mahameed , Jiri Pirko , Ido Schimmel , Ganesh GR , Jakub Kicinski , linux-net-drivers@solarflare.com, peppe.cavallaro@st.com, alexandre.torgue@st.com, joabreu@synopsys.com, grygorii.strashko@ti.com, Andrew Lunn , Vivien D To: Roopa Prabhu , Pablo Neira Ayuso Return-path: Received: from www62.your-server.de ([213.133.104.62]:42730 "EHLO www62.your-server.de" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1733128AbeGTSR5 (ORCPT ); Fri, 20 Jul 2018 14:17:57 -0400 In-Reply-To: Content-Language: en-US Sender: netdev-owner@vger.kernel.org List-ID: On 07/20/2018 04:37 PM, Roopa Prabhu wrote: > On Wed, Jul 18, 2018 at 5:11 PM, Pablo Neira Ayuso wrote: >> One of the recurring complaints is that we do not have, as a driver >> writer, a central location from which we would be fed offloading rules >> into a NIC. This was brought up again during Netconf'18 in Boston. >> >> This patch just renames ndo_setup_tc to ndo_setup_offload as a very >> early initial work to prepare for follow up patch that discuss unified >> flow representation for the existing offload programming APIs. >> >> Signed-off-by: Pablo Neira Ayuso >> Acked-by: Jiri Pirko >> Acked-by: Jakub Kicinski > > ok with a rename,...but this seems to be going from a very specific to > a completely generic name. > maybe ndo_setup_flow_offload or ndo_setup_rule_offload might be better ?. This might be fine as new ndo depending on the use case this will have (?), but fwiw the term 'flow' or 'rule' would be misleading for what tc offload would be doing today (e.g. to name one, there's no notion of 'flow' in BPF offload). Given today this interface is deeply baked into tc, just a rename might not suffice but should probably move the whole handling around it such as assembling the offload info into generic net/core/netdev.c as well if this is the way to go. > (or maybe i am missing some context and this is really for setting up > every possible hardware offload ?)