From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: from mail-pf0-f196.google.com ([209.85.192.196]:33393 "EHLO mail-pf0-f196.google.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1751320AbeCTR1W (ORCPT ); Tue, 20 Mar 2018 13:27:22 -0400 Received: by mail-pf0-f196.google.com with SMTP id 123so914458pfe.0 for ; Tue, 20 Mar 2018 10:27:22 -0700 (PDT) Subject: Re: [PATCH net-next] fib_rules: rename FRA_PROTOCOL to FRA_ORIGINATOR To: Nicolas Dichtel , davem@davemloft.net Cc: netdev@vger.kernel.org, Donald Sharp References: <20180320170453.27577-1-nicolas.dichtel@6wind.com> From: David Ahern Message-ID: <73742889-4982-410f-2128-82dcd85f1147@gmail.com> Date: Tue, 20 Mar 2018 11:27:19 -0600 MIME-Version: 1.0 In-Reply-To: <20180320170453.27577-1-nicolas.dichtel@6wind.com> Content-Type: text/plain; charset=utf-8 Content-Language: en-US Content-Transfer-Encoding: 7bit Sender: netdev-owner@vger.kernel.org List-ID: On 3/20/18 11:04 AM, Nicolas Dichtel wrote: > As the comment said, this attribute defines the originator of the rule, > it's not really a (network) protocol. > Let's rename it accordingly to avoid confusion (difference between > FRA_PROTOCOL and FRA_IP_PROTO was not obvious). > > CC: Donald Sharp > Signed-off-by: Nicolas Dichtel > --- > > FRA_PROTOCOL exists only in net-next for now, thus it's still possible to > rename it. > > drivers/net/vrf.c | 4 ++-- > include/net/fib_rules.h | 4 ++-- > include/uapi/linux/fib_rules.h | 2 +- > net/core/fib_rules.c | 14 +++++++------- > 4 files changed, 12 insertions(+), 12 deletions(-) > > This protocol is meant to be analogous to rtm_protocol. Changing the name to FRA_ORIGINATOR loses that connection.