From mboxrd@z Thu Jan 1 00:00:00 1970 From: Heiner Kallweit Subject: [PATCH net-next 0/8] r8169: further improvements w/o functional change Date: Sat, 28 Apr 2018 22:06:02 +0200 Message-ID: <9b5f541e-8725-46ca-4466-0c3295229252@gmail.com> Mime-Version: 1.0 Content-Type: text/plain; charset=utf-8 Content-Transfer-Encoding: 7bit Cc: "netdev@vger.kernel.org" To: David Miller , Realtek linux nic maintainers Return-path: Received: from mail-wr0-f182.google.com ([209.85.128.182]:46385 "EHLO mail-wr0-f182.google.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1751310AbeD1UGJ (ORCPT ); Sat, 28 Apr 2018 16:06:09 -0400 Received: by mail-wr0-f182.google.com with SMTP id o2-v6so1760852wrj.13 for ; Sat, 28 Apr 2018 13:06:08 -0700 (PDT) Sender: netdev-owner@vger.kernel.org List-ID: This series aims at further improving and simplifying the code w/o any intended functional changes. Series was tested on: RTL8169sb, RTL8168d, RTL8168e-vl Heiner Kallweit (8): r8169: remove unneeded call to __rtl8169_set_features in rtl_open r8169: improve rtl8169_set_features r8169: replace magic number for INTT mask with a constant r8169: improve CPlusCmd handling r8169: improve handling of CPCMD quirk mask r8169: simplify rtl_hw_start_8169 r8169: remove calls to rtl_set_rx_mode r8169: move common initializations to tp->hw_start drivers/net/ethernet/realtek/r8169.c | 184 ++++++--------------------- 1 file changed, 42 insertions(+), 142 deletions(-) -- 2.17.0