From: "Théo Lebrun" <theo.lebrun@bootlin.com>
To: "Conor Dooley" <conor@kernel.org>,
"Vineeth Karumanchi" <vineeth.karumanchi@amd.com>
Cc: <conor.dooley@microchip.com>, <andrew+netdev@lunn.ch>,
<davem@davemloft.net>, <edumazet@google.com>, <kuba@kernel.org>,
<pabeni@redhat.com>, <git@amd.com>, <netdev@vger.kernel.org>,
<linux-kernel@vger.kernel.org>
Subject: Re: [PATCH net-next 1/4] net: macb: Rename MACB_CAPS_QBV to MACB_CAPS_TC
Date: Fri, 07 Aug 2026 20:26:28 +0200 [thread overview]
Message-ID: <DKIX8UXQE9AW.3V3Y8P4USSJDR@bootlin.com> (raw)
In-Reply-To: <20260807-juggle-porcupine-71281d2d9041@spud>
Hello Vineeth & Conor,
On Fri Aug 7, 2026 at 7:09 PM CEST, Conor Dooley wrote:
> On Fri, Aug 07, 2026 at 03:20:09PM +0530, Vineeth Karumanchi wrote:
>> The MACB_CAPS_QBV capability flag was originally introduced to
>> gate TAPRIO/QBV support. However, GEM IP versions that support
>> QBV also implement multiple TSN clauses.
>>
>> Replace this with a generic capability flag that can be reused
>> by other TSN features. Rename MACB_CAPS_QBV to MACB_CAPS_TC to
>> better reflect its role as a general traffic-class offload capability.
>
> I'm not convinced that this is broadly correct, whether or not there's
> Qav support (which is what you're using the newly renamed flag for)
> depends on an IP configuration time define that I think is independent
> of whether or not there's Qbv support (gem_exclude_cbs).
>
> That said, the only platform that supports Qbv that I have the exact
> documentation for does not disable the CBS bits.
EyeQ5 instances have both active qbv and cbs as well.
I see two ways forward:
- MACB_CAPS_TC aggregating the two, coming from match data
- split and use runtime-detection, see DCFG1/0x0280 bits 1 and 24
What I like with 1 is that when reading code it's easy to see what
platform can use what features.
What I like with 2 is that it's less churn overall: no modification of
match data once support is merged.
I guess let's go with 2?
(I'll review the rest of the series later on.)
Thanks,
--
Théo Lebrun, Bootlin
Embedded Linux and Kernel engineering
https://bootlin.com
next prev parent reply other threads:[~2026-08-07 18:26 UTC|newest]
Thread overview: 8+ messages / expand[flat|nested] mbox.gz Atom feed top
2026-08-07 9:50 [PATCH net-next 0/4] net: macb: Add TSN MQPRIO and CBS traffic-class offload Vineeth Karumanchi
2026-08-07 9:50 ` [PATCH net-next 1/4] net: macb: Rename MACB_CAPS_QBV to MACB_CAPS_TC Vineeth Karumanchi
2026-08-07 17:09 ` Conor Dooley
2026-08-07 18:26 ` Théo Lebrun [this message]
2026-08-07 9:50 ` [PATCH net-next 2/4] net: macb: Move TC capability and PM checks to macb_setup_tc() Vineeth Karumanchi
2026-08-07 9:50 ` [PATCH net-next 3/4] net: macb: Add MQPRIO qdisc hardware offload support Vineeth Karumanchi
2026-08-07 9:50 ` [PATCH net-next 4/4] net: macb: Add TSN CBS TC " Vineeth Karumanchi
2026-08-07 17:32 ` Conor Dooley
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=DKIX8UXQE9AW.3V3Y8P4USSJDR@bootlin.com \
--to=theo.lebrun@bootlin.com \
--cc=andrew+netdev@lunn.ch \
--cc=conor.dooley@microchip.com \
--cc=conor@kernel.org \
--cc=davem@davemloft.net \
--cc=edumazet@google.com \
--cc=git@amd.com \
--cc=kuba@kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=netdev@vger.kernel.org \
--cc=pabeni@redhat.com \
--cc=vineeth.karumanchi@amd.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox