From: Gregory Herrero <gregory.herrero@oracle.com>
To: "Creeley, Brett" <bcreeley@amd.com>
Cc: aleksandr.loktionov@intel.com, anthony.l.nguyen@intel.com,
przemyslaw.kitszel@intel.com, andrew+netdev@lunn.ch,
davem@davemloft.net, edumazet@google.com, kuba@kernel.org,
pabeni@redhat.com, intel-wired-lan@lists.osuosl.org,
netdev@vger.kernel.org, linux-kernel@vger.kernel.org
Subject: Re: [PATCH v4 1/1] i40e: validate ring_len parameter against hardware-specific values
Date: Fri, 12 Dec 2025 21:22:22 +0100 [thread overview]
Message-ID: <aTx5fiC_YCFF-iD3@oracle> (raw)
In-Reply-To: <ad274880-8736-459b-ac9e-fac2477b44ea@amd.com>
On Fri, Dec 12, 2025 at 09:37:20AM -0800, Creeley, Brett wrote:
>
> On 11/17/2025 12:33 AM, gregory.herrero@oracle.com wrote:
> > Caution: This message originated from an External Source. Use proper caution when opening attachments, clicking links, or responding.
> >
> >
> > From: Gregory Herrero <gregory.herrero@oracle.com>
> >
> > The maximum number of descriptors supported by the hardware is hardware
> > dependent and can be retrieved using i40e_get_max_num_descriptors().
> > Move this function to a shared header and use it when checking for valid
> > ring_len parameter rather than using hardcoded value.
> >
> > By fixing an over-acceptance issue, behavior change could be seen where
> > ring_len could now be rejected while configuring rx and tx queues if its
> > size is larger than the hardware-specific maximum number of descriptors.
> >
> > Fixes: 55d225670def ("i40e: add validation for ring_len param")
> > Signed-off-by: Gregory Herrero <gregory.herrero@oracle.com>
> > ---
> > drivers/net/ethernet/intel/i40e/i40e.h | 18 ++++++++++++++++++
> > drivers/net/ethernet/intel/i40e/i40e_ethtool.c | 12 ------------
> > .../net/ethernet/intel/i40e/i40e_virtchnl_pf.c | 4 ++--
> > 3 files changed, 20 insertions(+), 14 deletions(-)
> >
> > diff --git a/drivers/net/ethernet/intel/i40e/i40e.h b/drivers/net/ethernet/intel/i40e/i40e.h
> > index 801a57a925da..5b367397ae43 100644
> > --- a/drivers/net/ethernet/intel/i40e/i40e.h
> > +++ b/drivers/net/ethernet/intel/i40e/i40e.h
> > @@ -1418,4 +1418,22 @@ static inline struct i40e_veb *i40e_pf_get_main_veb(struct i40e_pf *pf)
> > return (pf->lan_veb != I40E_NO_VEB) ? pf->veb[pf->lan_veb] : NULL;
> > }
> >
> > +/**
> > + * i40e_get_max_num_descriptors - get maximum number of descriptors for this
> > + * hardware.
> > + * @pf: pointer to a PF
> > + *
> > + * Return: u32 value corresponding to the maximum number of descriptors.
> > + **/
>
> Nit, but the function name is descriptive enough without the documentation.
>
> I think the purpose of the function would be even more obvious if the
> argument was a pointer to the hw structure instead of a pointer to the pf
> since the max is based on the hw not the pf.
>
I agree, it's just that it will require changing the 5 callers of this
function and invalidate the testing from Rafal Romanowski.
Please let me know what you think, I can wait before sending v5.
Thanks,
Gregory
> > +static inline u32 i40e_get_max_num_descriptors(const struct i40e_pf *pf)
> > +{
> > + const struct i40e_hw *hw = &pf->hw;
> > +
> > + switch (hw->mac.type) {
> > + case I40E_MAC_XL710:
> > + return I40E_MAX_NUM_DESCRIPTORS_XL710;
> > + default:
> > + return I40E_MAX_NUM_DESCRIPTORS;
> > + }
> > +}
> > #endif /* _I40E_H_ */
> > diff --git a/drivers/net/ethernet/intel/i40e/i40e_ethtool.c b/drivers/net/ethernet/intel/i40e/i40e_ethtool.c
> > index 86c72596617a..61c39e881b00 100644
> > --- a/drivers/net/ethernet/intel/i40e/i40e_ethtool.c
> > +++ b/drivers/net/ethernet/intel/i40e/i40e_ethtool.c
> > @@ -2013,18 +2013,6 @@ static void i40e_get_drvinfo(struct net_device *netdev,
> > drvinfo->n_priv_flags += I40E_GL_PRIV_FLAGS_STR_LEN;
> > }
> >
> > -static u32 i40e_get_max_num_descriptors(struct i40e_pf *pf)
> > -{
> > - struct i40e_hw *hw = &pf->hw;
> > -
> > - switch (hw->mac.type) {
> > - case I40E_MAC_XL710:
> > - return I40E_MAX_NUM_DESCRIPTORS_XL710;
> > - default:
> > - return I40E_MAX_NUM_DESCRIPTORS;
> > - }
> > -}
> > -
> > static void i40e_get_ringparam(struct net_device *netdev,
> > struct ethtool_ringparam *ring,
> > struct kernel_ethtool_ringparam *kernel_ring,
> > diff --git a/drivers/net/ethernet/intel/i40e/i40e_virtchnl_pf.c b/drivers/net/ethernet/intel/i40e/i40e_virtchnl_pf.c
> > index 081a4526a2f0..cf831c649c9c 100644
> > --- a/drivers/net/ethernet/intel/i40e/i40e_virtchnl_pf.c
> > +++ b/drivers/net/ethernet/intel/i40e/i40e_virtchnl_pf.c
> > @@ -656,7 +656,7 @@ static int i40e_config_vsi_tx_queue(struct i40e_vf *vf, u16 vsi_id,
> >
> > /* ring_len has to be multiple of 8 */
> > if (!IS_ALIGNED(info->ring_len, 8) ||
> > - info->ring_len > I40E_MAX_NUM_DESCRIPTORS_XL710) {
> > + info->ring_len > i40e_get_max_num_descriptors(pf)) {
> > ret = -EINVAL;
> > goto error_context;
> > }
> > @@ -726,7 +726,7 @@ static int i40e_config_vsi_rx_queue(struct i40e_vf *vf, u16 vsi_id,
> >
> > /* ring_len has to be multiple of 32 */
> > if (!IS_ALIGNED(info->ring_len, 32) ||
> > - info->ring_len > I40E_MAX_NUM_DESCRIPTORS_XL710) {
> > + info->ring_len > i40e_get_max_num_descriptors(pf)) {
> > ret = -EINVAL;
> > goto error_param;
> > }
> > --
> > 2.51.0
> >
> >
next prev parent reply other threads:[~2025-12-12 20:28 UTC|newest]
Thread overview: 8+ messages / expand[flat|nested] mbox.gz Atom feed top
2025-11-17 8:33 [PATCH v4 0/1] i40e: additional safety check gregory.herrero
2025-11-17 8:33 ` [PATCH v4 1/1] i40e: validate ring_len parameter against hardware-specific values gregory.herrero
2025-11-17 11:58 ` Loktionov, Aleksandr
2025-12-11 8:38 ` Romanowski, Rafal
2025-12-12 20:20 ` Gregory Herrero
2025-12-12 17:37 ` Creeley, Brett
2025-12-12 20:22 ` Gregory Herrero [this message]
2025-12-12 20:45 ` Creeley, Brett
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=aTx5fiC_YCFF-iD3@oracle \
--to=gregory.herrero@oracle.com \
--cc=aleksandr.loktionov@intel.com \
--cc=andrew+netdev@lunn.ch \
--cc=anthony.l.nguyen@intel.com \
--cc=bcreeley@amd.com \
--cc=davem@davemloft.net \
--cc=edumazet@google.com \
--cc=intel-wired-lan@lists.osuosl.org \
--cc=kuba@kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=netdev@vger.kernel.org \
--cc=pabeni@redhat.com \
--cc=przemyslaw.kitszel@intel.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox