From: "Lorenzo Stoakes (ARM)" <ljs@kernel.org>
To: Suren Baghdasaryan <surenb@google.com>
Cc: akpm@linux-foundation.org, dave.hansen@linux.intel.com,
Liam.Howlett@oracle.com, david@redhat.com, willy@infradead.org,
shakeel.butt@linux.dev, vbabka@kernel.org, jannh@google.com,
aliceryhl@google.com, arve@android.com, cmllamas@google.com,
christian@brauner.io, tkjos@android.com, dsahern@kernel.org,
davem@davemloft.net, gregkh@linuxfoundation.org,
linux-kernel@vger.kernel.org, linux-mm@kvack.org,
netdev@vger.kernel.org
Subject: Re: [PATCH v3 3/5] mm: Add RCU-based VMA lookup helper that waits for writers
Date: Tue, 4 Aug 2026 09:47:09 +0100 [thread overview]
Message-ID: <anGmhgqk-HjhejJL@lucifer> (raw)
In-Reply-To: <CAJuCfpGXk8jfRrJ=JwMLvpzxbNnzJUOYRHfWUX5e4vgP5j72Og@mail.gmail.com>
On Mon, Aug 03, 2026 at 12:01:21PM -0700, Suren Baghdasaryan wrote:
> On Mon, Aug 3, 2026 at 4:28 AM Lorenzo Stoakes (ARM) <ljs@kernel.org> wrote:
> > >
> >
> > Would be nice to have a:
> >
> > Suggested-by: Lorenzo Stoakes (ARM) <ljs@kernel.org>
>
> Ack.
Thanks!
>
> >
> > Here given https://lore.kernel.org/linux-mm/af4Zx0gJIWbdDeY2@lucifer/ :)
> >
> > > diff --git a/mm/mmap_lock.c b/mm/mmap_lock.c
> > > index e20d01e8d38f..6ff05e68e61b 100644
> > > --- a/mm/mmap_lock.c
> > > +++ b/mm/mmap_lock.c
> > > @@ -338,6 +338,35 @@ struct vm_area_struct *lock_vma_under_rcu(struct mm_struct *mm,
> > > return NULL;
> > > }
> > >
> > > +/*
> >
> > Why not a kdoc comment?
>
> Indeed. Will change.
Thanks!
>
> >
> > > + * Find the VMA covering 'address' and lock it for reading. Waits for writers to
> > > + * finish if the VMA is being modified. Returns NULL if there is no VMA covering
> > > + * 'address'.
> > > + *
> > > + * Use only in code paths where no mmap_lock and no VMA lock is held.
> >
> > Well, a VMA read lock can be held which would make this a noop essentially.
> >
> > If a VMA write lock is held you're also ok as the mmap read lock will preclude
> > an mmap write lock, meaning vma_end_write_all() will have been called and the
> > write lock released.
> >
> > So I think you can just drop this line?
>
> Maybe instead of this I should say: Use when mmap_lock is not held,
> otherwise use vma_start_read_locked() ? I think that was the original
> reason for this comment.
Yeah that works thanks!
>
> >
> > > + *
> > > + * The fast path does not take mmap_lock.
> > > + */
> > > +struct vm_area_struct *vma_start_read_unlocked(struct mm_struct *mm,
> > > + unsigned long address)
> > > +{
> > > + struct vm_area_struct *vma;
> > > +
> > > + /* Fast path: return stable VMA covering 'address': */
> > > + vma = lock_vma_under_rcu(mm, address);
> > > + if (vma)
> > > + return vma;
> > > +
> > > + /* Slow path: preclude VMA writers by temporarily getting mmap read lock. */
> > > + mmap_read_lock(mm);
> > > + vma = vma_lookup(mm, address);
> > > + if (vma && !vma_start_read_locked(vma))
> >
> > This maybe warrants an unlikely() given it can only happen if refcount
> > overflows? Also worth having a comment to that effect here?
>
> vma_start_read_locked()
> vma_start_read_locked()
> vma_start_read_locked_nested()
> unlikely(!__refcount_inc_not_zero_limited_acquire())
>
> already contains "unlikely" clause. Do we need to add it in all its users?
> I can modify the comment for vma_start_read_locked() stating that
> refcount overflow is very unlikely. Would that work or do you want
> callers to have that too?
Ah ok not an issue then. But good to add a comment at least?
> > > diff --git a/mm/userfaultfd.c b/mm/userfaultfd.c
> > > index edd90892f8cc..c3a0c38a3dc3 100644
> > > --- a/mm/userfaultfd.c
> > > +++ b/mm/userfaultfd.c
> > > @@ -129,8 +129,10 @@ struct vm_area_struct *find_vma_and_prepare_anon(struct mm_struct *mm,
> > > *
> > > * Should be called without holding mmap_lock.
> > > *
> > > - * Return: A locked vma containing @address, -ENOENT if no vma is found, or
> > > - * -ENOMEM if anon_vma couldn't be allocated.
> > > + * Return: A locked vma containing @address, -ENOENT if no vma is found,
> > > + * -ENOMEM if anon_vma couldn't be allocated, or -EAGAIN if vma refcount
> > > + * overflow happened due to high number of readers and the caller should
> > > + * retry later.
> >
> > I'm guessing you're fixing this up as part of the patch? But it feels a bit
> > random, I mean fine but you should mention this change in the commit message +
> > explain why.
>
> I'm fixing that because Vlastimil asked about these inconsistencies in
> his previous review :)
> I can package these fixes as a separate patch or add a comment in the
> changelog, smth like "While at it, fix the comments for related
> functions". Would that work?
Comment in change log is fine thanks!
--
Cheers, Lorenzo
next prev parent reply other threads:[~2026-08-04 8:47 UTC|newest]
Thread overview: 48+ messages / expand[flat|nested] mbox.gz Atom feed top
2026-08-02 21:54 [PATCH v3 0/5] mm: Unconditional per-VMA locks and cleanups Suren Baghdasaryan
2026-08-02 21:54 ` [PATCH v3 1/5] mm: Make per-VMA locks available universally Suren Baghdasaryan
2026-08-03 10:49 ` Lorenzo Stoakes (ARM)
2026-08-03 14:01 ` Vlastimil Babka (SUSE)
2026-08-03 17:45 ` Suren Baghdasaryan
2026-08-03 15:24 ` Suren Baghdasaryan
2026-08-03 16:08 ` Lorenzo Stoakes (ARM)
2026-08-03 17:41 ` Suren Baghdasaryan
2026-08-03 17:45 ` Suren Baghdasaryan
2026-08-03 21:12 ` Jann Horn
2026-08-04 8:56 ` Lorenzo Stoakes (ARM)
2026-08-04 14:59 ` Suren Baghdasaryan
2026-08-03 19:33 ` Jann Horn
2026-08-03 19:43 ` Suren Baghdasaryan
2026-08-02 21:54 ` [PATCH v3 2/5] binder: Make shrinker rely solely on per-VMA lock Suren Baghdasaryan
2026-08-03 9:48 ` Alice Ryhl
2026-08-03 10:50 ` Lorenzo Stoakes (ARM)
2026-08-03 11:11 ` Lorenzo Stoakes (ARM)
2026-08-03 11:33 ` Lorenzo Stoakes (ARM)
2026-08-03 18:02 ` Suren Baghdasaryan
2026-08-04 9:15 ` Lorenzo Stoakes (ARM)
2026-08-03 11:10 ` Lorenzo Stoakes (ARM)
2026-08-03 18:31 ` Suren Baghdasaryan
2026-08-04 9:08 ` Lorenzo Stoakes (ARM)
2026-08-04 9:04 ` Alice Ryhl
2026-08-04 9:11 ` Lorenzo Stoakes (ARM)
2026-08-04 14:54 ` Suren Baghdasaryan
2026-08-02 21:54 ` [PATCH v3 3/5] mm: Add RCU-based VMA lookup helper that waits for writers Suren Baghdasaryan
2026-08-03 11:28 ` Lorenzo Stoakes (ARM)
2026-08-03 19:01 ` Suren Baghdasaryan
2026-08-04 8:47 ` Lorenzo Stoakes (ARM) [this message]
2026-08-04 15:00 ` Suren Baghdasaryan
2026-08-03 14:55 ` Vlastimil Babka (SUSE)
2026-08-03 15:00 ` Lorenzo Stoakes (ARM)
2026-08-03 16:24 ` Vlastimil Babka (SUSE)
2026-08-03 16:43 ` Lorenzo Stoakes (ARM)
2026-08-03 19:13 ` Suren Baghdasaryan
2026-08-04 7:59 ` Vlastimil Babka (SUSE)
2026-08-04 8:44 ` Lorenzo Stoakes (ARM)
2026-08-02 21:54 ` [PATCH v3 4/5] binder: Remove mmap_lock fallback Suren Baghdasaryan
2026-08-03 10:34 ` Alice Ryhl
2026-08-03 19:14 ` Suren Baghdasaryan
2026-08-03 11:33 ` Lorenzo Stoakes (ARM)
2026-08-03 19:16 ` Suren Baghdasaryan
2026-08-02 21:54 ` [PATCH v3 5/5] tcp: Remove mmap_lock fallback path Suren Baghdasaryan
2026-08-03 2:11 ` [PATCH v3 0/5] mm: Unconditional per-VMA locks and cleanups Barry Song
2026-08-03 17:51 ` Suren Baghdasaryan
2026-08-04 9:27 ` Lorenzo Stoakes (ARM)
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=anGmhgqk-HjhejJL@lucifer \
--to=ljs@kernel.org \
--cc=Liam.Howlett@oracle.com \
--cc=akpm@linux-foundation.org \
--cc=aliceryhl@google.com \
--cc=arve@android.com \
--cc=christian@brauner.io \
--cc=cmllamas@google.com \
--cc=dave.hansen@linux.intel.com \
--cc=davem@davemloft.net \
--cc=david@redhat.com \
--cc=dsahern@kernel.org \
--cc=gregkh@linuxfoundation.org \
--cc=jannh@google.com \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-mm@kvack.org \
--cc=netdev@vger.kernel.org \
--cc=shakeel.butt@linux.dev \
--cc=surenb@google.com \
--cc=tkjos@android.com \
--cc=vbabka@kernel.org \
--cc=willy@infradead.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox