From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: from mail-pf0-f196.google.com ([209.85.192.196]:39594 "EHLO mail-pf0-f196.google.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1752105AbeCUPAR (ORCPT ); Wed, 21 Mar 2018 11:00:17 -0400 Received: by mail-pf0-f196.google.com with SMTP id u5so2070186pfh.6 for ; Wed, 21 Mar 2018 08:00:17 -0700 (PDT) Subject: Re: [PATCH net-next] fib_rules: rename FRA_PROTOCOL to FRA_ORIGINATOR To: nicolas.dichtel@6wind.com, davem@davemloft.net Cc: netdev@vger.kernel.org, Donald Sharp References: <20180320170453.27577-1-nicolas.dichtel@6wind.com> <73742889-4982-410f-2128-82dcd85f1147@gmail.com> <74299bf5-ea7f-eaa9-25de-fd485fd6f9ad@6wind.com> From: David Ahern Message-ID: Date: Wed, 21 Mar 2018 09:00:09 -0600 MIME-Version: 1.0 In-Reply-To: <74299bf5-ea7f-eaa9-25de-fd485fd6f9ad@6wind.com> Content-Type: text/plain; charset=utf-8 Content-Language: en-US Content-Transfer-Encoding: 8bit Sender: netdev-owner@vger.kernel.org List-ID: On 3/21/18 3:24 AM, Nicolas Dichtel wrote: > Le 20/03/2018 à 18:27, David Ahern a écrit : >> On 3/20/18 11:04 AM, Nicolas Dichtel wrote: >>> As the comment said, this attribute defines the originator of the rule, >>> it's not really a (network) protocol. >>> Let's rename it accordingly to avoid confusion (difference between >>> FRA_PROTOCOL and FRA_IP_PROTO was not obvious). >>> >>> CC: Donald Sharp >>> Signed-off-by: Nicolas Dichtel >>> --- >>> >>> FRA_PROTOCOL exists only in net-next for now, thus it's still possible to >>> rename it. >>> >>> drivers/net/vrf.c | 4 ++-- >>> include/net/fib_rules.h | 4 ++-- >>> include/uapi/linux/fib_rules.h | 2 +- >>> net/core/fib_rules.c | 14 +++++++------- >>> 4 files changed, 12 insertions(+), 12 deletions(-) >>> >>> >> >> This protocol is meant to be analogous to rtm_protocol. Changing the >> name to FRA_ORIGINATOR loses that connection. > I understand your concerns. But I think the connection still exists after the > patch because the values used for this field are RTPROT_* > rtm_protocol is here from ages and we cannot change that. Moreover, FRA_* > attributes are usually used as a selector or a target, which is not the case for > a route. Thus I think it's important to carrefully choose the name. The rule->proto value is not used as a selector. It is passed in, stored on a rule and returned to userspace. It is book keeping only so an admin has some idea of which program installed the rule.