From: Matthieu Baerts <matttbe@kernel.org>
To: Eric Dumazet <edumazet@google.com>
Cc: Simon Horman <horms@kernel.org>,
Neal Cardwell <ncardwell@google.com>,
Kuniyuki Iwashima <kuniyu@google.com>,
Mat Martineau <martineau@kernel.org>,
Geliang Tang <geliang@kernel.org>,
netdev@vger.kernel.org, eric.dumazet@gmail.com,
"David S . Miller" <davem@davemloft.net>,
Jakub Kicinski <kuba@kernel.org>, Paolo Abeni <pabeni@redhat.com>
Subject: Re: [PATCH net-next 0/4] tcp: provide better locality for retransmit timer
Date: Wed, 26 Nov 2025 12:23:09 +0100 [thread overview]
Message-ID: <d5760f10-829d-4e0f-b755-1c651c1e1c42@kernel.org> (raw)
In-Reply-To: <20251124175013.1473655-1-edumazet@google.com>
Hi Eric,
On 24/11/2025 18:50, Eric Dumazet wrote:
> TCP stack uses three timers per flow, currently spread this way:
>
> - sk->sk_timer : keepalive timer
> - icsk->icsk_retransmit_timer : retransmit timer
> - icsk->icsk_delack_timer : delayed ack timer
>
> This series moves the retransmit timer to sk->sk_timer location,
> to increase data locality in TX paths.
>
> keepalive timers are not often used, this change should be neutral for them.
>
> After the series we have following fields:
>
> - sk->tcp_retransmit_timer : retransmit timer, in sock_write_tx group
> - icsk->icsk_delack_timer : delayed ack timer
> - icsk->icsk_keepalive_timer : keepalive timer
>
> Moving icsk_delack_timer in a beter location would also be welcomed.
Sorry for the delay, I didn't manage to look at it yesterday. I just
wanted to say thank you for this series, and for having adapted MPTCP as
well!
Just in case, even if the series has already been applied:
Acked-by: Matthieu Baerts (NGI0) <matttbe@kernel.org>
Cheers,
Matt
--
Sponsored by the NGI0 Core fund.
next prev parent reply other threads:[~2025-11-26 11:23 UTC|newest]
Thread overview: 12+ messages / expand[flat|nested] mbox.gz Atom feed top
2025-11-24 17:50 [PATCH net-next 0/4] tcp: provide better locality for retransmit timer Eric Dumazet
2025-11-24 17:50 ` [PATCH net-next 1/4] tcp: rename icsk_timeout() to tcp_timeout_expires() Eric Dumazet
2025-11-25 23:59 ` Kuniyuki Iwashima
2025-11-24 17:50 ` [PATCH net-next 2/4] net: move sk_dst_pending_confirm and sk_pacing_status to sock_read_tx group Eric Dumazet
2025-11-26 0:02 ` Kuniyuki Iwashima
2025-11-24 17:50 ` [PATCH net-next 3/4] tcp: introduce icsk->icsk_keepalive_timer Eric Dumazet
2025-11-26 0:06 ` Kuniyuki Iwashima
2025-11-24 17:50 ` [PATCH net-next 4/4] tcp: remove icsk->icsk_retransmit_timer Eric Dumazet
2025-11-26 0:10 ` Kuniyuki Iwashima
2025-11-26 4:00 ` [PATCH net-next 0/4] tcp: provide better locality for retransmit timer patchwork-bot+netdevbpf
2025-11-26 11:23 ` Matthieu Baerts [this message]
2025-11-26 11:27 ` Eric Dumazet
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=d5760f10-829d-4e0f-b755-1c651c1e1c42@kernel.org \
--to=matttbe@kernel.org \
--cc=davem@davemloft.net \
--cc=edumazet@google.com \
--cc=eric.dumazet@gmail.com \
--cc=geliang@kernel.org \
--cc=horms@kernel.org \
--cc=kuba@kernel.org \
--cc=kuniyu@google.com \
--cc=martineau@kernel.org \
--cc=ncardwell@google.com \
--cc=netdev@vger.kernel.org \
--cc=pabeni@redhat.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox