Netdev List
 help / color / mirror / Atom feed
From: Daniel Borkmann <daniel@iogearbox.net>
To: Krzesimir Nowak <krzesimir@kinvolk.io>,
	Andrii Nakryiko <andrii.nakryiko@gmail.com>
Cc: Andrii Nakryiko <andriin@fb.com>,
	Kernel Team <kernel-team@fb.com>, Alexei Starovoitov <ast@fb.com>,
	bpf <bpf@vger.kernel.org>, Networking <netdev@vger.kernel.org>
Subject: Re: [PATCH bpf-next] selftests/bpf: remove logic duplication in test_verifier.c
Date: Fri, 12 Jul 2019 15:57:02 +0200	[thread overview]
Message-ID: <d6ff6022-56f7-de63-d3e1-8949360296ca@iogearbox.net> (raw)
In-Reply-To: <CAGGp+cHaV1EMXqeQvKN-p5gEZWcSgGfcbKimcS+C8u=dfeU=1Q@mail.gmail.com>

On 07/12/2019 09:53 AM, Krzesimir Nowak wrote:
> On Thu, Jul 11, 2019 at 4:43 PM Andrii Nakryiko
> <andrii.nakryiko@gmail.com> wrote:
>>
>> On Thu, Jul 11, 2019 at 5:13 AM Krzesimir Nowak <krzesimir@kinvolk.io> wrote:
>>>
>>> On Thu, Jul 11, 2019 at 3:08 AM Andrii Nakryiko <andriin@fb.com> wrote:
>>>>
>>>> test_verifier tests can specify single- and multi-runs tests. Internally
>>>> logic of handling them is duplicated. Get rid of it by making single run
>>>> retval specification to be a first retvals spec.
>>>>
>>>> Cc: Krzesimir Nowak <krzesimir@kinvolk.io>
>>>> Signed-off-by: Andrii Nakryiko <andriin@fb.com>
>>>
>>> Looks good, one nit below.
>>>
>>> Acked-by: Krzesimir Nowak <krzesimir@kinvolk.io>
>>>
>>>> ---
>>>>  tools/testing/selftests/bpf/test_verifier.c | 37 ++++++++++-----------
>>>>  1 file changed, 18 insertions(+), 19 deletions(-)
>>>>
>>>> diff --git a/tools/testing/selftests/bpf/test_verifier.c b/tools/testing/selftests/bpf/test_verifier.c
>>>> index b0773291012a..120ecdf4a7db 100644
>>>> --- a/tools/testing/selftests/bpf/test_verifier.c
>>>> +++ b/tools/testing/selftests/bpf/test_verifier.c
>>>> @@ -86,7 +86,7 @@ struct bpf_test {
>>>>         int fixup_sk_storage_map[MAX_FIXUPS];
>>>>         const char *errstr;
>>>>         const char *errstr_unpriv;
>>>> -       uint32_t retval, retval_unpriv, insn_processed;
>>>> +       uint32_t insn_processed;
>>>>         int prog_len;
>>>>         enum {
>>>>                 UNDEF,
>>>> @@ -95,16 +95,24 @@ struct bpf_test {
>>>>         } result, result_unpriv;
>>>>         enum bpf_prog_type prog_type;
>>>>         uint8_t flags;
>>>> -       __u8 data[TEST_DATA_LEN];
>>>>         void (*fill_helper)(struct bpf_test *self);
>>>>         uint8_t runs;
>>>> -       struct {
>>>> -               uint32_t retval, retval_unpriv;
>>>> -               union {
>>>> -                       __u8 data[TEST_DATA_LEN];
>>>> -                       __u64 data64[TEST_DATA_LEN / 8];
>>>> +       union {
>>>> +               struct {
>>>
>>> Maybe consider moving the struct definition outside to further the
>>> removal of the duplication?
>>
>> Can't do that because then retval/retval_unpriv/data won't be
>> accessible as a normal field of struct bpf_test. It has to be in
>> anonymous structs/unions, unfortunately.
>>
> 
> Ah, right.
> 
> Meh.
> 
> I tried something like this:
> 
> #define BPF_DATA_STRUCT \
>     struct { \
>         uint32_t retval, retval_unpriv; \
>         union { \
>             __u8 data[TEST_DATA_LEN]; \
>             __u64 data64[TEST_DATA_LEN / 8]; \
>         }; \
>     }
> 
> and then:
> 
>     union {
>         BPF_DATA_STRUCT;
>         BPF_DATA_STRUCT retvals[MAX_TEST_RUNS];
>     };
> 
> And that seems to compile at least. But question is: is this
> acceptably ugly or unacceptably ugly? :)

Both a bit ugly, but I'd have a slight preference towards the above,
perhaps a bit more readable like:

#define bpf_testdata_struct_t                                   \
        struct {                                                \
                uint32_t retval, retval_unpriv;                 \
                union {                                         \
                        __u8 data[TEST_DATA_LEN];               \
                        __u64 data64[TEST_DATA_LEN / 8];        \
                };                                              \
        }
        union {
                bpf_testdata_struct_t;
                bpf_testdata_struct_t retvals[MAX_TEST_RUNS];
        };

Thanks,
Daniel

  reply	other threads:[~2019-07-12 13:57 UTC|newest]

Thread overview: 6+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2019-07-11  1:08 [PATCH bpf-next] selftests/bpf: remove logic duplication in test_verifier.c Andrii Nakryiko
2019-07-11 12:13 ` Krzesimir Nowak
2019-07-11 14:43   ` Andrii Nakryiko
2019-07-12  7:53     ` Krzesimir Nowak
2019-07-12 13:57       ` Daniel Borkmann [this message]
2019-07-12 15:45         ` Andrii Nakryiko

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=d6ff6022-56f7-de63-d3e1-8949360296ca@iogearbox.net \
    --to=daniel@iogearbox.net \
    --cc=andrii.nakryiko@gmail.com \
    --cc=andriin@fb.com \
    --cc=ast@fb.com \
    --cc=bpf@vger.kernel.org \
    --cc=kernel-team@fb.com \
    --cc=krzesimir@kinvolk.io \
    --cc=netdev@vger.kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox