From: Prashant Bhole <bhole_prashant_q7@lab.ntt.co.jp>
To: Mauricio Vasquez <mauricio.vasquez@polito.it>,
Alexei Starovoitov <alexei.starovoitov@gmail.com>
Cc: Alexei Starovoitov <ast@kernel.org>,
Daniel Borkmann <daniel@iogearbox.net>,
Jakub Kicinski <jakub.kicinski@netronome.com>,
Quentin Monnet <quentin.monnet@netronome.com>,
"David S . Miller" <davem@davemloft.net>,
netdev@vger.kernel.org
Subject: Re: [RFC bpf-next 2/4] bpf: return EOPNOTSUPP when map lookup isn't supported
Date: Thu, 20 Sep 2018 11:34:30 +0900 [thread overview]
Message-ID: <ef15f2b1-ae87-56a1-54b1-29ea27637d5b@lab.ntt.co.jp> (raw)
In-Reply-To: <bd05a444-95b0-8573-4bbc-4ce0a10f7042@polito.it>
On 9/20/2018 3:40 AM, Mauricio Vasquez wrote:
>
>
> On 09/19/2018 10:14 AM, Alexei Starovoitov wrote:
>> On Wed, Sep 19, 2018 at 04:51:41PM +0900, Prashant Bhole wrote:
>>> Return ERR_PTR(-EOPNOTSUPP) from map_lookup_elem() methods of below
>>> map types:
>>> - BPF_MAP_TYPE_PROG_ARRAY
>>> - BPF_MAP_TYPE_STACK_TRACE
>>> - BPF_MAP_TYPE_XSKMAP
>>> - BPF_MAP_TYPE_SOCKMAP/BPF_MAP_TYPE_SOCKHASH
>>>
>>> Signed-off-by: Prashant Bhole <bhole_prashant_q7@lab.ntt.co.jp>
>>> ---
>>> kernel/bpf/arraymap.c | 2 +-
>>> kernel/bpf/sockmap.c | 2 +-
>>> kernel/bpf/stackmap.c | 2 +-
>>> kernel/bpf/xskmap.c | 2 +-
>>> 4 files changed, 4 insertions(+), 4 deletions(-)
>>>
>>> diff --git a/kernel/bpf/arraymap.c b/kernel/bpf/arraymap.c
>>> index dded84cbe814..24583da9ffd1 100644
>>> --- a/kernel/bpf/arraymap.c
>>> +++ b/kernel/bpf/arraymap.c
>>> @@ -449,7 +449,7 @@ static void fd_array_map_free(struct bpf_map *map)
>>> static void *fd_array_map_lookup_elem(struct bpf_map *map, void *key)
>>> {
>>> - return NULL;
>>> + return ERR_PTR(-EOPNOTSUPP);
>>> }
>> conceptually the set looks good to me.
>> Please add a test to test_verifier.c to make sure
>> that these lookup helpers cannot be called from BPF program.
>> Otherwise this diff may cause crashes.
>>
>>
> I think we can remove all these stub functions that return EOPNOTSUPP or
> EINVAL and return the error in syscall.c if ops->map_[update, delete,
> lookup, ...] is null.
> This will require to extend (and test) the verifier to guarantee that
> those helpers are not called in wrong maps, for example
> map_delete_element in array like maps.
>
> Would it make sense?
Thanks for review and suggestion.
I had thought about this way too (except adding restrictions in the
verifier). There is no strong reason for choosing current implementation.
I thought there must be some reason that those methods are implemented
and just returning NULL. Also there are no NULL checks for
map_lookup_elem stub. So I decided to simply change the return value.
If some more people agree with removing stub function idea, I will do it.
-Prashant
next prev parent reply other threads:[~2018-09-20 8:16 UTC|newest]
Thread overview: 16+ messages / expand[flat|nested] mbox.gz Atom feed top
2018-09-19 7:51 [RFC bpf-next 0/4] Error handling when map lookup isn't supported Prashant Bhole
2018-09-19 7:51 ` [RFC bpf-next 1/4] bpf: error handling when map_lookup_elem " Prashant Bhole
2018-09-19 7:51 ` [RFC bpf-next 2/4] bpf: return EOPNOTSUPP when map lookup " Prashant Bhole
2018-09-19 15:14 ` Alexei Starovoitov
2018-09-19 18:40 ` Mauricio Vasquez
2018-09-20 2:34 ` Prashant Bhole [this message]
2018-09-20 2:44 ` Prashant Bhole
2018-09-19 7:51 ` [RFC bpf-next 3/4] tools/bpf: bpftool, split the function do_dump() Prashant Bhole
2018-09-19 15:26 ` Jakub Kicinski
2018-09-20 2:49 ` Prashant Bhole
2018-09-19 7:51 ` [RFC bpf-next 4/4] tools/bpf: handle EOPNOTSUPP when map lookup is failed Prashant Bhole
2018-09-19 15:29 ` Jakub Kicinski
2018-09-20 2:58 ` Prashant Bhole
2018-09-20 5:04 ` Prashant Bhole
2018-09-20 15:59 ` Jakub Kicinski
2018-10-02 5:33 ` Prashant Bhole
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=ef15f2b1-ae87-56a1-54b1-29ea27637d5b@lab.ntt.co.jp \
--to=bhole_prashant_q7@lab.ntt.co.jp \
--cc=alexei.starovoitov@gmail.com \
--cc=ast@kernel.org \
--cc=daniel@iogearbox.net \
--cc=davem@davemloft.net \
--cc=jakub.kicinski@netronome.com \
--cc=mauricio.vasquez@polito.it \
--cc=netdev@vger.kernel.org \
--cc=quentin.monnet@netronome.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox