Nouveau Archive on lore.kernel.org
 help / color / mirror / Atom feed
[PATCH resend v5] drm: uapi: Add macro for chipset specific event ID region
 2026-08-03 12:08 UTC 

[PATCH] drm/nouveau/bios/init: drop unneeded semicolon
 2026-08-01 19:09 UTC 

[PATCH 0/2] drm/nouveau/clk: fix RAM error handling and pstate desync in nvkm_pstate_prog
 2026-08-01 12:11 UTC  (4+ messages)
` [PATCH 1/2] drm/nouveau/clk: don't ignore RAM clock programming errors "
` [PATCH 2/2] drm/nouveau/clk: only update clk->pstate after hardware programming succeeds

[PATCH v11 0/8] mm/hmm: Add mmap lock-drop support for userfaultfd-backed mappings
 2026-07-31 21:37 UTC  (15+ messages)
` [PATCH v11 1/8] mm/hmm: move page fault handling out of walk callbacks
` [PATCH v11 2/8] mm/hmm: add hmm_range_fault_unlocked_timeout() for mmap lock-drop support
` [PATCH v11 3/8] selftests/mm: add HMM test for mmap lock-dropping faults
` [PATCH v11 4/8] mshv: Use hmm_range_fault_unlocked_timeout() for region faults
` [PATCH v11 5/8] drm/nouveau: Use hmm_range_fault_unlocked_timeout() for SVM faults
` [PATCH v11 6/8] RDMA/umem: Use hmm_range_fault_unlocked_timeout() for ODP faults
` [PATCH v11 7/8] accel/amdxdna: Use hmm_range_fault_unlocked_timeout() for range population
` [PATCH v11 8/8] drm/gpusvm: Use hmm_range_fault_unlocked_timeout() for range faults

[PATCH v5 0/5] Enable atomic modesetting by default
 2026-07-30 20:45 UTC  (6+ messages)
` [PATCH v5 1/5] drm/nouveau: Fix cleanup bug in nouveau_drm_device_new()
` [PATCH v5 2/5] drm/nouveau: Print the nouveau.atomic parameter in nouveau_display_options()
` [PATCH v5 3/5] drm/nouveau: Fix drm_driver struct/nouveau.atomic parameter handling
` [PATCH v5 4/5] drm/nouveau/kms: Only allow enabling atomic modesetting on nv50+
` [PATCH v5 5/5] drm/nouveau/kms/nv50-: Enable atomic modesetting by default

[PATCH v4 0/5] Enable atomic modesetting by default
 2026-07-30 20:36 UTC  (6+ messages)
` [PATCH v4 1/5] drm/nouveau: Fix cleanup bug in nouveau_drm_device_new()
` [PATCH v4 2/5] drm/nouveau: Print the nouveau.atomic parameter in nouveau_display_options()
` [PATCH v4 3/5] drm/nouveau: Fix drm_driver struct/nouveau.atomic parameter handling
` [PATCH v4 4/5] drm/nouveau/kms: Only allow enabling atomic modesetting on nv50+
` [PATCH v4 5/5] drm/nouveau/kms/nv50-: Enable atomic modesetting by default

[PATCH v3 0/5] Enable atomic modesetting by default
 2026-07-30 20:28 UTC  (6+ messages)
` [PATCH v3 1/5] drm/nouveau: Fix cleanup bug in nouveau_drm_device_new()
` [PATCH v3 2/5] drm/nouveau: Print the nouveau.atomic parameter in nouveau_display_options()
` [PATCH v3 3/5] drm/nouveau: Fix drm_driver struct/nouveau.atomic parameter handling
` [PATCH v3 4/5] drm/nouveau/kms: Only allow enabling atomic modesetting on nv50+
` [PATCH v3 5/5] drm/nouveau/kms/nv50-: Enable atomic modesetting by default

[PATCH v2 0/5] drm/nouveau: Enable atomic modesetting by default
 2026-07-30 19:51 UTC  (6+ messages)
` [PATCH v2 1/5] drm/nouveau: Fix cleanup bug in nouveau_drm_device_new()
` [PATCH v2 2/5] drm/nouveau: Print the nouveau.atomic parameter in nouveau_display_options()
` [PATCH v2 3/5] drm/nouveau: Fix drm_driver struct/nouveau.atomic parameter handling
` [PATCH v2 4/5] drm/nouveau/kms: Only allow enabling atomic modesetting on nv50+
` [PATCH v2 5/5] drm/nouveau/kms/nv50-: Enable atomic modesetting by default

nouveau/gsp: some r570 additions and refactoring
 2026-07-30  2:20 UTC  (9+ messages)
` [PATCH 1/6] nouveau/gsp: refactor libos entry handling for r535
` [PATCH 2/6] nouveau/gsp: make libos init per-gsp version
` [PATCH 3/6] nouveau/gsp: add logging entries for r570
` [PATCH 4/6] nouveau/gsp: refactor the chan allocation arguments into a struct
` [PATCH 5/6] nouveau/gsp: add some more fields to r570 system info
` [PATCH 6/6] nouveau: set wpr boost flags like open driver does

[PATCH 0/4] drm/nouveau: Enable atomic modesetting by default
 2026-07-30  0:56 UTC  (5+ messages)
` [PATCH 1/4] drm/nouveau: Print the nouveau.atomic parameter in nouveau_display_options()
` [PATCH 2/4] drm/nouveau/kms: Check nouveau.atomic parameter after nvif_device_ctor()
` [PATCH 3/4] drm/nouveau/kms: Only allow enabling atomic modesetting on nv50+
` [PATCH 4/4] drm/nouveau/kms/nv50-: Enable atomic modesetting by default

[PATCH] nouveau/instmem: handle iomapping already existing
 2026-07-29  2:45 UTC 

[PATCH] drm/gem: Move pages_to_sg helper into drm_gem.c
 2026-07-28 14:34 UTC  (3+ messages)

[PATCH 0/4] tracing/mmiotrace: Fix some bugs in mmiotrace
 2026-07-28 12:50 UTC  (5+ messages)
` [PATCH 1/4] tracing/mmiotrace: Reset dropped_count in mmio_reset_data()
` [PATCH 2/4] tracing/mmiotrace: Add NULL check for mmio_trace_array in logging functions
` [PATCH 3/4] tracing/mmiotrace: Use trace_assign_type() in mmio_print_mark()
` [PATCH 4/4] tracing/mmiotrace: Clean up coding style and redundant debug logs

[PATCH RFC] drm/nouveau: Use write-combined maps for coherent on Tegra
 2026-07-28  8:38 UTC  (2+ messages)

[PATCH 00/36] treewide: remove conditional returns with no effect
 2026-07-27 12:59 UTC  (10+ messages)
` [PATCH 06/36] drm: remove conditional return "
` (subset) [PATCH 00/36] treewide: remove conditional returns "

[PATCH v4 0/3] drm/nouveau: GSP runtime PM fixes
 2026-07-27 17:54 UTC  (5+ messages)
` [PATCH v4 1/3] Revert "nouveau/gsp: fix suspend/resume regression on r570 firmware"
` [PATCH v4 2/3] drm/nouveau/gsp/r570: Set GcOff = 1 in fbsr
` [PATCH v4 3/3] drm/nouveau/gsp/r570: Enable S/R Display workaround in GSP

[PATCH v3 0/3] drm/nouveau/gsp/r570: Fix runtime PM
 2026-07-27 17:12 UTC  (9+ messages)
` [PATCH v3 2/3] drm/nouveau/gsp/r570: Never enter Gcoff state

[PATCH 0/2] drm/nouveau/clk: fix RAM error handling and pstate desync in nvkm_pstate_prog
 2026-07-27 15:05 UTC  (3+ messages)
` [PATCH 1/2] drm/nouveau/clk: don't ignore RAM clock programming errors "
` [PATCH 2/2] drm/nouveau/clk: only update clk->pstate after hardware programming succeeds

[PATCH v2 0/3] drm: Use named initializers for arrays of i2c_device_data
 2026-07-27 13:51 UTC  (4+ messages)
` [PATCH v2 3/3] drm/nouveau: Use named initializers for i2c_device_id arrays
` (subset) [PATCH v2 0/3] drm: Use named initializers for arrays of i2c_device_data

[PATCH 0/2] drm/nouveau: nv04 FIFO cleanup + recovery for Tesla
 2026-07-25 18:59 UTC  (2+ messages)

[PATCH] drm/nouveau: allow allocating NVDEC channels via abi16
 2026-07-25  3:59 UTC 

[PATCH v3 0/3] drm/nouveau: Fix WARN_ON() from missing blend modes
 2026-07-25  3:49 UTC  (5+ messages)
` [PATCH v3 1/3] drm/nouveau/kms/nv50-: Add .blend_modes to nv50_wndw_func
` [PATCH v3 2/3] drm/nouveau/kms/nv50-: Introduce nv50_wndw_default_state()
` [PATCH v3 3/3] drm/nouveau/kms/nv50-: Unconditionally create blend_mode prop for wndws

[PATCH] drm/nouveau: Fix NULL pointer dereference in nouveau_fence_sync() when prev->cli == NULL
 2026-07-23 10:06 UTC 

[PATCH v10 0/8] mm/hmm: Add mmap lock-drop support for userfaultfd-backed mappings
 2026-07-22 22:48 UTC  (10+ messages)
` [PATCH v10 1/8] mm/hmm: move page fault handling out of walk callbacks
` [PATCH v10 2/8] mm/hmm: add hmm_range_fault_unlocked_timeout() for mmap lock-drop support
` [PATCH v10 3/8] selftests/mm: add HMM test for mmap lock-dropping faults
` [PATCH v10 4/8] mshv: Use hmm_range_fault_unlocked_timeout() for region faults
` [PATCH v10 5/8] drm/nouveau: Use hmm_range_fault_unlocked_timeout() for SVM faults
` [PATCH v10 6/8] RDMA/umem: Use hmm_range_fault_unlocked_timeout() for ODP faults
` [PATCH v10 7/8] accel/amdxdna: Use hmm_range_fault_unlocked_timeout() for range population
` [PATCH v10 8/8] drm/gpusvm: Use hmm_range_fault_unlocked_timeout() for range faults

[PATCH v9 0/8] mm/hmm: Add mmap lock-drop support for userfaultfd-backed mappings
 2026-07-22 18:52 UTC  (15+ messages)
` [PATCH v9 1/8] mm/hmm: move page fault handling out of walk callbacks
` [PATCH v9 2/8] mm/hmm: add hmm_range_fault_unlocked_timeout() for mmap lock-drop support
` [PATCH v9 3/8] selftests/mm: add HMM test for mmap lock-dropping faults
` [PATCH v9 4/8] mshv: Use hmm_range_fault_unlocked_timeout() for region faults
` [PATCH v9 5/8] drm/nouveau: Use hmm_range_fault_unlocked_timeout() for SVM faults
` [PATCH v9 6/8] RDMA/umem: Use hmm_range_fault_unlocked_timeout() for ODP faults
` [PATCH v9 7/8] accel/amdxdna: Use hmm_range_fault_unlocked_timeout() for range population
` [PATCH v9 8/8] drm/gpusvm: Use hmm_range_fault_unlocked_timeout() for range faults

[PATCH v2 00/13] mm: convert more vm_flags_t users to vma_flags_t
 2026-07-22 16:15 UTC  (29+ messages)
` [PATCH v2 01/13] mm: introduce vma_flags_can_grow() and vma_can_grow()
` [PATCH v2 02/13] mm/vma: update do_mmap() to use vma_flags_t
` [PATCH v2 03/13] mm: convert __get_unmapped_area() "
` [PATCH v2 04/13] mm: update generic_get_unmapped_area[_topdown]() "
` [PATCH v2 05/13] mm: prefer mm->def_vma_flags in mm logic
` [PATCH v2 06/13] mm/vma: convert vm_pgprot_modify() to use vma_flags_t and rename
` [PATCH v2 07/13] mm/vma: rename vma_get_page_prot to vma_flags_to_page_prot
` [PATCH v2 08/13] mm: introduce vma_get_page_prot() and use it
` [PATCH v2 09/13] mm/vma: update create_init_stack_vma() to use vma_flags_t
` [PATCH v2 10/13] mm/vma: convert miscellaneous uses of VMA flags in core mm
` [PATCH v2 11/13] mm/mlock: convert mlock code to use vma_flags_t
` [PATCH v2 12/13] mm/mprotect: convert mprotect "
` [PATCH v2 13/13] mm/mremap: convert mremap "

[PATCH] drm/nouveau/gsp: validate sequencer command span
 2026-07-22 13:36 UTC  (2+ messages)

[PATCH] tracing/mmiotrace: fix resource leak on trace_pipe close
 2026-07-22  0:38 UTC  (2+ messages)

[PATCH 0/6] drm/nouveau: GSP telemetry via RUSD, and fdinfo telemetry exposure
 2026-07-21 20:46 UTC  (16+ messages)
` [PATCH 1/6] drm/nouveau/gsp: vendor the RUSD header
` [PATCH 2/6] drm/nouveau/gsp: add RUSD telemetry support
` [PATCH 3/6] drm/nouveau: add GSP hwmon support
` [PATCH 4/6] drm/nouveau: expose RUSD telemetry via sysfs
` [PATCH 5/6] drm/nouveau: expose global VRAM size and usage "
` [PATCH 6/6] drm/nouveau: expose per-client GPU usage via fdinfo

[PATCH v2 0/3] drm/nouveau: Fix WARN_ON() from missing blend modes
 2026-07-21 20:08 UTC  (5+ messages)
` [PATCH v2 1/3] drm/nouveau/kms/nv50-: Add .blend_modes to nv50_wndw_func
` [PATCH v2 2/3] drm/nouveau/kms/nv50-: Introduce nv50_wndw_default_state()
` [PATCH v2 3/3] drm/nouveau/kms/nv50-: Unconditionally create blend_mode prop for wndws

[PATCH] drm/nouveau/kms/nv50-: Unconditionally create blend_mode prop for wndws
 2026-07-17 22:47 UTC 

[PATCH] drm/nouveau: Omit a redundant pm_runtime_mark_last_busy() call in nouveau_pmops_runtime_idle()
 2026-07-17 21:14 UTC  (2+ messages)

[PATCH] drm/nouveau/disp: Prevent division-by-zero during DisplayPort link training transitions
 2026-07-17  8:15 UTC  (3+ messages)

[PATCH v2 0/4] mm/hmm: Clarify notifier retry state and scope HMM timeouts
 2026-07-16 16:37 UTC  (15+ messages)
` [PATCH v2 1/4] fixup! mm/hmm: add hmm_range_fault_unlocked_timeout() for mmap lock-drop support
` [PATCH v2 2/4] fixup! drm/nouveau: use hmm_range_fault_unlocked_timeout() for SVM faults
` [PATCH v2 3/4] fixup! accel/amdxdna: use hmm_range_fault_unlocked_timeout() for range population
` [PATCH v2 4/4] fixup! drm/gpusvm: use hmm_range_fault_unlocked_timeout() for range faults

Reproducible NULL pointer dereference in nouveau_fence_sync() when closing a GPU-composited client window
 2026-07-16 10:39 UTC 

[PATCH 0/4] mm/hmm: Clarify notifier retry state and scope HMM timeouts
 2026-07-14 21:33 UTC  (6+ messages)
` [PATCH 1/4] fixup! mm/hmm: add hmm_range_fault_unlocked_timeout() for mmap lock-drop support
` [PATCH 2/4] fixup! drm/nouveau: use hmm_range_fault_unlocked_timeout() for SVM faults
` [PATCH 3/4] fixup! accel/amdxdna: use hmm_range_fault_unlocked_timeout() for range population
` [PATCH 4/4] fixup! drm/gpusvm: use hmm_range_fault_unlocked_timeout() for range faults

[PATCH v8 0/8] mm/hmm: Add mmap lock-drop support for userfaultfd-backed mappings
 2026-07-14 20:05 UTC  (18+ messages)
` [PATCH v8 5/8] drm/nouveau: Use hmm_range_fault_unlocked_timeout() for SVM faults
` [PATCH v8 8/8] drm/gpusvm: Use hmm_range_fault_unlocked_timeout() for range faults


This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox