From mboxrd@z Thu Jan 1 00:00:00 1970 From: Christoph Hellwig Subject: Re: [RFC PATCH v3 1/2] ext4/xfs: add page refcount helper Date: Fri, 2 Oct 2020 07:56:27 +0200 Message-ID: <20201002055627.GA8891@lst.de> References: <20201001181715.17416-1-rcampbell@nvidia.com> <20201001181715.17416-2-rcampbell@nvidia.com> Mime-Version: 1.0 Content-Type: text/plain; charset=us-ascii Return-path: Content-Disposition: inline In-Reply-To: <20201001181715.17416-2-rcampbell@nvidia.com> To: Ralph Campbell Cc: linux-mm@kvack.org, kvm-ppc@vger.kernel.org, nouveau@lists.freedesktop.org, linux-kernel@vger.kernel.org, Dan Williams , Ira Weiny , Matthew Wilcox , Jerome Glisse , John Hubbard , Alistair Popple , Christoph Hellwig , Jason Gunthorpe , Bharata B Rao , Zi Yan , "Kirill A . Shutemov" , Yang Shi , Paul Mackerras , Ben Skeggs , Andrew Morton List-Id: nouveau.vger.kernel.org On Thu, Oct 01, 2020 at 11:17:14AM -0700, Ralph Campbell wrote: > There are several places where ZONE_DEVICE struct pages assume a reference > count == 1 means the page is idle and free. Instead of open coding this, > add a helper function to hide this detail. > > Signed-off-by: Ralph Campbell Looks good: Reviewed-by: Christoph Hellwig