messages from 2026-06-29 08:57:39 to 2026-07-05 12:08:58 UTC [more...]
[PATCH 0/7] rust: Use kernel style vertical imports in various drivers
2026-07-05 12:08 UTC (11+ messages)
` [PATCH 1/7] samples: rust_dma: use vertical import style
` [PATCH 3/7] cpufreq: rcpufreq_dt: "
[RESEND PATCH v2 0/5] drm/nova: replace `transmute` with `zerocopy`
2026-07-04 13:00 UTC (7+ messages)
` [PATCH v2 1/5] drm/nova: use `zerocopy` in firmware.rs
` [PATCH v2 2/5] drm/nova: use `zerocopy` in booter.rs
` [PATCH v2 3/5] drm/nova: use `zerocopy` in fwsec.rs
` [PATCH v2 4/5] drm/nova: use `zerocopy` in bootloader.rs
` [PATCH v2 5/5] drm/nova: use `zerocopy` in riscv.rs
[PATCH] gpu: nova: fix rust-analyzer generation
2026-07-03 21:29 UTC (6+ messages)
[PATCH v5 00/20] rust: I/O type generalization and projection
2026-07-03 15:13 UTC (40+ messages)
` [PATCH v5 01/20] rust: io: add dynamically-sized `Region` type
` [PATCH v5 02/20] rust: io: add missing safety requirement in `IoCapable` methods
` [PATCH v5 07/20] rust: io: implement `Mmio` as view type
` [PATCH v5 09/20] rust: io: use view types instead of addresses for `Io`
` [PATCH v5 10/20] pwm: th1520: remove unnecessary `deref`
` [PATCH v5 11/20] rust: io: remove `MmioOwned`
` [PATCH v5 12/20] rust: io: move `Io` methods to extension trait
` [PATCH v5 13/20] rust: io: add projection macro and methods
` [PATCH v5 14/20] rust: io: add I/O backend for system memory with volatile access
` [PATCH v5 15/20] rust: io: implement a view type for `Coherent`
` [PATCH v5 16/20] rust: io: add `read_val` and `write_val` functions on `Io`
` [PATCH v5 17/20] gpu: nova-core: use I/O projection for cleaner encapsulation
` [PATCH v5 18/20] rust: dma: drop `dma_read!` and `dma_write!` API
[PATCH v3 0/7] Transition Nova Core to TLV firmare images
2026-07-03 13:51 UTC (12+ messages)
` [PATCH v3 1/7] rust: firmware: add request_into_buf()
` [PATCH v3 2/7] gpu: nova-core: add TLV parser for firmware files
` [PATCH v3 3/7] gpu: nova-core: transition booter_load to TLV images
` [PATCH v3 4/7] gpu: nova-core: transition gsp "
` [PATCH v3 5/7] gpu: nova-core: transition gen_bootloader "
` [PATCH v3 6/7] gpu: nova-core: transition fsp "
` [PATCH v3 7/7] gpu: nova-core: update firmware module info for "
[PATCH 0/4] rust: Add support for reserving of ranges of IDs
2026-07-03 10:31 UTC (6+ messages)
` [PATCH 1/4] rust: bitmap: use function-level cfg on kunit test
` [PATCH 2/4] rust: bitmap: add contiguous area operations
` [PATCH 3/4] rust: id_pool: add contiguous area allocation
` [PATCH 4/4] gpu: nova-core: add ChannelIdPool
[PATCH v2 00/10] gpu: nova-core: blackwell follow-ups and fixes
2026-07-03 10:22 UTC (11+ messages)
` [PATCH v2 01/10] gpu: nova-core: fsp: limit FSP receive message allocation size
` [PATCH v2 02/10] gpu: nova-core: fsp: catch bogus queue pointer issues
` [PATCH v2 03/10] gpu: nova-core: gsp: ensure lifetime for FMC boot DMA allocations
` [PATCH v2 04/10] gpu: nova-core: gsp: ensure LibOS DMA allocation lives long enough
` [PATCH v2 05/10] gpu: nova-core: split FbLayout into FSP and non-FSP versions
` [PATCH v2 06/10] gpu: nova-core: correct FRTS vidmem offset calculation
` [PATCH v2 07/10] gpu: nova-core: rename heap size field
` [PATCH v2 08/10] gpu: nova-core: return non-WPR heap size as u64 from HALs
` [PATCH v2 09/10] gpu: nova-core: correct RISC-V HALTED field
` [PATCH v2 10/10] gpu: nova-core: wait for RISC-V HALTED on FSP unload
[RFC 0/3] gpu: nova: Export parameters from nova-core to nova-drm
2026-07-03 6:45 UTC (4+ messages)
` [RFC 1/3] gpu: nova-core: Add auxiliary bus registration data to nova-core
` [RFC 2/3] drm: nova: Add GETPARAM parameter to read the GPU chipset
` [RFC 3/3] drm: nova: Add a GETPARAM parameter to read usable VRAM size
[PATCH v2 0/2] gpu: nova-core: convert to kernel bitfield macro and remove local variant
2026-07-03 2:47 UTC (4+ messages)
` [PATCH v2 1/2] gpu: nova-core: convert to kernel bitfield macro
` [PATCH v2 2/2] gpu: nova-core: remove local "
[PATCH v5 00/19] rust: drm: Higher-Ranked Lifetime private data
2026-07-03 0:09 UTC (44+ messages)
` [PATCH v5 01/19] rust: drm: ioctl: fix unbounded lifetimes in ioctl handler arguments
` [PATCH v5 02/19] rust: drm: rename Uninit DeviceContext to Normal
` [PATCH v5 03/19] rust: faux: add Device type with AsBusDevice support
` [PATCH v5 04/19] rust: drm: Add Driver::ParentDevice associated type
` [PATCH v5 05/19] rust: drm: change default DeviceContext to Normal
` [PATCH v5 06/19] rust: drm: restrict AlwaysRefCounted to Normal Device context
` [PATCH v5 07/19] rust: drm: restrict AlwaysRefCounted to Normal GEM Object context
` [PATCH v5 08/19] rust: drm/gem: remove DeviceContext from shmem::Object
` [PATCH v5 09/19] rust: drm: split Deref for Device context typestates
` [PATCH v5 10/19] rust: drm: pin ioctl Device reference to Normal context
` [PATCH v5 11/19] rust: drm: add Ioctl device context typestate
` [PATCH v5 12/19] rust: drm: Add RegistrationGuard for drm_dev_enter/exit critical sections
` [PATCH v5 13/19] rust: drm: Wrap ioctl dispatch in RegistrationGuard
` [PATCH v5 14/19] rust: drm: return ParentDevice from Device AsRef
` [PATCH v5 15/19] rust: drm: add AsRef<ParentDevice<Bound>> for Device<Registered>
` [PATCH v5 16/19] drm: fix race between partial drm_dev_register() failure and ioctl
` [PATCH v5 17/19] rust: drm: Add RegistrationData to drm::Driver
` [PATCH v5 18/19] rust: drm: Pass registration data to ioctl handlers
` [PATCH v5 19/19] drm: nova: Use drm::Device<Registered> to access the parent bus device
[PATCH] rust: pci: rework device enabling API
2026-07-02 21:47 UTC (2+ messages)
[PATCH v2 0/4] rust: more memory barriers bindings
2026-07-02 4:56 UTC (5+ messages)
` [PATCH v2 1/4] rust: sync: add helpers for mb, dma_mb and friends
` [PATCH v2 2/4] rust: sync: generic memory barriers
[PATCH v4 00/13] gpu: nova-core: consolidate and streamline GSP boot process
2026-07-02 2:28 UTC (24+ messages)
` [PATCH v4 01/13] gpu: nova-core: gsp: sequencer: use GspBootContext
` [PATCH v4 02/13] gpu: nova-core: gsp: sequencer: do not store sequence into GspSequencer
` [PATCH v4 03/13] gpu: nova-core: gsp: replace BootUnloadGuard with local handlers
` [PATCH v4 04/13] gpu: nova-core: gsp: pass GspBootContext to unload methods
` [PATCH v4 05/13] gpu: nova-core: gsp: centralize missing unload bundle warnings
` [PATCH v4 06/13] gpu: nova-core: gsp: fold TU102 unload bundle construction into HAL method
` [PATCH v4 07/13] gpu: nova-core: gsp: turn FWSEC execution "
` [PATCH v4 08/13] gpu: nova-core: gsp: make use of FWSEC bootloader a property of the TU102 HAL
` [PATCH v4 09/13] gpu: nova-core: introduce GspBootMethod
` [PATCH v4 10/13] gpu: nova-core: avoid repeated calls to pci::Device::as_ref
` [PATCH v4 11/13] gpu: nova-core: gsp: pass GspBootContext mutably
` [PATCH v4 12/13] gpu: nova-core: gsp: separate context and GPU lifetimes in GspBootContext
` [PATCH v4 13/13] gpu: nova-core: store Fsp instance in Gpu
[PATCH v2 0/7] Transition Nova Core to TLV firmware images
2026-07-02 1:18 UTC (12+ messages)
` [PATCH v2 1/7] rust: firmware: add request_into_buf()
` [PATCH v2 2/7] gpu: nova-core: add TLV parser for firmware files
` [PATCH v2 3/7] gpu: nova-core: transition booter_load to TLV images
` [PATCH v2 4/7] gpu: nova-core: transition gsp "
` [PATCH v2 5/7] gpu: nova-core: transition gen_bootloader "
` [PATCH v2 6/7] gpu: nova-core: transition fsp "
` [PATCH v2 7/7] gpu: nova-core: update firmware module info for "
[PATCH] gpu: nova-core: remove `#[allow(non_snake_case)]`
2026-07-01 21:07 UTC (2+ messages)
[PATCH v3 0/8] gpu: nova-core: boot GSP with vGPU enabled
2026-07-01 6:26 UTC (9+ messages)
` [PATCH v3 1/8] PCI/IOV: Return unsigned int from pci_sriov_get_totalvfs()
` [PATCH v3 2/8] rust: pci: add sriov_get_totalvfs() helper
` [PATCH v3 3/8] gpu: nova-core: fsp: rename FSP response header type
` [PATCH v3 4/8] gpu: nova-core: read vGPU mode from FSP via PRC protocol
` [PATCH v3 5/8] gpu: nova-core: add vGPU preludes
` [PATCH v3 6/8] gpu: nova-core: build SetRegistry entries dynamically
` [PATCH v3 7/8] gpu: nova-core: set RMSetSriovMode for vGPU
` [PATCH v3 8/8] gpu: nova-core: reserve vGPU WPR2 heap
[PATCH v2] gpu: nova-core: parse structs via zerocopy
2026-06-30 14:03 UTC (2+ messages)
[PATCH v4 0/7] ForLt/CovariantForLt split, auxiliary closure API and DevresLt
2026-06-30 13:50 UTC (3+ messages)
` [PATCH v4 2/7] rust: types: introduce ForLt base trait for CovariantForLt
[PATCH v2 0/7] gpu: nova-core: boot GSP with vGPU enabled
2026-06-30 13:39 UTC (8+ messages)
` [PATCH v2 3/7] gpu: nova-core: read vGPU mode from FSP via PRC protocol
` [PATCH v2 4/7] gpu: nova-core: add vGPU preludes
` [PATCH v2 7/7] gpu: nova-core: reserve larger WPR2 heap for vGPU
[PATCH v3 00/12] gpu: nova-core: consolidate and streamline GSP boot process
2026-06-29 13:05 UTC (14+ messages)
` [PATCH v3 01/12] gpu: nova-core: gsp: sequencer: use GspBootContext
` [PATCH v3 02/12] gpu: nova-core: gsp: sequencer: do not store sequence into GspSequencer
` [PATCH v3 03/12] gpu: nova-core: gsp: replace BootUnloadGuard with local handlers
` [PATCH v3 04/12] gpu: nova-core: gsp: pass GspBootContext to unload methods
` [PATCH v3 05/12] gpu: nova-core: gsp: centralize missing unload bundle warnings
` [PATCH v3 06/12] gpu: nova-core: gsp: fold TU102 unload bundle construction into HAL method
` [PATCH v3 07/12] gpu: nova-core: gsp: turn FWSEC execution "
` [PATCH v3 08/12] gpu: nova-core: gsp: make use of FWSEC bootloader a property of the TU102 HAL
` [PATCH v3 09/12] gpu: nova-core: introduce GspBootMethod
` [PATCH v3 10/12] gpu: nova-core: avoid repeated calls to pci::Device::as_ref
` [PATCH v3 11/12] gpu: nova-core: gsp: pass GspBootContext mutably
` [PATCH v3 12/12] gpu: nova-core: store Fsp instance in Gpu
[PATCH v2] gpu: nova-core: falcon: store bar and dev in falcon
2026-06-29 13:00 UTC (4+ messages)
[PATCH v2 00/12] rust: driver: use pointers instead of indices for ID info
2026-06-29 12:41 UTC (2+ messages)
[PATCH v2 00/11] rust: driver: use pointers instead of indices for ID info
2026-06-29 12:39 UTC (12+ messages)
` [PATCH v2 01/11] rust: driver: remove `IdTable::id`
` [PATCH v2 02/11] rust: driver: simplify `IdArray::new_without_index`
` [PATCH v2 03/11] rust: pci: use `Option<&IdInfo>` for device ID info
` [PATCH v2 04/11] rust: usb: "
` [PATCH v2 05/11] rust: net/phy: remove expansion from doc
` [PATCH v2 06/11] rust: driver: centralize device ID handling
` [PATCH v2 07/11] rust: driver: remove `$module_table_name` from `module_device_table`
` [PATCH v2 08/11] rust: driver: store pointers in `DeviceId`
` [PATCH v2 09/11] rust: driver: remove open-coded matching logic
` [PATCH v2 10/11] rust: driver: remove duplicate ID table
` [PATCH v2 11/11] RFC: rust: driver: support map-like syntax for "
[PATCH RFC 0/4] rust: dma: bridge zerocopy-derived types into the transmute byte-safety bound
2026-06-29 11:38 UTC (11+ messages)
` [PATCH RFC 4/4] gpu: nova-core: gsp: convert GspMem to zerocopy via the transmute bridge
[PATCH v5 0/5] gpu: drm: nova: enable calling into nova-core
2026-06-29 10:11 UTC (2+ messages)
` (subset) "
page: next (older) | prev (newer) | latest
- recent:[subjects (threaded)|topics (new)|topics (active)]
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox