NVIDIA GPU driver infrastructure
 help / color / mirror / Atom feed
From: "Danilo Krummrich" <dakr@kernel.org>
To: "John Hubbard" <jhubbard@nvidia.com>
Cc: "Timur Tabi" <ttabi@nvidia.com>,
	"Alexandre Courbot" <acourbot@nvidia.com>,
	"vladazaharova2018@gmail.com" <vladazaharova2018@gmail.com>,
	"dri-devel@lists.freedesktop.org"
	<dri-devel@lists.freedesktop.org>,
	"nova-gpu@lists.linux.dev" <nova-gpu@lists.linux.dev>,
	"aliceryhl@google.com" <aliceryhl@google.com>,
	"linux-kernel@vger.kernel.org" <linux-kernel@vger.kernel.org>,
	"linux-doc@vger.kernel.org" <linux-doc@vger.kernel.org>
Subject: Re: [PATCH 1/2] gpu: nova-core: gsp: retain the GSP-RM log buffers after unbind
Date: Thu, 13 Aug 2026 22:00:20 +0200	[thread overview]
Message-ID: <DKO2ZZQU2MQ9.B0PAI47OAV0I@kernel.org> (raw)
In-Reply-To: <aecd067a-e308-44b5-ae46-8f9947c9b44e@nvidia.com>

On Thu Aug 13, 2026 at 9:30 PM CEST, John Hubbard wrote:
> On 8/13/26 9:29 AM, Timur Tabi wrote:
>> On Wed, 2026-08-12 at 15:41 -0700, John Hubbard wrote:
>>> And so should nova! (Except for the strangely worded "keep_gsp_logging"
>>> param name.) See below.
>> 
>> The patch set that added that parameter to Nouveau was under review for months, and no one had
>> any complaints about it until now.  Regardless of whether it's "strange", I think it's important
>
> I'm not keeping a close eye on the nouveau list.

That was back in 2024 and when I reviewed this series I wasn't paying too much
attention on the name.

That said, the name is in fact misleading as we do not keep the GSP logging, we
only keep the logs.

Since we're now already in the game of bikeshedding over the name, I'd like to
go with "gsp_keep_logs". :)

>> that both Nouveau and Nova use the same parameter for the same functionality, so Nova should
>> also call it "keep_gsp_logging".

There's not much value in doing that, and as I've mentioned previously in a
discussion about the uAPI, I don't want to constrain nova on anything because of
how things work in nouveau.

> Completely disagree. There is no need for these disparate drivers to share
> a name, especially given that a better name is available. I'm quite
> unhappy with your continuing efforts to add artificial constraints
> along the lines of "nova must match nouveau", tbh.
>
> Nothing is stopping nouveau from adopting nova's names, if that is
> desirable from their end.

It's not.

  reply	other threads:[~2026-08-13 20:00 UTC|newest]

Thread overview: 19+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2026-08-12 11:37 [PATCH 0/2] gpu: nova-core: retain the GSP-RM log buffers Vladislav Zaharov
2026-08-12 11:37 ` [PATCH 1/2] gpu: nova-core: gsp: retain the GSP-RM log buffers after unbind Vladislav Zaharov
2026-08-12 12:06   ` Vladislav Zaharov
2026-08-12 14:00     ` Gary Guo
2026-08-12 14:38       ` Vladislav Zaharov
2026-08-12 22:41   ` John Hubbard
2026-08-12 23:15     ` Danilo Krummrich
2026-08-13  0:00       ` John Hubbard
2026-08-13 16:29     ` Timur Tabi
2026-08-13 19:30       ` John Hubbard
2026-08-13 20:00         ` Danilo Krummrich [this message]
2026-08-13 20:21           ` John Hubbard
2026-08-12 23:43   ` Danilo Krummrich
2026-08-12 11:37 ` [PATCH 2/2] Documentation: nova: remove completed GSP log buffer task Vladislav Zaharov
2026-08-12 15:54 ` [PATCH 0/2] gpu: nova-core: retain the GSP-RM log buffers Danilo Krummrich
2026-08-12 16:08   ` Vladislav Zaharov
2026-08-13  5:50   ` [PATCH 1/2] gpu: nova-core: gsp: retain the GSP-RM log buffers after unbind Vladislav Zaharov
2026-08-13 19:37     ` John Hubbard
2026-08-13 19:58       ` Gary Guo

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=DKO2ZZQU2MQ9.B0PAI47OAV0I@kernel.org \
    --to=dakr@kernel.org \
    --cc=acourbot@nvidia.com \
    --cc=aliceryhl@google.com \
    --cc=dri-devel@lists.freedesktop.org \
    --cc=jhubbard@nvidia.com \
    --cc=linux-doc@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=nova-gpu@lists.linux.dev \
    --cc=ttabi@nvidia.com \
    --cc=vladazaharova2018@gmail.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox