From: "Eliot Courtney" <ecourtney@nvidia.com>
To: "Yury Norov" <ynorov@nvidia.com>, "Danilo Krummrich" <dakr@kernel.org>
Cc: "Eliot Courtney" <ecourtney@nvidia.com>,
"Alice Ryhl" <aliceryhl@google.com>,
"Burak Emir" <burak.emir@gmail.com>,
"Yury Norov" <yury.norov@gmail.com>,
"Miguel Ojeda" <ojeda@kernel.org>,
"Boqun Feng" <boqun@kernel.org>, "Gary Guo" <gary@garyguo.net>,
"Björn Roy Baron" <bjorn3_gh@protonmail.com>,
"Benno Lossin" <lossin@kernel.org>,
"Andreas Hindborg" <a.hindborg@kernel.org>,
"Trevor Gross" <tmgross@umich.edu>,
"Daniel Almeida" <daniel.almeida@collabora.com>,
"Tamir Duberstein" <tamird@kernel.org>,
"Alexandre Courbot" <acourbot@nvidia.com>,
"Onur Özkan" <work@onurozkan.dev>,
"David Airlie" <airlied@gmail.com>,
"Simona Vetter" <simona@ffwll.ch>,
"Greg Kroah-Hartman" <gregkh@linuxfoundation.org>,
"John Hubbard" <jhubbard@nvidia.com>,
"Alistair Popple" <apopple@nvidia.com>,
"Timur Tabi" <ttabi@nvidia.com>, "Zhi Wang" <zhiw@nvidia.com>,
rust-for-linux@vger.kernel.org, linux-kernel@vger.kernel.org,
nova-gpu@lists.linux.dev, dri-devel@lists.freedesktop.org,
dri-devel <dri-devel-bounces@lists.freedesktop.org>
Subject: Re: [PATCH v5 5/5] gpu: nova-core: add ChannelIdPool
Date: Fri, 14 Aug 2026 11:14:09 +0900 [thread overview]
Message-ID: <DKOAY7J1IFTP.DMKSXK625EW5@nvidia.com> (raw)
In-Reply-To: <an4xDp29VX8Am0uR@yury>
On Fri Aug 14, 2026 at 6:03 AM JST, Yury Norov wrote:
> On Thu, Aug 13, 2026 at 10:48:50PM +0200, Danilo Krummrich wrote:
>> On Thu Aug 13, 2026 at 8:32 PM CEST, Yury Norov wrote:
>> > pub(crate) fn alloc_area(
>> > &self,
>> > count: usize,
>> > align: usize,
>> > ) -> Result<ChannelIdArea<'_>> {
>> > let count = NonZero::new(count).ok_or(EINVAL)?;
>> > let align = Alignment::new_checked(align).ok_or(EINVAL)?;
>> >
>> > let mut ids = self.inner.lock();
>> > let area = ids.find_unused_area(0, count, align).ok_or(ENOSPC)?;
>> >
>> > // If the pool is small, the backing bitmap may be rounded up to a larger size.
>> > if area.range().end > self.num_chids {
>> > return Err(ENOSPC);
>> > }
>> >
>> > Ok(ChannelIdArea {
>> > pool: self,
>> > range: area.acquire(),
>> > })
>> > }
>> >
>> > let area = pool.alloc_area(8, 4)?;
>> >
>> > See the difference? You still check the parameters, but don't make it
>> > the part of interface.
>>
>> Miguel already replied to this, so just briefly adding to this.
>>
>> We usually want the arguments to already carry the invariants we require. If we
>> make the arguments unconstrained, we may end up in situations where we already
>> have types that provide certain guarantees about value constraints and yet we
>> have to give up on them because the API takes unconstrained arguments and
>> revalidates.
>>
>> The code from Eliot does actually already takes advantage of this. In
>>
>> pool.alloc_area(nz::<8>(), Alignment::new::<8>())?;
>>
>> both arguments are already validated at compile time, whereas with unconstrained
>> arguments we're left with a runtime check.
>>
>> Yes, nz() does not actually validate it statically, but it easily could (and
>> probably should).
>
> Alright, I'm not against the static checks, and I don't insist on my
> version. My complain is about readability and unnecessary complexity
> for end user.
>
> let's find a way to convert this beast:
>
> pool.alloc_area(nz::<8>(), alignment::new::<8>())?;
>
> to something more readable, ideally:
>
> pool.alloc_area(8, 8)?;
>
> We were able to do this for bitfields, and I don't think we should
> give up here.
At the moment I can think of two ideas.
1. Provide a nz! macro to create constant non-zero things. Provide some
constants for common alignments
Potentially, we could use build_assert! for cases it is provably
non-zero but not a literal (although tbh not sure this is a good idea -
at least not do this initially).
So either: nz!: const { NonZero::new(value).unwrap() }, or, nz!: some
build assert gated construction of NonZero. A general nz! macro could
also help ergonomics for other use cases too.
That looks like this:
pool.alloc_area(nz!(8), Alignment::AL_8)?;
I actually do not like pool.alloc_area(8, 8) because you can't tell what
the parameters mean. Having to write `Alignment` is useful, IMO.
2. The same solution for bitfield, whcih was to provide a separate const
method that takes the values as const generics. That looks like this:
pool.alloc_area_const::<8, 8>()?;
That said I think this form would mostly only be used in tests.
I personally prefer option #1 because it will make NonZero easier to use
for everyone (I already have a few copies of the nz::<>() function in
unit tests) and because it self-describes what the parameters do. And it
doesn't have any turbofish.
What do you reckon?
next prev parent reply other threads:[~2026-08-14 2:15 UTC|newest]
Thread overview: 24+ messages / expand[flat|nested] mbox.gz Atom feed top
2026-08-12 8:51 [PATCH v5 0/5] rust: Add support for reserving of ranges of IDs Eliot Courtney
2026-08-12 8:51 ` [PATCH v5 1/5] rust: bitmap: use function-level cfg on kunit test Eliot Courtney
2026-08-12 22:23 ` Yury Norov
2026-08-12 8:51 ` [PATCH v5 2/5] rust: bitmap: restrict bitmap length to at most i32::MAX Eliot Courtney
2026-08-12 19:44 ` Yury Norov
2026-08-12 8:51 ` [PATCH v5 3/5] rust: bitmap: add contiguous area operations Eliot Courtney
2026-08-12 20:31 ` Yury Norov
2026-08-13 7:27 ` Eliot Courtney
2026-08-12 8:51 ` [PATCH v5 4/5] rust: id_pool: add contiguous area allocation Eliot Courtney
2026-08-12 21:16 ` Yury Norov
2026-08-13 7:29 ` Eliot Courtney
2026-08-12 8:51 ` [PATCH v5 5/5] gpu: nova-core: add ChannelIdPool Eliot Courtney
2026-08-12 22:18 ` Yury Norov
2026-08-13 7:31 ` Eliot Courtney
2026-08-13 18:32 ` Yury Norov
2026-08-13 20:20 ` Miguel Ojeda
2026-08-13 20:48 ` Danilo Krummrich
2026-08-13 20:58 ` Gary Guo
2026-08-13 21:38 ` John Hubbard
2026-08-13 21:44 ` Yury Norov
2026-08-13 21:53 ` John Hubbard
2026-08-13 21:03 ` Yury Norov
2026-08-14 2:14 ` Eliot Courtney [this message]
2026-08-14 4:54 ` Eliot Courtney
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=DKOAY7J1IFTP.DMKSXK625EW5@nvidia.com \
--to=ecourtney@nvidia.com \
--cc=a.hindborg@kernel.org \
--cc=acourbot@nvidia.com \
--cc=airlied@gmail.com \
--cc=aliceryhl@google.com \
--cc=apopple@nvidia.com \
--cc=bjorn3_gh@protonmail.com \
--cc=boqun@kernel.org \
--cc=burak.emir@gmail.com \
--cc=dakr@kernel.org \
--cc=daniel.almeida@collabora.com \
--cc=dri-devel-bounces@lists.freedesktop.org \
--cc=dri-devel@lists.freedesktop.org \
--cc=gary@garyguo.net \
--cc=gregkh@linuxfoundation.org \
--cc=jhubbard@nvidia.com \
--cc=linux-kernel@vger.kernel.org \
--cc=lossin@kernel.org \
--cc=nova-gpu@lists.linux.dev \
--cc=ojeda@kernel.org \
--cc=rust-for-linux@vger.kernel.org \
--cc=simona@ffwll.ch \
--cc=tamird@kernel.org \
--cc=tmgross@umich.edu \
--cc=ttabi@nvidia.com \
--cc=work@onurozkan.dev \
--cc=ynorov@nvidia.com \
--cc=yury.norov@gmail.com \
--cc=zhiw@nvidia.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox