Linux ocfs2 filesystem development
 help / color / mirror / Atom feed
From: Goldwyn Rodrigues <rgoldwyn@suse.de>
To: ocfs2-devel@oss.oracle.com
Subject: [Ocfs2-devel] [PATCH 3/6] Shift allocation ocfs2_live_connection to user_connect()
Date: Sun, 03 Nov 2013 21:46:01 -0600	[thread overview]
Message-ID: <52771879.5060808@suse.de> (raw)
In-Reply-To: <20131103231457.GI29346@wotan.suse.de>

On 11/03/2013 05:14 PM, Mark Fasheh wrote:
> On Fri, Oct 18, 2013 at 09:45:39AM -0500, Goldwyn Rodrigues wrote:
>> We perform this because the DLM recovery callbacks will require
>> the ocfs2_live_connection structure to record the node information
>> when dlm_new_lockspace() is updated.
>
> Ok but what I see below is that you took the alloc out of
> ocfs2_live_connecion_new() and just do it above that call in
> user_cluster_connect(), then call ocfs2_live_connection_new().
>
> Aside from that though this doesn't seem to add new functionality, which is
> fine if the later patches use what you've done here but I don't where this
> change has made any impact on patches 4-6. So my guess is that there's one
> of two things going on here:
>
> 1) This change was just left in by accident in which case you can just
> remove this patch from your series.
>
> 2) I made an error reading the later patches and this _is_ used :)
> If that's the case do me a favor and point out what I missed :)

When dlm_new_lockspace is called, it calls recover_done() to inform our 
node number. This is recorded in the live_connection data structure and 
  needs ocfs2_live_connection to be available before the call to 
dlm_lockspce_new(). I will put this information in the next series.

> Also, if this needs to stay I would rename ocfs2_live_connecion_new() since
> _new() usually makes me think "allocates" and we're not doing that any more.
> Maybe something like ocfs2_live_connection_attach()?

Yes, we should change the name of the function.


-- 
Goldwyn

  reply	other threads:[~2013-11-04  3:46 UTC|newest]

Thread overview: 7+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2013-10-18 14:45 [Ocfs2-devel] [PATCH 3/6] Shift allocation ocfs2_live_connection to user_connect() Goldwyn Rodrigues
2013-11-03 23:14 ` Mark Fasheh
2013-11-04  3:46   ` Goldwyn Rodrigues [this message]
2013-11-04 22:10     ` Mark Fasheh
  -- strict thread matches above, loose matches on Subject: below --
2013-11-12 14:07 Goldwyn Rodrigues
2013-11-25 23:05 ` Mark Fasheh
2013-12-09 19:41 Goldwyn Rodrigues

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=52771879.5060808@suse.de \
    --to=rgoldwyn@suse.de \
    --cc=ocfs2-devel@oss.oracle.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox