From: Junxiao Bi <junxiao.bi@oracle.com>
To: ocfs2-devel@oss.oracle.com
Subject: [Ocfs2-devel] [PATCH] ocfs2: add uuid to ocfs2 thread name for problem analysis
Date: Wed, 28 Oct 2015 12:04:50 +0800 [thread overview]
Message-ID: <56304962.7000803@oracle.com> (raw)
In-Reply-To: <562F6266.3090100@huawei.com>
On 10/27/2015 07:39 PM, Joseph Qi wrote:
> Hi Junxiao,
>
...
>>> diff --git a/fs/ocfs2/dlm/dlmrecovery.c b/fs/ocfs2/dlm/dlmrecovery.c
>>> index a43f9ef..570509e 100644
>>> --- a/fs/ocfs2/dlm/dlmrecovery.c
>>> +++ b/fs/ocfs2/dlm/dlmrecovery.c
>>> @@ -205,7 +205,7 @@ int dlm_launch_recovery_thread(struct dlm_ctxt *dlm)
>>> mlog(0, "starting dlm recovery thread...\n");
>>>
>>> dlm->dlm_reco_thread_task = kthread_run(dlm_recovery_thread, dlm,
>>> - "dlm_reco_thread");
>>> + "dlm_reco_thread-%s", dlm->name);
>> Indeed max length of task name is 16 bytes, and "dlm_reco_thread" plus
>> '\0' have taken all the space. So indeed above code is useless. Can we
>> rename this name and maybe other one(like "dlm_thread") to leave more
>> space for domain marker?
>>
> Yes, you are right. For dlm_reco_thread it won't print any uuid bytes.
> I put it here just for code consistency.
> It is really hard for me to rename it to a better one:)
> Any suggestions?
How about this?
dlmwq-xxxx
dlmrec-xxxx
dlm-xxxx
o2dc-xxxx
o2cmt-xxx
o2rec-xxx
Thanks,
Junxiao.
>
> Thanks,
> Joseph
>
next prev parent reply other threads:[~2015-10-28 4:04 UTC|newest]
Thread overview: 6+ messages / expand[flat|nested] mbox.gz Atom feed top
2015-10-27 3:32 [Ocfs2-devel] [PATCH] ocfs2: add uuid to ocfs2 thread name for problem analysis Joseph Qi
2015-10-27 7:56 ` Junxiao Bi
2015-10-27 11:39 ` Joseph Qi
2015-10-28 4:04 ` Junxiao Bi [this message]
2015-10-28 6:18 ` Joseph Qi
2015-10-28 7:05 ` Junxiao Bi
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=56304962.7000803@oracle.com \
--to=junxiao.bi@oracle.com \
--cc=ocfs2-devel@oss.oracle.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox