Openembedded Core Discussions
 help / color / mirror / Atom feed
From: Paul Menzel <paulepanter@users.sourceforge.net>
To: openembedded-core@lists.openembedded.org
Subject: [PATCH] libarchive: Remove obsolete comment and empty line at the end
Date: Wed, 09 Nov 2011 00:23:17 +0100	[thread overview]
Message-ID: <1320794597.12955.22.camel@mattotaupa> (raw)
In-Reply-To: <1320790090.12955.16.camel@mattotaupa>

[-- Attachment #1: Type: text/plain, Size: 1813 bytes --]

Date: Wed, 9 Nov 2011 00:17:22 +0100

This is a fix up for

        commit fb19df5b21e551c5dfdfa340438952560c5fa528
        Author: Xiaofeng Yan <xiaofeng.yan@windriver.com>
        Date:   Mon Nov 7 20:03:53 2011 +0800
        
            libarchive: update to 2.8.5
        
            Remove patch "0003-Patch-from-upstream-rev-2516.patch" because it has been merged
            to source codes.
        
            Signed-off-by: Xiaofeng Yan <xiaofeng.yan@windriver.com>

removing a now obsolete comment because the undistributable content was removed [1] from upstream’s tarball.

Also remove an empty line at the end introduced in the above commit.

[1] http://code.google.com/p/libarchive/issues/detail?id=162

Signed-off-by: Paul Menzel <paulepanter@users.sourceforge.net>
---
 .../libarchive/libarchive_2.8.5.bb                 |    3 ---
 1 files changed, 0 insertions(+), 3 deletions(-)

diff --git a/meta/recipes-extended/libarchive/libarchive_2.8.5.bb b/meta/recipes-extended/libarchive/libarchive_2.8.5.bb
index 1bc49e2..5cf13e6 100644
--- a/meta/recipes-extended/libarchive/libarchive_2.8.5.bb
+++ b/meta/recipes-extended/libarchive/libarchive_2.8.5.bb
@@ -7,8 +7,6 @@ PR = "r0"
 
 DEPENDS = "libxml2"
 
-# We need to repack the tarball due undistributable content on the upstream one.
-# More details at http://code.google.com/p/libarchive/issues/detail?id=162
 SRC_URI = "http://libarchive.googlecode.com/files/libarchive-${PV}.tar.gz \
            file://0001-Patch-from-upstream-revision-1990.patch \
            file://0002-Patch-from-upstream-revision-1991.patch \
@@ -24,4 +22,3 @@ SRC_URI[sha256sum] = "13993e0ffbd121ccda46ea226b1f8eac218de0fa8da7d8b1f998093d5c
 inherit autotools lib_package
 
 BBCLASSEXTEND = "nativesdk"
-
-- 
1.7.7.2

[-- Attachment #2: This is a digitally signed message part --]
[-- Type: application/pgp-signature, Size: 205 bytes --]

  reply	other threads:[~2011-11-08 23:29 UTC|newest]

Thread overview: 28+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2011-11-08 19:22 [CONSOLIDATED PULL 00/17] Updates and Fixes Saul Wold
2011-11-08 19:22 ` [CONSOLIDATED PULL 01/17] pseudo: Uprev pseudo to version 1.2 Saul Wold
2011-11-08 21:59   ` Paul Menzel
2011-11-08 19:22 ` [CONSOLIDATED PULL 02/17] libcap: fix sstate for native package Saul Wold
2011-11-08 19:22 ` [CONSOLIDATED PULL 03/17] files/device_table-minimal.txt: add /dev/kmsg Saul Wold
2011-11-08 19:22 ` [CONSOLIDATED PULL 04/17] dhcp: drop unused dhcp3.inc file Saul Wold
2011-11-08 19:22 ` [CONSOLIDATED PULL 05/17] dhcp: rename dhcp4.inc to dhcp.inc Saul Wold
2011-11-08 19:22 ` [CONSOLIDATED PULL 06/17] dhcp: move server configuration to dhcp-server-config Saul Wold
2011-11-08 19:22 ` [CONSOLIDATED PULL 07/17] libarchive: update to 2.8.5 Saul Wold
2011-11-08 22:08   ` Paul Menzel
2011-11-08 23:23     ` Paul Menzel [this message]
2011-11-08 19:22 ` [CONSOLIDATED PULL 08/17] distro_tracking_fields.inc: update to libarchive " Saul Wold
2011-11-08 19:22 ` [CONSOLIDATED PULL 09/17] qmmp: update to 0.5.2 Saul Wold
2011-11-08 19:22 ` [CONSOLIDATED PULL 10/17] distro_tracking_fields.inc: Modify the status of qmmp Saul Wold
2011-11-08 19:22 ` [CONSOLIDATED PULL 11/17] Add new IMAGE_CLASSES variable for classes for image generation Saul Wold
2011-11-08 19:22 ` [CONSOLIDATED PULL 12/17] tune-corei7: Add tune file for Intel Core i7 machines Saul Wold
2011-11-08 19:22 ` [CONSOLIDATED PULL 13/17] tune-ivb: Add tune file for Intel Ivy Bridge machines Saul Wold
2011-11-08 19:22 ` [CONSOLIDATED PULL 14/17] machine/include/tune-atom.inc: add atom-specific settings Saul Wold
2011-11-08 19:22 ` [CONSOLIDATED PULL 15/17] gmp_5.0.2: Set CC_FOR_BUILD to BUILD_CC Saul Wold
2011-11-08 19:22 ` [CONSOLIDATED PULL 16/17] libzypp: fix mishandling of hyphenated arches Saul Wold
2011-11-08 19:22 ` [CONSOLIDATED PULL 17/17] python: skip setup.py 'import check' when cross-compiling Saul Wold
2011-11-09  9:39   ` Koen Kooi
2011-11-09 10:34   ` Cui, Dexuan
2011-11-09 13:42     ` Tom Zanussi
2011-11-10  0:57       ` Cui, Dexuan
2011-11-10  1:06         ` Tom Zanussi
2011-11-10  1:25           ` Cui, Dexuan
2011-11-08 21:46 ` [CONSOLIDATED PULL 00/17] Updates and Fixes Richard Purdie

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=1320794597.12955.22.camel@mattotaupa \
    --to=paulepanter@users.sourceforge.net \
    --cc=openembedded-core@lists.openembedded.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox