openembedded-core.lists.openembedded.org archive mirror
 help / color / mirror / Atom feed
From: Ross Burton <ross.burton@intel.com>
To: openembedded-core@lists.openembedded.org
Subject: [PATCH 1/7] gst-openmax: fix build with GLib 2.40 onwards
Date: Mon, 12 May 2014 13:14:47 +0100	[thread overview]
Message-ID: <1399896893-486-1-git-send-email-ross.burton@intel.com> (raw)

GLib 2.40 adds g_ptr_array_insert, but gst-openmax is definining that as a
static helper function.  Rename the static function so it doesn't conflict with
GLib's namespace.

Signed-off-by: Ross Burton <ross.burton@intel.com>
---
 .../gstreamer/gst-openmax/ptr-array.patch          |   46 ++++++++++++++++++++
 .../gstreamer/gst-openmax_0.10.1.bb                |    1 +
 2 files changed, 47 insertions(+)
 create mode 100644 meta/recipes-multimedia/gstreamer/gst-openmax/ptr-array.patch

diff --git a/meta/recipes-multimedia/gstreamer/gst-openmax/ptr-array.patch b/meta/recipes-multimedia/gstreamer/gst-openmax/ptr-array.patch
new file mode 100644
index 0000000..5965bba
--- /dev/null
+++ b/meta/recipes-multimedia/gstreamer/gst-openmax/ptr-array.patch
@@ -0,0 +1,46 @@
+Rename static functions that use GLib naming conventions as one of them
+(g_ptr_array_insert) has now been added to GLib.
+
+Upstream-Status: Pending
+Signed-off-by: Ross Burton <ross.burton@intel.com>
+
+diff --git a/omx/gstomx_util.c b/omx/gstomx_util.c
+index 423e441..579dbf5 100644
+--- a/omx/gstomx_util.c
++++ b/omx/gstomx_util.c
+@@ -85,7 +85,7 @@ static gboolean initialized;
+  */
+ 
+ static void
+-g_ptr_array_clear (GPtrArray * array)
++omx_g_ptr_array_clear (GPtrArray * array)
+ {
+   guint index;
+   for (index = 0; index < array->len; index++)
+@@ -93,7 +93,7 @@ g_ptr_array_clear (GPtrArray * array)
+ }
+ 
+ static void
+-g_ptr_array_insert (GPtrArray * array, guint index, gpointer data)
++omx_g_ptr_array_insert (GPtrArray * array, guint index, gpointer data)
+ {
+   if (index + 1 > array->len) {
+     g_ptr_array_set_size (array, index + 1);
+@@ -394,7 +394,7 @@ g_omx_core_unload (GOmxCore * core)
+   }
+ 
+   core_for_each_port (core, g_omx_port_free);
+-  g_ptr_array_clear (core->ports);
++  omx_g_ptr_array_clear (core->ports);
+ }
+ 
+ static inline GOmxPort *
+@@ -418,7 +418,7 @@ g_omx_core_new_port (GOmxCore * core, guint index)
+   }
+ 
+   port = g_omx_port_new (core, index);
+-  g_ptr_array_insert (core->ports, index, port);
++  omx_g_ptr_array_insert (core->ports, index, port);
+ 
+   return port;
+ }
diff --git a/meta/recipes-multimedia/gstreamer/gst-openmax_0.10.1.bb b/meta/recipes-multimedia/gstreamer/gst-openmax_0.10.1.bb
index ea3b66b..4e22f46 100644
--- a/meta/recipes-multimedia/gstreamer/gst-openmax_0.10.1.bb
+++ b/meta/recipes-multimedia/gstreamer/gst-openmax_0.10.1.bb
@@ -13,6 +13,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=fbc093901857fcd118f065f900982c24 \
 
 SRC_URI = "http://gstreamer.freedesktop.org/src/gst-openmax/gst-openmax-${PV}.tar.bz2 \
            file://gcc_4.6.patch \
+           file://ptr-array.patch \
            "
 
 inherit autotools
-- 
1.7.10.4



             reply	other threads:[~2014-05-12 12:21 UTC|newest]

Thread overview: 12+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2014-05-12 12:14 Ross Burton [this message]
2014-05-12 12:14 ` [PATCH 2/7] glib-2.0: upgrade to 2.40.0 Ross Burton
2014-05-12 12:14 ` [PATCH 3/7] freetype: upgrade to 2.5.3 Ross Burton
2014-05-14  4:28   ` Saul Wold
2014-05-14  4:30     ` Saul Wold
2014-05-14  7:27     ` Koen Kooi
2014-05-14  7:53       ` Richard Purdie
2014-05-14  9:32         ` Burton, Ross
2014-05-12 12:14 ` [PATCH 4/7] gdk-pixbuf: upgrade to 2.30.7 Ross Burton
2014-05-12 12:14 ` [PATCH 5/7] python-numpy: add Signed-off-by to patches Ross Burton
2014-05-12 12:14 ` [PATCH 6/7] json-glib: upgrade to 1.0.0 Ross Burton
2014-05-12 12:14 ` [PATCH 7/7] systemd: remove tcp-wrappers option Ross Burton

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=1399896893-486-1-git-send-email-ross.burton@intel.com \
    --to=ross.burton@intel.com \
    --cc=openembedded-core@lists.openembedded.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).