Openembedded Devel Discussions
 help / color / mirror / Atom feed
From: Jamie Lenehan <lenehan@twibble.org>
To: Richard Purdie <rpurdie@rpsys.net>
Subject: Re: site/* - using common files for site information
Date: Fri, 25 Aug 2006 19:34:44 +1000	[thread overview]
Message-ID: <20060825093443.GA18720@twibble.org> (raw)
In-Reply-To: <1156495256.5554.16.camel@localhost.localdomain>

On Fri, Aug 25, 2006 at 09:40:56AM +0100, Richard Purdie wrote:
> On Fri, 2006-08-25 at 18:22 +1000, Jamie Lenehan wrote:
> > On Fri, Aug 25, 2006 at 09:08:09AM +0100, Richard Purdie wrote:
> > I changed my mind about a dozen times on this, so seeing what someone
> > else thinks would be good. 
> 
> I'll try and take a look at the patches this weekend. I can't promise
> but I will try :).

No hurry. I'd had enough of looking at them was all and so figure I
should either throw out or push it of no one else had any comments on
it ;)

[...]
> > The autotools.bbclass then makes use of this to decided which site
> > files to use.
> 
> You can argue that both ways. Ultimately, those files are generally used
> by configure which implies autotools but other packages also use them to
> provide supplementary info, just to confuse the issue :). I like the

Right. I focussed too much on the "call it autotools-info" rather
than the "don't call it info cause that's too generic" bit of your
email. I agree with you now that I think about it that way.

> idea of some functions like get_info_endianess_select (although your
> example doesn't quite match with get_info_choice_endianess) and it would
> be good to abstract direct access to the site files.

Duh. I've been unable to decide on what to call the damn thing and
the two diffs were taken a few minutes apart - and I'd renamed it
(again!) during those few minutes.

> I still feel info is too generic as we have 101 different forms of info
> around and we need to find a better more descriptive name.
> config-info.bclass? site-config.bbclass? Calling it autotools-info
> doesn't mean none autotooled packages can't use it btw!

Yep. Agreed. config-info or target-info or something would probably make
more sense.

> > I also made use of the info.bbclass to provide the endiness
> > information to recipes that were currently manaully looking in the
> > site file to determine this (since the way they currently work breaks
> > with the site file.)
> 
> Just throwing ideas around, rather than create a function for each
> option like endiness, why not have a variable which contains the
> endiness set by the class and use base_conditional to get the value you
> want? This might make things a little more flexiable?

I didn't know about base_conditional, but now that I look it - yeah
that looks like it's very close to what I was trying to do and it'll
work fine in this case. And pre-loading into variables is probably a
good idea as well.

Thanks.

-- 
 Jamie Lenehan <lenehan@twibble.org>



  reply	other threads:[~2006-08-25  9:36 UTC|newest]

Thread overview: 7+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
     [not found] <20060817105325.GA2172@twibble.org>
     [not found] ` <20060817153312.GA23152@twibble.org>
2006-08-25  5:33   ` site/* - using common files for site information Jamie Lenehan
2006-08-25  8:08     ` Richard Purdie
2006-08-25  8:22       ` Jamie Lenehan
2006-08-25  8:40         ` Richard Purdie
2006-08-25  9:34           ` Jamie Lenehan [this message]
2006-08-25  9:57           ` Michael 'Mickey' Lauer
2006-08-28  0:05           ` Jamie Lenehan

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20060825093443.GA18720@twibble.org \
    --to=lenehan@twibble.org \
    --cc=openembedded-devel@lists.openembedded.org \
    --cc=rpurdie@rpsys.net \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox