From: Rod Whitby <rod@whitby.id.au>
To: openembedded-devel@lists.openembedded.org
Subject: RFC: Rename MACHINE_TASK_PROVIDER to DEFAULT_TASK_PROVIDER
Date: Tue, 01 May 2007 17:47:11 +0930 [thread overview]
Message-ID: <4636F787.8030902@whitby.id.au> (raw)
> <rwhitby> so in my mokoslug distro, I set MACHINE_TASK_PROVIDER to task-boot or task-base, depending on flash size.
> <rwhitby> what is MACHINE_TASK_PROVIDER really meant to be used for?
> <koen> to distinguish between task-bootstrap and task-base
> <rwhitby> does task-bootstrap still exist?
> <koen> rwhitby: I hope not
> <rwhitby> koen: so MACHINE_TASK_PROVIDER has no current reason for existence then?
> <rwhitby> (and no definition of what it should be used for if it did have a current reason for existence)
> <koen> rwhitby: not that I know off, but your task-boot suggestion would make sense
> <rwhitby> koen: So it really should now be called something like BOOTSTRAP_IMAGE_FOUNDATION_TASK or something?
> <rwhitby> (since it doesn't have anything to do with MACHINEs)
> <koen> nor with BOOTSTRAP
> <koen> something like DEFAULT_TASK_PROVIDER?
> <rwhitby> yep, DEFAULT_TASK_PROVIDER floats my boat.
> <koen> do you want to write an RFC for that?
The proposal is to replace MACHINE_TASK_PROVIDER with
DEFAULT_TASK_PROVIDER throughout OE, and encourage all image-foo.bb
maintainers to base their image on DEFAULT_TASK_PROVIDER (which can be
set to task-boot, or task-base, or perhaps some other distro-specific
single task-foo value), plus other image-specific stuff.
Comments? Objections?
BTW, task-bootstrap existence is as follows:
> ./conf/distro/generic.conf:PREFERRED_PROVIDER_task-bootstrap = "task-bootstrap"
> ./conf/distro/include/oplinux.inc:PREFERRED_PROVIDER_task-bootstrap = "task-base"
> ./conf/distro/angstrom-2007.1.conf:PREFERRED_PROVIDER_task-bootstrap = "task-bootstrap"
> ./conf/distro/jlime-donkey.conf:PREFERRED_PROVIDER_task-bootstrap = "task-bootstrap"
> ./conf/distro/openprotium.conf:#PREFERRED_PROVIDER_task-bootstrap = "task-bootstrap"
> ./conf/machine/gumstix.conf:PREFERRED_VERSION_task-bootstrap = "1.0unionroot"
> ./packages/obsolete/tasks/task-bootstrap-unionroot.bb:PROVIDES = "task-bootstrap"
> ./packages/obsolete/tasks/task-bootstrap-unionroot.bb:RPROVIDES = "task-bootstrap"
> ./packages/obsolete/tasks/task-bootstrap-unionroot.bb:require task-bootstrap.inc
> ./packages/obsolete/tasks/task-bootstrap.bb:require task-bootstrap.inc
> ./packages/images/jlime-opie.bb:DEPENDS = "task-bootstrap task-opie"
> ./packages/images/jlime-opie.bb:INSTALL_PACKAGES = "task-bootstrap task-opie-base task-opie-base-applets \
> ./removal.txt:Package Name: task-bootstrap*
-- Rod
next reply other threads:[~2007-05-01 8:27 UTC|newest]
Thread overview: 5+ messages / expand[flat|nested] mbox.gz Atom feed top
2007-05-01 8:17 Rod Whitby [this message]
2007-05-01 18:32 ` squasfs jffs2 default image settings Stelios Koroneos
2007-05-02 0:05 ` Rod Whitby
2007-05-27 14:30 ` RFC: Rename MACHINE_TASK_PROVIDER to DEFAULT_TASK_PROVIDER Marcin Juszkiewicz
2007-05-27 22:46 ` Rod Whitby
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=4636F787.8030902@whitby.id.au \
--to=rod@whitby.id.au \
--cc=openembedded-devel@lists.openembedded.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox