Linux OpenRISC platform development
 help / color / mirror / Atom feed
 messages from 2020-05-12 18:44:19 to 2020-07-28 10:44:45 UTC [more...]

[OpenRISC] [PATCH 00/15] memblock: seasonal cleaning^w cleanup
 2020-07-28 10:44 UTC  (19+ messages)
` [OpenRISC] [PATCH 01/15] KVM: PPC: Book3S HV: simplify kvm_cma_reserve()
` [OpenRISC] [PATCH 02/15] dma-contiguous: simplify cma_early_percent_memory()
` [OpenRISC] [PATCH 03/15] arm, xtensa: simplify initialization of high memory pages
` [OpenRISC] [PATCH 04/15] arm64: numa: simplify dummy_numa_init()
` [OpenRISC] [PATCH 05/15] h8300, nds32, openrisc: simplify detection of memory extents
` [OpenRISC] [PATCH 06/15] powerpc: fadamp: simplify fadump_reserve_crash_area()
` [OpenRISC] [PATCH 07/15] riscv: drop unneeded node initialization
` [OpenRISC] [PATCH 08/15] mircoblaze: drop unneeded NUMA and sparsemem initializations
` [OpenRISC] [PATCH 09/15] memblock: make for_each_memblock_type() iterator private
` [OpenRISC] [PATCH 10/15] memblock: make memblock_debug and related functionality private
` [OpenRISC] [PATCH 11/15] memblock: reduce number of parameters in for_each_mem_range()
` [OpenRISC] [PATCH 12/15] arch, mm: replace for_each_memblock() with for_each_mem_pfn_range()
` [OpenRISC] [PATCH 13/15] arch, drivers: replace for_each_membock() with for_each_mem_range()
` [OpenRISC] [PATCH 14/15] x86/numa: remove redundant iteration over memblock.reserved
` [OpenRISC] [PATCH 15/15] memblock: remove 'type' parameter from for_each_memblock()

[OpenRISC] [PATCH 14/24] openrisc: use asm-generic/mmu_context.h for no-op implementations
 2020-07-28  3:35 UTC 

[OpenRISC] Fpu tininess
 2020-07-26 13:15 UTC  (5+ messages)

[OpenRISC] [PATCH] openrisc: Implement proper SMP tlb flushing
 2020-07-25  1:01 UTC 

[OpenRISC] [PATCH v2] openrisc: Fix oops caused when dumping stack
 2020-07-24  8:37 UTC 

[OpenRISC] [PATCH] OPENRISC ARCHITECTURE: Replace HTTP links with HTTPS ones
 2020-07-14 19:42 UTC  (7+ messages)

[OpenRISC] [PATCH v5 14/25] mm/openrisc: Use general page fault accounting
 2020-07-07 22:50 UTC 

[OpenRISC] [PATCH] openrisc: Add support for external initrd images
 2020-07-04 21:11 UTC 

[OpenRISC] [PATCH 16/17] arch: remove HAVE_COPY_THREAD_TLS
 2020-07-04 16:11 UTC  (12+ messages)
` [OpenRISC] [PATCH 17/17] arch: rename copy_thread_tls() back to copy_thread()

[OpenRISC] [PATCH 0/8] mm: cleanup usage of <asm/pgalloc.h>
 2020-07-02 21:47 UTC  (20+ messages)
` [OpenRISC] [PATCH 1/8] mm: remove unneeded includes "
` [OpenRISC] [PATCH 2/8] opeinrisc: switch to generic version of pte allocation
` [OpenRISC] [PATCH 3/8] xtensa: "
` [OpenRISC] [PATCH 4/8] asm-generic: pgalloc: provide generic pmd_alloc_one() and pmd_free_one()
` [OpenRISC] [PATCH 5/8] asm-generic: pgalloc: provide generic pud_alloc_one() and pud_free_one()
` [OpenRISC] [PATCH 6/8] asm-generic: pgalloc: provide generic pgd_free()
` [OpenRISC] [PATCH 7/8] mm: move lib/ioremap.c to mm/
` [OpenRISC] [PATCH 8/8] mm: move p?d_alloc_track to separate header file
` [OpenRISC] [PATCH 9/8] mm: Account PMD tables like PTE tables

[OpenRISC] [PATCH v4 14/26] mm/openrisc: Use general page fault accounting
 2020-06-30 20:45 UTC 

[OpenRISC] [PATCH 14/26] mm/openrisc: Use general page fault accounting
 2020-06-26 22:36 UTC 

[OpenRISC] Binary builds of or1k newlib toolchain?
 2020-06-26 17:07 UTC  (2+ messages)

[OpenRISC] [PATCH] openrisc: fix __user in raw_copy_to_user()'s prototype
 2020-06-25 21:11 UTC  (2+ messages)

[OpenRISC] [PATCH 14/26] mm/openrisc: Use general page fault accounting
 2020-06-19 16:12 UTC 

[OpenRISC] [PATCH AUTOSEL 4.4 53/60] openrisc: Fix issue with argument clobbering for clone/fork
 2020-06-18  1:29 UTC 

[OpenRISC] [PATCH AUTOSEL 4.9 70/80] openrisc: Fix issue with argument clobbering for clone/fork
 2020-06-18  1:28 UTC 

[OpenRISC] [PATCH AUTOSEL 4.14 088/108] openrisc: Fix issue with argument clobbering for clone/fork
 2020-06-18  1:25 UTC 

[OpenRISC] [PATCH AUTOSEL 4.19 136/172] openrisc: Fix issue with argument clobbering for clone/fork
 2020-06-18  1:21 UTC 

[OpenRISC] [PATCH AUTOSEL 5.4 214/266] openrisc: Fix issue with argument clobbering for clone/fork
 2020-06-18  1:15 UTC 

[OpenRISC] [PATCH AUTOSEL 5.7 313/388] openrisc: Fix issue with argument clobbering for clone/fork
 2020-06-18  1:06 UTC 

[OpenRISC] [PATCH 15/25] mm/openrisc: Use mm_fault_accounting()
 2020-06-17 16:10 UTC  (7+ messages)
` [OpenRISC] [PATCH 00/25] mm: Page fault accounting cleanups

[OpenRISC] [PATCH] openrisc: Fix boot oops when DEBUG_VM is enabled
 2020-06-17 12:04 UTC  (2+ messages)

[OpenRISC] [PATCH] openrisc: Fix oops caused when dumping stack
 2020-06-17  9:13 UTC  (2+ messages)

[OpenRISC] Possible duplicate page fault accounting on some archs after commit 4064b9827063
 2020-06-15 21:34 UTC  (4+ messages)

[OpenRISC] [PATCH 04/21] mm: free_area_init: use maximal zone PFNs rather than zone sizes
 2020-06-15  7:17 UTC  (4+ messages)

[OpenRISC] [GIT PULL] OpenRISC updates for v5.8
 2020-06-13  2:19 UTC 

[OpenRISC] [PATCH 0/1] OpenRISC port
 2020-06-10 20:17 UTC  (11+ messages)
` [OpenRISC] [PATCH 1/1] Initial support for OpenRISC

[OpenRISC] [PATCH v4 00/14] mm: remove __ARCH_HAS_5LEVEL_HACK
 2020-06-04  9:50 UTC  (7+ messages)
` [OpenRISC] [PATCH v4 03/14] arm64: add support for folded p4d page tables
` [OpenRISC] [PATCH v4 08/14] powerpc: "

[OpenRISC] [PATCH] openrisc: Fix issue with argument clobbering for clone/fork
 2020-05-31 21:24 UTC 

[OpenRISC] sort out the flush_icache_range mess v2
 2020-05-27 13:45 UTC  (38+ messages)
` [OpenRISC] [PATCH 01/29] arm: fix the flush_icache_range arguments in set_fiq_handler
` [OpenRISC] [PATCH 02/29] nds32: unexport flush_icache_page
` [OpenRISC] [PATCH 03/29] powerpc: unexport flush_icache_user_range
` [OpenRISC] [PATCH 04/29] unicore32: remove flush_cache_user_range
` [OpenRISC] [PATCH 05/29] asm-generic: fix the inclusion guards for cacheflush.h
` [OpenRISC] [PATCH 06/29] asm-generic: don't include <linux/mm.h> in cacheflush.h
  ` [OpenRISC] [PATCH] media: omap3isp: Shuffle cacheflush.h and include mm.h
` [OpenRISC] [PATCH 07/29] asm-generic: improve the flush_dcache_page stub
` [OpenRISC] [PATCH 08/29] alpha: use asm-generic/cacheflush.h
` [OpenRISC] [PATCH 09/29] arm64: "
` [OpenRISC] [PATCH 10/29] c6x: "
` [OpenRISC] [PATCH 11/29] hexagon: "
` [OpenRISC] [PATCH 12/29] ia64: "
` [OpenRISC] [PATCH 13/29] microblaze: "
` [OpenRISC] [PATCH 14/29] m68knommu: "
` [OpenRISC] [PATCH 15/29] openrisc: "
` [OpenRISC] [PATCH 16/29] powerpc: "
` [OpenRISC] [PATCH 17/29] riscv: "
` [OpenRISC] [PATCH 18/29] arm, sparc, unicore32: remove flush_icache_user_range
` [OpenRISC] [PATCH 19/29] mm: rename flush_icache_user_range to flush_icache_user_page
` [OpenRISC] [PATCH 20/29] asm-generic: add a flush_icache_user_range stub
` [OpenRISC] [PATCH 21/29] sh: implement flush_icache_user_range
` [OpenRISC] [PATCH 22/29] xtensa: "
` [OpenRISC] [PATCH 23/29] arm: rename flush_cache_user_range to flush_icache_user_range
` [OpenRISC] [PATCH 24/29] m68k: implement flush_icache_user_range
` [OpenRISC] [PATCH 25/29] exec: only build read_code when needed
` [OpenRISC] [PATCH 26/29] exec: use flush_icache_user_range in read_code
` [OpenRISC] [PATCH 27/29] binfmt_flat: use flush_icache_user_range
` [OpenRISC] [PATCH 28/29] nommu: use flush_icache_user_range in brk and mmap
` [OpenRISC] [PATCH 29/29] module: move the set_fs hack for flush_icache_range to m68k

[OpenRISC] [PATCH v2 00/20] mm: rework free_area_init*() funcitons
 2020-05-26 17:15 UTC  (7+ messages)
` [OpenRISC] [PATCH v2 03/20] mm: remove CONFIG_HAVE_MEMBLOCK_NODE_MAP option
` [OpenRISC] [PATCH v2 05/20] mm: use free_area_init() instead of free_area_init_nodes()
` [OpenRISC] [PATCH v2 08/20] arm64: simplify detection of memory zone boundaries for UMA configs

[OpenRISC] OpenRISC: User mode writing to FPCSR
 2020-05-24 19:12 UTC  (5+ messages)

[OpenRISC] [PATCH 0/8] OpenRISC BFD fixups for Glibc
 2020-05-20 10:41 UTC  (12+ messages)
` [OpenRISC] [PATCH 1/8] or1k: Fix static linking when with .rela.got relocations
` [OpenRISC] [PATCH 2/8] or1k: Fix dynamic TLS symbol flag
` [OpenRISC] [PATCH 3/8] or1k: Add TLS mask to handle multiple model access
` [OpenRISC] [PATCH 4/8] or1k: Fix issue with multiple PCREL relocations
` [OpenRISC] [PATCH 5/8] or1k: TLS offset to use tcb size and section alignment
` [OpenRISC] [PATCH 6/8] or1k: refactor: Rename p to sec_relocs
` [OpenRISC] [PATCH 7/8] or1k: refactor: Rename s to sgot and splt
` [OpenRISC] [PATCH 8/8] or1k: Add dynamic flag to tpoff

[OpenRISC] [PATCH 0/5] OpenRISC GCC Fixes for Glibc Support
 2020-05-19 20:37 UTC  (6+ messages)
` [OpenRISC] [PATCH 1/5] or1k: Implement profile hook calling _mcount
` [OpenRISC] [PATCH 2/5] or1k: Add builtin define to detect hard float
` [OpenRISC] [PATCH 3/5] or1k: Support for softfloat to emulate hw exceptions
` [OpenRISC] [PATCH 4/5] or1k: Add note to indicate execstack
` [OpenRISC] [PATCH 5/5] or1k: Fixup exception header data encodings

[OpenRISC] [PATCH 00/21] mm: rework free_area_init*() funcitons
 2020-05-18 21:38 UTC  (4+ messages)
` [OpenRISC] [PATCH 16/21] mm: remove early_pfn_in_nid() and CONFIG_NODES_SPAN_OTHER_NODES

[OpenRISC] [PATCH v2 00/12] mm: consolidate definitions of page table accessors
 2020-05-15 21:12 UTC  (14+ messages)
` [OpenRISC] [PATCH v2 01/12] mm: don't include asm/pgtable.h if linux/mm.h is already included
` [OpenRISC] [PATCH v2 02/12] mm: introduce include/linux/pgtable.h
` [OpenRISC] [PATCH v2 03/12] mm: reorder includes after introduction of linux/pgtable.h
` [OpenRISC] [PATCH v2 04/12] csky: replace definitions of __pXd_offset() with pXd_index()
` [OpenRISC] [PATCH v2 05/12] m68k/mm/motorola: move comment about page table allocation funcitons
` [OpenRISC] [PATCH v2 06/12] m68k/mm: move {cache, nocahe}_page() definitions close to their user
` [OpenRISC] [PATCH v2 07/12] x86/mm: simplify init_trampoline() and surrounding logic
` [OpenRISC] [PATCH v2 08/12] mm: pgtable: add shortcuts for accessing kernel PMD and PTE
` [OpenRISC] [PATCH v2 09/12] mm: consolidate pte_index() and pte_offset_*() definitions
` [OpenRISC] [PATCH v2 10/12] mm: consolidate pmd_index() and pmd_offset() definitions
` [OpenRISC] [PATCH v2 11/12] mm: consolidate pud_index() and pud_offset() definitions
` [OpenRISC] [PATCH v2 12/12] mm: consolidate pgd_index() and pgd_offset{_k}() definitions

[OpenRISC] [PATCH 00/12] mm: consolidate definitions of page table accessors
 2020-05-13 11:19 UTC  (13+ messages)
` [OpenRISC] [PATCH 03/12] mm: reorder includes after introduction of linux/pgtable.h
` [OpenRISC] [PATCH 06/12] m68k/mm: move {cache, nocahe}_page() definitions close to their user
` [OpenRISC] [PATCH 08/12] mm: pgtable: add shortcuts for accessing kernel PMD and PTE
` [OpenRISC] [PATCH 09/12] mm: consolidate pte_index() and pte_offset_*() definitions
` [OpenRISC] [PATCH 10/12] mm: consolidate pmd_index() and pmd_offset() definitions
` [OpenRISC] [PATCH 11/12] mm: consolidate pud_index() and pud_offset() definitions
` [OpenRISC] [PATCH 12/12] mm: consolidate pgd_index() and pgd_offset{_k}() definitions

[OpenRISC] [PATCH 19/31] riscv: use asm-generic/cacheflush.h
 2020-05-13  6:23 UTC  (3+ messages)


This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox