messages from 2026-04-16 04:57:50 to 2026-07-09 11:16:27 UTC [more...]
[patch 00/18] entry: Consolidate and rework syscall entry handling
2026-07-09 11:16 UTC (62+ messages)
` [patch 01/18] powerpc: Move stack randomization after syscall_enter_from_user_mode()
` [patch 02/18] randomize_kstack: Provide add_random_kstack_offset_irqsoff()
` [patch 03/18] entry: Provide [syscall_]enter_from_user_mode_randomize_stack()
` [patch 04/18] loongarch/syscall: Use syscall_enter_from_user_mode_randomize_stack()
` [patch 05/18] powerpc/syscall: "
` [patch 06/18] riscv/syscall: "
` [patch 07/18] s390/syscall: Use enter_from_user_mode_randomize_stack()
` [patch 08/18] x86/syscall: Use [syscall_]enter_from_user_mode_randomize_stack()
` [patch 09/18] entry: Remove syscall_enter_from_user_mode()
` [patch 10/18] entry: Use syscall number instead of rereading it
` [patch 11/18] seccomp, treewide: Rename and convert __secure_computing() to return boolean
` [patch 12/18] ptrace, treewide: Rename ptrace_report_syscall_entry() to ptrace_report_syscall_permit_entry()
` [patch 13/18] entry: Make trace_syscall_enter() return type bool
` [patch 14/18] entry: Make return type of syscall_trace_enter() bool
` [patch 15/18] x86/entry: Make syscall functions static
` [patch 16/18] x86/entry: Get rid of the sys_ni_syscall() indirection
` [patch 17/18] x86/entry: Simplify the syscall number logic
` [patch 18/18] entry, treewide: Make syscall_enter_from_user_mode[_work]() indicate syscall execution
[PATCH] or1k: Stop allowing referring to SR_F in SImode and fix cmov
2026-07-06 5:53 UTC
[GIT PULL] OpenRISC updates for 7.2
2026-06-21 17:27 UTC (2+ messages)
[PATCH] openrisc: Fix typo in exception comment
2026-06-14 19:57 UTC
[PATCH] or1k: Fix improper placement of cbranchsi4 instructions
2026-06-14 1:26 UTC
[PATCH v3 00/13] Refcounted interrupt disable and SpinLockIrq for rust (Part 1)
2026-06-05 6:45 UTC (19+ messages)
` [PATCH v3 01/13] preempt: Track NMI nesting to separate per-CPU counter
` [PATCH v3 02/13] preempt: Introduce HARDIRQ_DISABLE_BITS
` [PATCH v3 03/13] preempt: Introduce __preempt_count_{sub, add}_return()
` [PATCH v3 04/13] openrisc: Include <linux/cpumask.h> in smp.h
` [PATCH v3 05/13] irq & spin_lock: Add counted interrupt disabling/enabling
` [PATCH v3 06/13] irq: Add KUnit test for refcounted interrupt enable/disable
` [PATCH v3 07/13] locking: Switch to _irq_{disable,enable}() variants in cleanup guards
` [PATCH v3 08/13] sched: Remove the unused preempt_offset parameter of __cant_sleep()
` [PATCH v3 09/13] sched: Avoid signed comparison of preempt_count() in __cant_migrate()
` [PATCH v3 10/13] preempt: Introduce HAS_SEPARATE_PREEMPT_RESCHED_BITS
` [PATCH v3 11/13] arm64: sched/preempt: Enable HAS_SEPARATE_PREEMPT_RESCHED_BITS
` [PATCH v3 12/13] s390/preempt: "
` [PATCH v3 13/13] irq: Optimize reschedule check in local_interrupt_enable()
[PATCH] or1k: Fix 64-bit shifts on OpenRISC
2026-06-04 18:06 UTC
[PATCH v2 00/12] Refcounted interrupt disable and SpinLockIrq for rust (Part 1)
2026-06-04 12:40 UTC (27+ messages)
` [PATCH v2 01/12] preempt: Track NMI nesting to separate per-CPU counter
` [PATCH v2 02/12] preempt: Introduce HARDIRQ_DISABLE_BITS
` [PATCH v2 03/12] preempt: Introduce __preempt_count_{sub, add}_return()
` [PATCH v2 04/12] openrisc: Include <linux/cpumask.h> in smp.h
` [PATCH v2 05/12] irq & spin_lock: Add counted interrupt disabling/enabling
` [PATCH v2 06/12] irq: Add KUnit test for refcounted interrupt enable/disable
` [PATCH v2 07/12] locking: Switch to _irq_{disable,enable}() variants in cleanup guards
` [PATCH v2 08/12] sched: Remove the unused preempt_offset parameter of __cant_sleep()
` [PATCH v2 09/12] sched: Avoid signed comparison of preempt_count() in __cant_migrate()
` [PATCH v2 10/12] preempt: Introduce HAS_SEPARATE_PREEMPT_RESCHED_BITS
` [PATCH v2 11/12] arm64: sched/preempt: Enable HAS_SEPARATE_PREEMPT_RESCHED_BITS
` [PATCH v2 12/12] s390/preempt: "
[PATCH 0/3] OpenRISC Fixes for jump_label SMP Syncing
2026-05-23 5:36 UTC (4+ messages)
` [PATCH 1/3] openrisc: Cache invalidation cleanup
` [PATCH 2/3] openrisc: Add full instruction cache invalidate functions
` [PATCH 3/3] openrisc: Fix jump_label smp syncing
[PATCH] Generate <asm/asm-offsets.h> and remove identical copies in all architectures
2026-05-19 1:18 UTC
[PATCH] openrisc: ptrace: Rename STACK_FRAME_OVERHEAD to KERNEL_REDZONE_SIZE
2026-05-18 7:08 UTC
[PATCH 00/11] Refcounted interrupt disable and SpinLockIrq for rust (Part 1)
2026-05-12 23:33 UTC (22+ messages)
` [PATCH 01/11] preempt: Introduce HARDIRQ_DISABLE_BITS
` [PATCH 02/11] preempt: Track NMI nesting to separate per-CPU counter
` [PATCH 03/11] preempt: Introduce __preempt_count_{sub, add}_return()
` [PATCH 04/11] openrisc: Include <linux/cpumask.h> in smp.h
` [PATCH 05/11] irq & spin_lock: Add counted interrupt disabling/enabling
` [PATCH 06/11] irq: Add KUnit test for refcounted interrupt enable/disable
` [PATCH 07/11] locking: Switch to _irq_{disable,enable}() variants in cleanup guards
` [PATCH 08/11] sched: Remove the unused preempt_offset parameter of __cant_sleep()
` [PATCH 09/11] sched: Avoid signed comparison of preempt_count() in __cant_migrate()
` [PATCH 10/11] preempt: Introduce PREEMPT_COUNT_64BIT
` [PATCH 11/11] arm64: sched/preempt: Enable PREEMPT_COUNT_64BIT
[PULL 0/2] OpenRISC board maintainer updates for 2026-05-05
2026-05-06 18:19 UTC (4+ messages)
` [PULL 1/2] MAINTAINERS: Add myself as maintainer for or1k-sim
` [PULL 2/2] MAINTAINERS: Add myself as the OpenRISC virt maintainer
[PATCH v2] tools/nolibc: add support for OpenRISC / or1k
2026-05-01 7:59 UTC (4+ messages)
[PATCH v3 0/4] arch, mm: consolidate empty_zero_page
2026-04-30 3:25 UTC (2+ messages)
[RFC PATCH v1 0/9] uaccess: Convert small fixed size copy_{to/from}_user() to scoped user access
2026-04-29 11:26 UTC (30+ messages)
` [RFC PATCH v1 1/9] uaccess: Split check_zeroed_user() out of usercopy.c
` [RFC PATCH v1 2/9] uaccess: Convert INLINE_COPY_{TO/FROM}_USER to kconfig and reduce ifdefery
` [RFC PATCH v1 3/9] x86/umip: Be stricter in fixup_umip_exception()
` [RFC PATCH v1 4/9] uaccess: Introduce copy_{to/from}_user_partial()
` [RFC PATCH v1 5/9] uaccess: Switch to copy_{to/from}_user_partial() when relevant
` [RFC PATCH v1 6/9] uaccess: Change copy_{to/from}_user to return -EFAULT
` [RFC PATCH v1 7/9] x86: Add unsafe_copy_from_user()
` [RFC PATCH v1 8/9] arm64: "
` [RFC PATCH v1 9/9] uaccess: Convert small fixed size copy_{to/from}_user() to scoped user access
[PATCH 0/2] MAINTAINERS: Add myself as OpenRISC board maintainer
2026-04-28 19:00 UTC (5+ messages)
` [PATCH 1/2] MAINTAINERS: Add myself as maintainer for or1k-sim
` [PATCH 2/2] MAINTAINERS: Add myself as the OpenRISC virt maintainer
[PATCH] tools/nolibc: add support for OpenRISC / or1k
2026-04-28 17:33 UTC (3+ messages)
[patch 00/38] treewide: Cleanup LATCH, CLOCK_TICK_RATE and get_cycles() [ab]use
2026-04-21 11:22 UTC (18+ messages)
` [patch 05/38] treewide: Remove CLOCK_TICK_RATE
` [patch 07/38] treewide: Consolidate cycles_t
` [patch 18/38] lib/tests: Replace get_cycles() with ktime_get()
` [patch 27/38] m68k: Select ARCH_HAS_RANDOM_ENTROPY
` [patch 32/38] powerpc/spufs: Use mftb() directly
` [patch 33/38] powerpc: Select ARCH_HAS_RANDOM_ENTROPY
` [patch 35/38] s390: "
[RFC 0/2] openrisc: Add support for KProbes
2026-04-16 5:00 UTC (7+ messages)
` [RFC 1/2] openrisc: Add utilities and clean up simulation of instructions
page: next (older) | prev (newer) | latest
- recent:[subjects (threaded)|topics (new)|topics (active)]
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox