Linux OpenRISC platform development
 help / color / mirror / Atom feed
 messages from 2026-05-23 05:36:59 to 2026-07-13 20:27:51 UTC [more...]

[RFC PATCH 00/34] mm: optimize unnecessary loads due to ptep_get() and friends out
 2026-07-13 20:27 UTC  (50+ messages)
` [RFC PATCH 01/34] ARM: mm: make nommu pgd_t a scalar
` [RFC PATCH 02/34] ARM: mm: make 2-level "
` [RFC PATCH 03/34] ARM: mm: remove custom pgdp_get()
` [RFC PATCH 04/34] LoongArch: mm: define pud_leaf() only when PUD exists
` [RFC PATCH 05/34] MIPS: "
` [RFC PATCH 06/34] mm/pgtable: define (pgd|p4d|pud)_leaf() for folded page tables
` [RFC PATCH 07/34] mm/pgtable: define (pgd|p4d|pud)_offset_lockless() "
` [RFC PATCH 08/34] loongarch: kvm: remove stack copy address of pXd in pXd_offset()
` [RFC PATCH 09/34] riscv: "
` [RFC PATCH 10/34] x86: mm: carve out the generic compile-time folded pgtable case in effective_prot()
` [RFC PATCH 11/34] mm: vmscan: remove stack copy address of pud pass in wallk_pud_range()
` [RFC PATCH 12/34] arm64: mm: use proper set_pXd() for generic compile-time folded patable in kasan_early_init()
` [RFC PATCH 13/34] arm64: mm: define pud_set_huge() when __PGTABLE_PMD_FOLDED not defined
` [RFC PATCH 14/34] csky: mm: use proper set_pXd() for generic compile-time folded patable in vmalloc_fault()
` [RFC PATCH 15/34] mips: mm: use proper set_pXd() for generic compile-time folded patable in vmalloc_fault path
` [RFC PATCH 16/34] nios2: "
` [RFC PATCH 17/34] riscv: mm: use proper set_pXd() for generic compile-time folded patable in vmalloc_fault()
` [RFC PATCH 18/34] riscv: mm: use proper set_pXd() for generic compile-time folded patable in setup_vm_final()
` [RFC PATCH 19/34] x86: power: use proper set_pXd() for generic compile-time folded patable in resume_one_md_table_init()
` [RFC PATCH 20/34] x86: kexec: use proper set_pXd() for generic compile-time folded patable in machine_kexec_page_table_set_one()
` [RFC PATCH 21/34] x86: platform: use proper set_pXd() for generic compile-time folded patable in setup_olpc_ofw_pgd()
` [RFC PATCH 22/34] x86: mm: use proper set_pXd() for generic compile-time folded patable in one_md_table_init()
` [RFC PATCH 23/34] x86: mm: skip pud setup when using generic compile-time folded pagetable
` [RFC PATCH 24/34] x86: mm: call try_to_free_pmd_page() when CONFIG_PGTABLE_LEVELS > 2
` [RFC PATCH 25/34] x86: mm: remove usage of pgd_page_vaddr() for CONFIG_x86_PAE
` [RFC PATCH 26/34] x86: mm: define pudp_set_access_flags() when CONFIG_HAVE_ARCH_TRANSPARENT_HUGEPAGE_PUD is enabled only
` [RFC PATCH 27/34] m68k: mm: remove usage of pgd_page_vaddr() for CONFIG_PGTABLE_LEVELS=3
` [RFC PATCH 28/34] arm: mm: use proper pgtable APIs for generic compile-time folded patable in kasan_init()
` [RFC PATCH 29/34] mm/pgtable: disallow calling folded set_pgd/set_p4d/set_pud
` [RFC PATCH 30/34] mm/pgtable: disallow calling folded (pgd|p4d|pud)_page, pgd_page_vaddr() and (p4d|pud)_pgtable
` [RFC PATCH 31/34] mm/pgtable: optimize pmdp_get() and friends for folded pagetable levels
` [RFC PATCH 32/34] openrisc/pgtable: drop __pmd_offset()
` [RFC PATCH 33/34] mm/pgtable: catch abuse of folded dummy pgd_t/p4d_t/pud_t
` [RFC PATCH 34/34] arm64: pgtable: convert pte_present() from macro to static inline

[patch 00/18] entry: Consolidate and rework syscall entry handling
 2026-07-13  7:06 UTC  (97+ messages)
` [patch 01/18] powerpc: Move stack randomization after syscall_enter_from_user_mode()
` [patch 02/18] randomize_kstack: Provide add_random_kstack_offset_irqsoff()
` [patch 03/18] entry: Provide [syscall_]enter_from_user_mode_randomize_stack()
` [patch 04/18] loongarch/syscall: Use syscall_enter_from_user_mode_randomize_stack()
` [patch 05/18] powerpc/syscall: "
` [patch 06/18] riscv/syscall: "
` [patch 07/18] s390/syscall: Use enter_from_user_mode_randomize_stack()
` [patch 08/18] x86/syscall: Use [syscall_]enter_from_user_mode_randomize_stack()
` [patch 09/18] entry: Remove syscall_enter_from_user_mode()
` [patch 10/18] entry: Use syscall number instead of rereading it
` [patch 11/18] seccomp, treewide: Rename and convert __secure_computing() to return boolean
` [patch 12/18] ptrace, treewide: Rename ptrace_report_syscall_entry() to ptrace_report_syscall_permit_entry()
` [patch 13/18] entry: Make trace_syscall_enter() return type bool
` [patch 14/18] entry: Make return type of syscall_trace_enter() bool
` [patch 15/18] x86/entry: Make syscall functions static
` [patch 16/18] x86/entry: Get rid of the sys_ni_syscall() indirection
` [patch 17/18] x86/entry: Simplify the syscall number logic
` [patch 18/18] entry, treewide: Make syscall_enter_from_user_mode[_work]() indicate syscall execution

[PATCH] or1k: Stop allowing referring to SR_F in SImode and fix cmov
 2026-07-06  5:53 UTC 

[GIT PULL] OpenRISC updates for 7.2
 2026-06-21 17:27 UTC  (2+ messages)

[PATCH] openrisc: Fix typo in exception comment
 2026-06-14 19:57 UTC 

[PATCH] or1k: Fix improper placement of cbranchsi4 instructions
 2026-06-14  1:26 UTC 

[PATCH v3 00/13] Refcounted interrupt disable and SpinLockIrq for rust (Part 1)
 2026-06-05  6:45 UTC  (19+ messages)
` [PATCH v3 01/13] preempt: Track NMI nesting to separate per-CPU counter
` [PATCH v3 02/13] preempt: Introduce HARDIRQ_DISABLE_BITS
` [PATCH v3 03/13] preempt: Introduce __preempt_count_{sub, add}_return()
` [PATCH v3 04/13] openrisc: Include <linux/cpumask.h> in smp.h
` [PATCH v3 05/13] irq & spin_lock: Add counted interrupt disabling/enabling
` [PATCH v3 06/13] irq: Add KUnit test for refcounted interrupt enable/disable
` [PATCH v3 07/13] locking: Switch to _irq_{disable,enable}() variants in cleanup guards
` [PATCH v3 08/13] sched: Remove the unused preempt_offset parameter of __cant_sleep()
` [PATCH v3 09/13] sched: Avoid signed comparison of preempt_count() in __cant_migrate()
` [PATCH v3 10/13] preempt: Introduce HAS_SEPARATE_PREEMPT_RESCHED_BITS
` [PATCH v3 11/13] arm64: sched/preempt: Enable HAS_SEPARATE_PREEMPT_RESCHED_BITS
` [PATCH v3 12/13] s390/preempt: "
` [PATCH v3 13/13] irq: Optimize reschedule check in local_interrupt_enable()

[PATCH] or1k: Fix 64-bit shifts on OpenRISC
 2026-06-04 18:06 UTC 

[PATCH v2 00/12] Refcounted interrupt disable and SpinLockIrq for rust (Part 1)
 2026-06-04 12:40 UTC  (27+ messages)
` [PATCH v2 01/12] preempt: Track NMI nesting to separate per-CPU counter
` [PATCH v2 02/12] preempt: Introduce HARDIRQ_DISABLE_BITS
` [PATCH v2 03/12] preempt: Introduce __preempt_count_{sub, add}_return()
` [PATCH v2 04/12] openrisc: Include <linux/cpumask.h> in smp.h
` [PATCH v2 05/12] irq & spin_lock: Add counted interrupt disabling/enabling
` [PATCH v2 06/12] irq: Add KUnit test for refcounted interrupt enable/disable
` [PATCH v2 07/12] locking: Switch to _irq_{disable,enable}() variants in cleanup guards
` [PATCH v2 08/12] sched: Remove the unused preempt_offset parameter of __cant_sleep()
` [PATCH v2 09/12] sched: Avoid signed comparison of preempt_count() in __cant_migrate()
` [PATCH v2 10/12] preempt: Introduce HAS_SEPARATE_PREEMPT_RESCHED_BITS
` [PATCH v2 11/12] arm64: sched/preempt: Enable HAS_SEPARATE_PREEMPT_RESCHED_BITS
` [PATCH v2 12/12] s390/preempt: "

[PATCH 0/3] OpenRISC Fixes for jump_label SMP Syncing
 2026-05-23  5:36 UTC  (2+ messages)
` [PATCH 3/3] openrisc: Fix jump_label smp syncing


This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox