From: Azael Avalos <coproscefalo@gmail.com>
To: Darren Hart <dvhart@infradead.org>,
platform-driver-x86@vger.kernel.org,
linux-kernel@vger.kernel.org
Cc: Azael Avalos <coproscefalo@gmail.com>
Subject: [PATCH v2 0/3] Return codes cleanup
Date: Mon, 29 Sep 2014 20:40:06 -0600 [thread overview]
Message-ID: <1412044809-3366-1-git-send-email-coproscefalo@gmail.com> (raw)
Up for review.
This series of patches are a cleanup to the Toshiba
configuration interface return codes (unification),
since we are now using both the HCI and the SCI, as
well as changing the returned type of the HCI/SCI
read/write functions from acpi_status to u32, since
the "status" was never checked on most of the functions.
Changes since v1:
- Be a bit more verbose on patch 1 about the Toshiba
configuration interface
- Merged patches 3 and 4 into a same patch
Azael Avalos (3):
toshiba_acpi: Rename hci_raw to tci_raw
toshiba_acpi: Unify return codes prefix from HCI/SCI to TOS
toshiba_acpi: Change HCI/SCI functions return code type
drivers/platform/x86/toshiba_acpi.c | 369 ++++++++++++++++++------------------
1 file changed, 183 insertions(+), 186 deletions(-)
--
2.0.0
next reply other threads:[~2014-09-30 2:40 UTC|newest]
Thread overview: 7+ messages / expand[flat|nested] mbox.gz Atom feed top
2014-09-30 2:40 Azael Avalos [this message]
2014-09-30 2:40 ` [PATCH v2 1/3] toshiba_acpi: Rename hci_raw to tci_raw Azael Avalos
2014-09-30 2:40 ` [PATCH v2 2/3] toshiba_acpi: Unify return codes prefix from HCI/SCI to TOS Azael Avalos
2014-09-30 2:40 ` [PATCH v2 3/3] toshiba_acpi: Change HCI/SCI functions return code type Azael Avalos
2014-09-30 20:58 ` Darren Hart
2014-10-01 1:58 ` Rafael J. Wysocki
2014-09-30 20:54 ` [PATCH v2 0/3] Return codes cleanup Darren Hart
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=1412044809-3366-1-git-send-email-coproscefalo@gmail.com \
--to=coproscefalo@gmail.com \
--cc=dvhart@infradead.org \
--cc=linux-kernel@vger.kernel.org \
--cc=platform-driver-x86@vger.kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox