From: Mattia Dongili <malattia@linux.it>
To: Marco Chiappero <marco@absence.it>
Cc: Javier Achirica <achirica@gmail.com>,
Matthew Garrett <mjg59@srcf.ucam.org>,
platform-driver-x86@vger.kernel.org
Subject: Re: [PATCH 23/25] sony-laptop: add ALS support
Date: Wed, 8 Jun 2011 01:07:39 +0900 [thread overview]
Message-ID: <20110607160738.GB4087@kamineko.org> (raw)
In-Reply-To: <4DED620E.60209@absence.it>
On Tue, Jun 07, 2011 at 01:26:06AM +0200, Marco Chiappero wrote:
> Il 07/06/2011 00:24, Mattia Dongili ha scritto:
> >>sony-acpid is already doing this without listening for key events
> >>(we can do that but we miss any other different backlight correction
> >>otherwise).
> >
> >how many sources of backlight changes do you have?
>
> Potentially many, user keys, power saving options, proximity
> sensors, als, etc. and any other user defined (eg. low backlight
> setting when compiling software).
>
> >A system should have
> >only one application trying to control the backlight, having more than
> >one is asking for trouble in the first place.
>
> But it is not when using sony-acpid.
How do you coordinate different policies, one trying to increase and one
trying to decrease brightness?
Or even, say you have two sony-acpid-like applications working with
different policies, how do you solve that? Create another backlight
sysfs file that overrules the other two?
Do you see where I'm going? I think you're trying to slove a problem at
the bottom of the stack when it should be solved at the top.
> >Also, if I echo a number to /sys/... directly I would expect that to be
> >applied no matter what and without any magic correction going on.
>
> Again another wrong assumption, IMO: if the user enables the
> autodimming feature everything should follow this rule. You are
> saying is that if you echo to sysfs, you really want to mess things
> up... really hard to believe.
possibly, I guess I just can't make my mind up about the fact that you
could set a backlight value via /sys/class/backlight/ that is not what
is going to applied.
> >>The small big issue is that not every notebook use the same LCD
> >>panel, so, in theory, different calculations are required (and this
> >>also the reason why a model specific parameter list is also provided
> >>by every Vaio notebook too). A single suboptimal formula for
> >>everybody is not likely to provide satisfactory results.
> >
> >this is something else that should be thought of presenting in a unified
> >way to userspace.
>
> Frankly, I cannot see how, especially right now... We have some
> hardware designed in a certain way that allows to be used only in
> that way, small changes are possible, but I really doubt that what
> you are asking for is possible.
I don't see how presenting illumination data and correction factors and
giving a way to change lid backlight is such an unreasonable request.
Why do you think is not possible with als chips you find on vaios?
...
> >the backlight change request is initiated in userspace already,
>
> Right, but how can you be sure when you have a backlight device that
> can be accessed by anything?
I'm not following you here. Sure about what? Also, is als_backlight only
accessible to a few privileged ones?
> >So again, can you split the patch in two so that we have the driver in
> >one patch and the interaction/integration part in another?
>
> Please specify "interaction/integration part". There is almost
> nothing to be removed if you want code that makes sense and
> something working, if you specify a particular function I'll try to
> remove it, if it is feasible, otherwise be more specific, please.
I'd just like to see just the ALS driver in one patch, all the
managed/backlight stuff in another.
PS: to tell you the truth, I think the way Sony implemented all this
autodimming idea is just a clever workaround with limitations and
constraints they find in Windows where I guess they couldn't strip off
some of the standard acpi components. It has nothing to do with
hardware.
--
mattia
:wq!
next prev parent reply other threads:[~2011-06-07 16:07 UTC|newest]
Thread overview: 125+ messages / expand[flat|nested] mbox.gz Atom feed top
2011-06-03 15:22 [PATCH 0/25] sony-laptop: code improvements and support extension for newer Vaios Marco Chiappero
2011-06-03 15:26 ` [PATCH 1/25] sony-laptop: use usigned data type when calling ACPI methods Marco Chiappero
2011-06-03 15:28 ` [PATCH 2/25] sony-laptop: simple_strtoul replaced by strict_strtoul Marco Chiappero
2011-06-12 21:56 ` Mattia Dongili
2011-06-03 15:29 ` [PATCH 3/25] sony-laptop: new ACPI SN06 method helper functions Marco Chiappero
2011-06-03 15:32 ` [PATCH 4/25] sony-laptop: new SNC setup and cleanup functions Marco Chiappero
2011-06-12 22:21 ` Mattia Dongili
2011-06-13 0:01 ` Marco Chiappero
2011-06-13 1:28 ` Mattia Dongili
2011-06-13 9:39 ` Marco Chiappero
2011-06-13 13:42 ` Mattia Dongili
2011-06-13 14:10 ` Marco Chiappero
2011-06-18 22:50 ` Marco Chiappero
2011-06-18 23:06 ` Marco Chiappero
2011-06-28 9:27 ` Mattia Dongili
2011-06-28 10:04 ` Marco Chiappero
2011-07-01 10:54 ` Marco Chiappero
2011-07-13 22:19 ` Marco Chiappero
2011-07-14 22:05 ` Mattia Dongili
2011-07-18 14:49 ` Marco Chiappero
2011-07-19 22:03 ` Mattia Dongili
2011-06-20 13:49 ` Marco Chiappero
2011-06-03 15:33 ` [PATCH 5/25] sony-laptop: new handles " Marco Chiappero
2011-06-03 15:35 ` [PATCH 6/25] sony-laptop: new notebook controller resume function Marco Chiappero
2011-06-03 15:36 ` [PATCH 7/25] sony-laptop: sony_nc_function_setup modifications Marco Chiappero
2011-06-03 15:38 ` [PATCH 8/25] sony-laptop: sony_nc_notify rewritten and improved Marco Chiappero
2011-06-04 8:43 ` Mattia Dongili
2011-06-04 11:26 ` Marco Chiappero
2011-06-05 22:38 ` Mattia Dongili
2011-06-06 12:23 ` Marco Chiappero
2011-06-06 12:42 ` Mattia Dongili
2011-06-06 12:45 ` Marco Chiappero
2011-06-20 14:00 ` Marco Chiappero
2011-07-19 21:30 ` Mattia Dongili
2011-06-04 12:42 ` Matthew Garrett
2011-06-04 14:22 ` Marco Chiappero
2011-06-04 14:30 ` Matthew Garrett
2011-06-04 14:34 ` Marco Chiappero
2011-06-04 14:36 ` Matthew Garrett
2011-06-04 14:42 ` Marco Chiappero
2011-06-04 14:45 ` Matthew Garrett
2011-06-04 15:04 ` Corentin Chary
2011-06-04 16:50 ` Marco Chiappero
2011-06-04 20:22 ` Alan Cox
2011-06-05 17:48 ` Marco Chiappero
2011-06-05 19:14 ` Alan Cox
2011-06-05 20:13 ` Marco Chiappero
2011-06-03 15:39 ` [PATCH 9/25] sony-laptop: sony_walk_callback moved for better readability Marco Chiappero
2011-06-03 15:41 ` [PATCH 10/25] sony-laptop: keyboard backlight support extended to newer Vaios Marco Chiappero
2011-06-04 7:58 ` Mattia Dongili
2011-06-04 10:30 ` Marco Chiappero
2011-06-04 11:23 ` Mattia Dongili
2011-06-04 11:41 ` Marco Chiappero
2011-06-05 22:33 ` Mattia Dongili
2011-06-06 12:27 ` Marco Chiappero
2011-06-10 12:31 ` Marco Chiappero
2011-06-12 22:24 ` Mattia Dongili
2011-06-13 14:28 ` Marco Chiappero
2011-06-18 4:15 ` Mattia Dongili
2011-06-03 15:42 ` [PATCH 11/25] sony-laptop: rfkill improvements Marco Chiappero
2011-06-04 7:59 ` Mattia Dongili
2011-06-03 15:43 ` [PATCH 12/25] sony-laptop: input core improvements improvements Marco Chiappero
2011-06-04 8:07 ` Mattia Dongili
2011-06-04 10:42 ` Marco Chiappero
[not found] ` <4DEA0C27.1000508-YK5v5TwyeXionA0d6jMUrA@public.gmane.org>
2011-06-04 12:44 ` Matthew Garrett
2011-06-04 13:11 ` Marco Chiappero
2011-06-08 8:26 ` Joey Lee
2011-06-04 15:21 ` Marco Chiappero
[not found] ` <4DEA4D67.8000009-YK5v5TwyeXionA0d6jMUrA@public.gmane.org>
2011-06-04 16:40 ` Mattia Dongili
[not found] ` <20110604164021.GA12552-pM3i+3kAS8Rg9hUCZPvPmw@public.gmane.org>
2011-06-04 16:58 ` Marco Chiappero
2011-06-05 22:24 ` Mattia Dongili
2011-06-06 13:26 ` Marco Chiappero
2011-06-07 14:23 ` Mattia Dongili
2011-06-07 15:15 ` Marco Chiappero
2011-06-07 16:24 ` Mattia Dongili
2011-06-07 17:59 ` Marco Chiappero
2011-06-20 13:53 ` Marco Chiappero
2011-07-01 11:12 ` Marco Chiappero
2011-07-01 12:50 ` Matthew Garrett
2011-07-01 14:03 ` Marco Chiappero
2011-07-01 14:09 ` Matthew Garrett
2011-07-01 14:20 ` Marco Chiappero
2011-07-01 15:06 ` Matthew Garrett
2011-07-01 15:11 ` Marco Chiappero
2011-07-01 15:53 ` Matthew Garrett
2011-07-01 16:12 ` Marco Chiappero
2011-07-19 21:26 ` Mattia Dongili
2011-06-03 15:45 ` [PATCH 13/25] sony-laptop: code style fixes Marco Chiappero
2011-06-03 15:46 ` [PATCH 14/25] sony-laptop: battery care functionality added Marco Chiappero
2011-06-03 17:33 ` [PATCH 15/25] sony-laptop: add thermal control feature Marco Chiappero
2011-06-03 17:45 ` [PATCH 16/25] sony-laptop: add HDD shock protection Marco Chiappero
2011-06-03 17:54 ` [PATCH 17/25] sony-laptop: add resume from S4/S3 when opening the lid Marco Chiappero
2011-06-03 18:02 ` [PATCH 18/25] sony-laptop: add control file for the HighSpeed Charging feature Marco Chiappero
2011-06-03 18:16 ` [PATCH 19/25] sony-laptop: add touchpad enable/disable control file Marco Chiappero
2011-06-03 20:23 ` Dmitry Torokhov
2011-06-03 20:33 ` Marco Chiappero
2011-06-03 21:00 ` Dmitry Torokhov
2011-06-03 21:46 ` Marco Chiappero
2011-06-03 22:12 ` Dmitry Torokhov
2011-06-04 1:54 ` Marco Chiappero
2011-06-04 7:09 ` Mattia Dongili
2011-06-04 11:15 ` Marco Chiappero
2011-06-04 12:46 ` Matthew Garrett
2011-06-04 14:28 ` Marco Chiappero
2011-06-03 18:28 ` [PATCH 20/25] sony-laptop: add fan related controls Marco Chiappero
2011-06-03 18:50 ` [PATCH 21/25] sony-laptop: add optical device power control Marco Chiappero
2011-06-03 19:27 ` [PATCH 22/25] sony-laptop: forward Hybrid GFX notifications to userspace Marco Chiappero
2011-06-04 8:48 ` Mattia Dongili
2011-06-20 21:12 ` Marco Chiappero
2011-07-19 21:50 ` Mattia Dongili
2011-06-03 19:49 ` [PATCH 23/25] sony-laptop: add ALS support Marco Chiappero
2011-06-05 5:31 ` Mattia Dongili
2011-06-05 22:21 ` Marco Chiappero
2011-06-06 7:41 ` Javier Achirica
2011-06-06 13:08 ` Mattia Dongili
2011-06-06 13:51 ` Marco Chiappero
2011-06-06 22:24 ` Mattia Dongili
2011-06-06 23:26 ` Marco Chiappero
2011-06-07 16:07 ` Mattia Dongili [this message]
2011-06-07 17:50 ` Marco Chiappero
2011-06-07 22:39 ` Mattia Dongili
2011-06-08 9:52 ` Marco Chiappero
2011-06-03 20:10 ` [PATCH 24/25] sony-laptop: backlight device changes Marco Chiappero
2011-06-03 20:10 ` [PATCH 25/25] sony-laptop: update copyright owners Marco Chiappero
2011-06-04 8:54 ` [PATCH 0/25] sony-laptop: code improvements and support extension for newer Vaios Mattia Dongili
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20110607160738.GB4087@kamineko.org \
--to=malattia@linux.it \
--cc=achirica@gmail.com \
--cc=marco@absence.it \
--cc=mjg59@srcf.ucam.org \
--cc=platform-driver-x86@vger.kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox