From: Jonathan Woithe <jwoithe@just42.net>
To: Micha?? K??pie?? <kernel@kempniu.pl>
Cc: Darren Hart <dvhart@infradead.org>,
Andy Shevchenko <andy@infradead.org>,
platform-driver-x86@vger.kernel.org,
linux-kernel@vger.kernel.org
Subject: Re: [PATCH v3 0/4] fujitsu_init() cleanup
Date: Fri, 10 Mar 2017 21:04:52 +1030 [thread overview]
Message-ID: <20170310103452.GA21396@marvin.atrad.com.au> (raw)
In-Reply-To: <20170307101516.9852-1-kernel@kempniu.pl>
On Tue, Mar 07, 2017 at 11:15:12AM +0100, Micha?? K??pie?? wrote:
> These patches should make fujitsu_init() a bit more palatable. No
> changes are made to platform device code yet, for clarity these will be
> posted in a separate series after this one gets applied.
>
> Changes from v2:
>
> - Patch 2/4 from v2 did not work as expected and was thus replaced
> with a rebased version of patch 3/4 from v1.
>
> - Added a check in patch 3/4 to prevent a NULL dereference when
> ACPI device FUJ02B1 is not present and ACPI device FUJ02E3 is.
>
> Changes from v1:
>
> - Rebase on top of reworked Alan Jenkins' cleanup patch series.
>
> - Drop patch 1/4 from v1 as it has already been applied in reworked
> Alan Jenkins' cleanup patch series.
>
> - Patch 3/4 from v1 has been replaced with a completely different one
> (patch 2/4). It needs to be tested on a relevant machine as it is
> based purely on a dump of a DSDT table (further details can be found
> in the patch itself).
>
> - Patch 3/4 in v2 is a rebased version of patch 8/10 from the reworked
> Alan Jenkins' cleanup patch series. Patch 2/4 from v2 (the one
> mentioned in the previous bullet point) ensures this one can be
> safely applied without causing a NULL dereference under any
> circumstances.
>
> drivers/platform/x86/fujitsu-laptop.c | 98 ++++++++++++++++++-----------------
> 1 file changed, 50 insertions(+), 48 deletions(-)
Having tested this V3 patch series on an S7020 I can confirm that there are
no key functional regressions with respect to the module components utilised
by this model: the bl_power and brightness controls work in the same way as
they have in the past.
My backlight control scripts failed because the attribute path they expected
(/sys/devices/virtual/backlight/fujitsu-laptop/) did not exist. Instead
this patch creates /sys/devices/virtual/backlight/fujitsu_laptop/, the
difference being an underscore instead of a hyphen. This API regression was
caused by the introduction of KBUILD_MODNAME to replace the literal
"fujitsu-laptop" in patch 1/4. While it would be nice to use KBUILD_MODNAME
instead of the string literal, doing so does constitute a userspace API
breakage which is best avoided. I therefore suggest KBUILD_MODNAME be
replaced with "fujitsu-laptop" in patch 1/4.
If the above substitution is made in patch 1/4 I am happy to see this series
applied. It represents a further worthwhile improvement to the
fujitsu-laptop driver which will facilitate future maintenance and provide a
more consistent basis for upcoming improvements.
Tested-by: Jonathan Woithe <jwoithe@just42.net>
Reviewed-by: Jonathan Woithe <jwoithe@just42.net>
Regards
jonathan
prev parent reply other threads:[~2017-03-10 10:34 UTC|newest]
Thread overview: 10+ messages / expand[flat|nested] mbox.gz Atom feed top
2017-03-07 10:15 [PATCH v3 0/4] fujitsu_init() cleanup Michał Kępień
2017-03-07 10:15 ` [PATCH v3 1/4] platform/x86: fujitsu-laptop: register backlight device in a separate function Michał Kępień
2017-03-10 9:08 ` Michał Kępień
2017-03-10 10:42 ` Jonathan Woithe
2017-03-10 10:45 ` Michał Kępień
2017-03-07 10:15 ` [PATCH v3 2/4] platform/x86: fujitsu-laptop: sync backlight power status in acpi_fujitsu_laptop_add() Michał Kępień
2017-03-07 10:15 ` [PATCH v3 3/4] platform/x86: fujitsu-laptop: only register backlight device if FUJ02B1 is present Michał Kępień
2017-03-07 10:15 ` [PATCH v3 4/4] platform/x86: fujitsu-laptop: cleanup error labels in fujitsu_init() Michał Kępień
2017-03-08 6:49 ` [PATCH v3 0/4] fujitsu_init() cleanup Jonathan Woithe
2017-03-10 10:34 ` Jonathan Woithe [this message]
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20170310103452.GA21396@marvin.atrad.com.au \
--to=jwoithe@just42.net \
--cc=andy@infradead.org \
--cc=dvhart@infradead.org \
--cc=kernel@kempniu.pl \
--cc=linux-kernel@vger.kernel.org \
--cc=platform-driver-x86@vger.kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox