From mboxrd@z Thu Jan 1 00:00:00 1970 From: Jarkko Sakkinen Subject: Re: [PATCH v15 11/23] x86/sgx: Add definitions for SGX's CPUID leaf and variable sub-leafs Date: Mon, 5 Nov 2018 16:35:46 +0200 Message-ID: <20181105143415.GA2798@linux.intel.com> References: <20181102231320.29164-1-jarkko.sakkinen@linux.intel.com> <20181102231320.29164-12-jarkko.sakkinen@linux.intel.com> Mime-Version: 1.0 Content-Type: text/plain; charset=us-ascii Return-path: Content-Disposition: inline In-Reply-To: Sender: linux-kernel-owner@vger.kernel.org To: Andy Shevchenko Cc: "maintainer:X86 ARCHITECTURE (32-BIT AND 64-BIT)" , Platform Driver , linux-sgx@vger.kernel.org, Dave Hansen , sean.j.christopherson@intel.com, nhorman@redhat.com, npmccallum@redhat.com, serge.ayoun@intel.com, shay.katz-zamir@intel.com, haitao.huang@intel.com, mark.shanahan@intel.com, Andy Shevchenko , Thomas Gleixner , Ingo Molnar , Borislav Petkov , "H. Peter Anvin" , Linux Kernel Mailing List List-Id: platform-driver-x86.vger.kernel.org On Sat, Nov 03, 2018 at 03:11:39PM +0200, Andy Shevchenko wrote: > On Sat, Nov 3, 2018 at 1:16 AM Jarkko Sakkinen > wrote: > > > > SGX defines its own CPUID leaf, 0x12, along with a variable number of > > sub-leafs. Sub-leafs 0 and 1 are always available if SGX is supported > > and enumerate various SGX features, e.g. instruction sets and enclave > > capabilities. Sub-leafs 2+ are variable, both in their existence and > > in what they enumerate. Bits 3:0 of EAX report the sub-leaf type, > > with the remaining bits in EAX, EBX, ECX and EDX being type-specific. > > Currently, the only known sub-leaf type enumerates an EPC section. An > > EPC section is simply a range of EPC memory available to software. > > The "list" of varaible SGX sub-leafs is NULL-terminated, i.e. software > > is expected to query CPUID until an invalid sub-leaf is encountered. > > > + SGX_CPUID_SUB_LEAF_TYPE_MASK = 0xF, > > GENMASK() if it suits here? > > P.S. Btw, BIT() and GENMASK() macros are now in a separate header, > i.e. linux/bits.h, perhaps you might need to revisit code to include > it explicitly Agreed. I would also think that is should be renamed simply as SGX_CPUID_SUBLEAF_MASK. /Jarkko