From mboxrd@z Thu Jan 1 00:00:00 1970 From: Thomas Gleixner Subject: Re: [patch 08/22] ACPI: Convert to new X86 CPU match macros Date: Fri, 20 Mar 2020 21:32:26 +0100 Message-ID: <87bloqpy1x.fsf@nanos.tec.linutronix.de> References: <20200320131345.635023594@linutronix.de> <20200320131509.467730627@linutronix.de> Mime-Version: 1.0 Content-Type: text/plain Return-path: In-Reply-To: Sender: linux-hwmon-owner@vger.kernel.org To: Andy Shevchenko Cc: LKML , "maintainer:X86 ARCHITECTURE (32-BIT AND 64-BIT)" , Greg Kroah-Hartman , Mark Gross , Tony Luck , "Rafael J. Wysocki" , Len Brown , ACPI Devel Maling List , Paolo Bonzini , Darren Hart , Andy Shevchenko , Viresh Kumar , Linux PM , Srinivas Pandruvada , linux-edac@vger.kernel.org, Platform Driver , Jean Delvare , Guenter Roeck li List-Id: platform-driver-x86.vger.kernel.org Andy Shevchenko writes: > On Fri, Mar 20, 2020 at 3:19 PM Thomas Gleixner wrote: >> >> The new macro set has a consistent namespace and uses C99 initializers >> instead of the grufty C89 ones. >> >> Rename the local macro wrapper to X86_MATCH for consistency. It stays for >> readability sake. > >> + X86_MATCH_INTEL_FAM6_MODEL(ATOM_SILVERMONT, NULL), >> + X86_MATCH_INTEL_FAM6_MODEL(ATOM_AIRMONT, NULL), > >> -#define ICPU(model) { X86_VENDOR_INTEL, 6, model, X86_FEATURE_ANY, } >> +#define X86_MATCH(model) X86_MATCH_INTEL_FAM6_MODEL(model, NULL) > > Maybe we can do a generic macro to avoid all these ', NULL' repetitions? I opted for having the data argument everywhere to keep the macro maze small. And we have enough places where data is actually used. Thanks, tglx