X86 platform drivers
 help / color / mirror / Atom feed
 messages from 2025-04-17 09:29:45 to 2025-04-23 13:20:12 UTC [more...]

[PATCH v2 0/2] Handle bad policies for AMD-PMF better
 2025-04-23 13:18 UTC  (3+ messages)
` [PATCH v2 1/2] drivers/platform/x86/amd: pmf: Check for invalid sideloaded Smart PC Policies
` [PATCH v2 2/2] drivers/platform/x86/amd: pmf: Check for invalid "

[PATCH v2] platform/x86: thinkpad-acpi: Add support for new hotkey for camera shutter switch
 2025-04-23 12:57 UTC  (4+ messages)

[PATCH 0/2] Handle bad policies for AMD-PMF better
 2025-04-23 12:43 UTC  (5+ messages)
` [PATCH 1/2] drivers/platform/x86/amd: pmf: Check for invalid Smart PC Policies
` [PATCH 2/2] drivers/platform/x86/amd: pmf: Handle bad policies in amd_pmf_get_pb_data()

[PATCH v7 0/1] platform/x86: Introduce dasharo-acpi platform driver
 2025-04-23 12:08 UTC  (3+ messages)
` [PATCH v7 1/1] "

[PATCHv6] platform/x86: ideapad-laptop: added support for some new buttons
 2025-04-23 11:38 UTC  (3+ messages)

[PATCH] platform/x86: asus-wmi: Disable OOBE state after resume from hibernation
 2025-04-23 11:38 UTC  (2+ messages)

[PATCH] platform/x86: alienware-wmi-wmax: Add support for Alienware m15 R7
 2025-04-23 11:38 UTC  (2+ messages)

[PATCH] platform/x86/intel: hid: Add Pantherlake support
 2025-04-23 11:38 UTC  (3+ messages)

[v10 01/11] platform/x86/amd/hsmp: Create hsmp/ directory
 2025-04-23 10:28 UTC  (7+ messages)
` [v10 08/11] platform/x86/amd/hsmp: Create separate ACPI, plat and common drivers
  ` [BUG?] "

[PATCH v4 0/9] platform/x86: int3472: Add handshake pin support
 2025-04-23  9:46 UTC  (14+ messages)
` [PATCH v4 1/9] platform/x86: int3472: Add skl_int3472_register_clock() helper
` [PATCH v4 2/9] platform/x86: int3472: Stop setting a supply-name for GPIO regulators
` [PATCH v4 3/9] platform/x86: int3472: Drop unused gpio field from struct int3472_gpio_regulator
` [PATCH v4 4/9] platform/x86: int3472: Rework AVDD second sensor quirk handling
` [PATCH v4 5/9] platform/x86: int3472: Make regulator supply name configurable
` [PATCH v4 6/9] platform/x86: int3472: Avoid GPIO regulator spikes
` [PATCH v4 7/9] platform/x86: int3472: Prepare for registering more than 1 GPIO regulator
` [PATCH v4 8/9] platform/x86: int3472: Add handshake pin support
` [PATCH v4 9/9] platform/x86: int3472: Debug log when remapping pins

[RFC PATCH v2 00/34] MSR refactor with new MSR instructions support
 2025-04-23  9:27 UTC  (54+ messages)
` [RFC PATCH v2 01/34] x86/msr: Move rdtsc{,_ordered}() to <asm/tsc.h>
` [RFC PATCH v2 02/34] x86/msr: Remove rdpmc()
` [RFC PATCH v2 03/34] x86/msr: Rename rdpmcl() to rdpmcq()
` [RFC PATCH v2 04/34] x86/msr: Convert rdpmcq() into a function
` [RFC PATCH v2 05/34] x86/msr: Return u64 consistently in Xen PMC read functions
` [RFC PATCH v2 06/34] x86/msr: Use the alternatives mechanism to read PMC
` [RFC PATCH v2 07/34] x86/msr: Convert __wrmsr() uses to native_wrmsr{,q}() uses
` [RFC PATCH v2 08/34] x86/msr: Convert a native_wrmsr() use to native_wrmsrq()
` [RFC PATCH v2 09/34] x86/msr: Add the native_rdmsrq() helper
` [RFC PATCH v2 10/34] x86/msr: Convert __rdmsr() uses to native_rdmsrq() uses
` [RFC PATCH v2 11/34] x86/msr: Remove calling native_{read,write}_msr{,_safe}() in pmu_msr_{read,write}()
` [RFC PATCH v2 12/34] x86/msr: Remove pmu_msr_{read,write}()
` [RFC PATCH v2 13/34] x86/xen/msr: Remove the error pointer argument from set_reg()
` [RFC PATCH v2 14/34] x86/msr: refactor pv_cpu_ops.write_msr{_safe}()
` [RFC PATCH v2 15/34] x86/msr: Replace wrmsr(msr, low, 0) with wrmsrq(msr, low)
` [RFC PATCH v2 16/34] x86/msr: Change function type of native_read_msr_safe()
` [RFC PATCH v2 17/34] x86/cpufeatures: Add a CPU feature bit for MSR immediate form instructions
` [RFC PATCH v2 18/34] x86/opcode: Add immediate form MSR instructions
` [RFC PATCH v2 19/34] x86/extable: Add support for "
` [RFC PATCH v2 20/34] x86/extable: Implement EX_TYPE_FUNC_REWIND
` [RFC PATCH v2 21/34] x86/msr: Utilize the alternatives mechanism to write MSR
` [RFC PATCH v2 22/34] x86/msr: Utilize the alternatives mechanism to read MSR
` [RFC PATCH v2 23/34] x86/extable: Remove new dead code in ex_handler_msr()
` [RFC PATCH v2 24/34] x86/mce: Use native MSR API __native_{wr,rd}msrq()
` [RFC PATCH v2 25/34] x86/msr: Rename native_wrmsrq() to native_wrmsrq_no_trace()
` [RFC PATCH v2 26/34] x86/msr: Rename native_wrmsr() to native_wrmsr_no_trace()
` [RFC PATCH v2 27/34] x86/msr: Rename native_write_msr() to native_wrmsrq()
` [RFC PATCH v2 28/34] x86/msr: Rename native_write_msr_safe() to native_wrmsrq_safe()
` [RFC PATCH v2 29/34] x86/msr: Rename native_rdmsrq() to native_rdmsrq_no_trace()
` [RFC PATCH v2 30/34] x86/msr: Rename native_rdmsr() to native_rdmsr_no_trace()
` [RFC PATCH v2 31/34] x86/msr: Rename native_read_msr() to native_rdmsrq()
` [RFC PATCH v2 32/34] x86/msr: Rename native_read_msr_safe() to native_rdmsrq_safe()
` [RFC PATCH v2 33/34] x86/msr: Move the ARGS macros after the MSR read/write APIs
` [RFC PATCH v2 34/34] x86/msr: Convert native_rdmsr_no_trace() uses to native_rdmsrq_no_trace() uses

[PATCH 0/5] intel-uncore-freq: Add agent_types and die_id attributes
 2025-04-23  9:10 UTC  (7+ messages)
` [PATCH 1/5] platform/x86/intel-uncore-freq: Add attributes to show agent types
` [PATCH 2/5] Documentation: admin-guide: pm: Add documentation for agent_types
` [PATCH 3/5] platform/x86/intel: power-domains: Add interface to get Linux die ID
` [PATCH 4/5] platform/x86/intel-uncore-freq: Add attributes to show die_id
` [PATCH 5/5] Documentation: admin-guide: pm: Add documentation for die_id

[PATCH v5] platform/x86: portwell-ec: Add GPIO and WDT driver for Portwell EC
 2025-04-23  8:38 UTC  (2+ messages)

[PATCH v1 1/1] platform/mellanox: mlxbf-pmc: Support additional PMC blocks
 2025-04-23  8:31 UTC 

[PATCH 0/2] platform/x86: firmware_attributes_class: Provide a highlevel interface
 2025-04-23  8:05 UTC  (3+ messages)
` [PATCH 1/2] "

[PATCH 0/2] platform/x86: alienware-wmi-wmax: Add support for GPIO methods
 2025-04-23  7:49 UTC  (3+ messages)
` [PATCH 1/2] platform/x86: alienware-wmi-wmax: Expose GPIO debug methods
` [PATCH 2/2] Documentation: wmi: alienware-wmi: Add GPIO control documentation

[PATCH v9 00/13] Add support for AMD hardware feedback interface
 2025-04-23  1:46 UTC  (14+ messages)
` [PATCH v9 01/13] Documentation: x86: Add AMD Hardware Feedback Interface documentation
` [PATCH v9 02/13] MAINTAINERS: Add maintainer entry for AMD Hardware Feedback Driver
` [PATCH v9 03/13] x86/msr-index: define AMD heterogeneous CPU related MSR
` [PATCH v9 04/13] platform/x86: hfi: Introduce AMD Hardware Feedback Interface Driver
` [PATCH v9 05/13] platform/x86: hfi: parse CPU core ranking data from shared memory
` [PATCH v9 06/13] platform/x86: hfi: init per-cpu scores for each class
` [PATCH v9 07/13] platform/x86: hfi: add online and offline callback support
` [PATCH v9 08/13] platform/x86: hfi: add power management callback
` [PATCH v9 09/13] x86/process: Clear hardware feedback history for AMD processors
` [PATCH v9 10/13] cpufreq/amd-pstate: Disable preferred cores on designs with workload classification
` [PATCH v9 11/13] platform/x86/amd: hfi: Set ITMT priority from ranking data
` [PATCH v9 12/13] platform/x86/amd: hfi: Add debugfs support
` [PATCH v9 13/13] x86/itmt: Add debugfs file to show core priorities

[PATCH v5 0/5] AMD Zen debugging documentation
 2025-04-22 23:48 UTC  (6+ messages)
` [PATCH v5 1/5] Documentation: Add AMD Zen debugging document
` [PATCH v5 2/5] i2c: piix4: Depends on X86
` [PATCH v5 3/5] i2c: piix4: Move SB800_PIIX4_FCH_PM_ADDR definition to amd/fch.h
` [PATCH v5 4/5] platform/x86/amd: pmc: use FCH_PM_BASE definition
` [PATCH v5 5/5] x86/CPU/AMD: Print the reason for the last reset

[PATCH v7] platform/x86: Add AMD ISP platform config for OV05C10
 2025-04-22 15:37 UTC  (2+ messages)

[PATCH AUTOSEL 6.14 10/30] platform/x86: x86-android-tablets: Add "9v" to Vexia EDU ATLA 10 tablet symbols
 2025-04-22  2:15 UTC  (2+ messages)
` [PATCH AUTOSEL 6.14 11/30] platform/x86: x86-android-tablets: Add Vexia Edu Atla 10 tablet 5V data

[PATCH] platform/x86: thinkpad-acpi: Add support for new hotkey for camera shutter switch
 2025-04-22  0:50 UTC  (9+ messages)

[PATCH v4 0/4] Create Intel PMC SSRAM Telemetry driver
 2025-04-21 21:10 UTC  (5+ messages)
` [PATCH v4 1/4] platform/x86:intel/vsec: Change return type of intel_vsec_register
` [PATCH v4 2/4] platform/x86:intel/pmc: Create Intel PMC SSRAM Telemetry driver
` [PATCH v4 3/4] platform/x86:intel/pmc: Move error handling to init function
` [PATCH v4 4/4] platform/x86:intel/pmc: Improve pmc_core_get_lpm_req()

[PATCH platform-next v9 0/6] Add support for new systems, amendments
 2025-04-21  9:20 UTC  (7+ messages)
` [PATCH platform-next v9 1/6] platform/mellanox: mlxreg-dpu: Add initial support for Nvidia DPU
` [PATCH platform-next v9 2/6] platform: mellanox: Introduce support of Nvidia smart switch
` [PATCH platform-next v9 3/6] platform: mellanox: Cosmetic changes to improve code style
` [PATCH platform-next v9 4/6] platform: mellanox: mlx-platform: Add support for new Nvidia system
` [PATCH platform-next v9 5/6] platform: mellanox: nvsw-sn2200: Add support for new system flavour
` [PATCH platform-next v9 6/6] Documentation/ABI: Add new attribute for mlxreg-io sysfs interfaces

[PATCH] ACPI: EC: Fix CPU frequency limitation on AMD platforms after suspend/resume
 2025-04-19 18:03 UTC  (2+ messages)

[PATCH] platform/x86/amd/hsmp: change driver name from amd_hsmp to hsmp_acpi
 2025-04-19  9:00 UTC  (2+ messages)

[PATCH] platform/x86: intel_pmc_core: Fix uninitialized pmc/map in pmc_core_send_ltr_ignore
 2025-04-18  9:06 UTC  (3+ messages)

[PATCH v4 0/5] AMD Zen debugging documentation
 2025-04-17 22:21 UTC  (4+ messages)
` [PATCH v4 2/5] i2c: piix4: Depends on X86

[PATCH] platform/x86: alienware-wmi-wmax: Fix uninitialized variable due to bad error handling
 2025-04-17 20:27 UTC  (4+ messages)

[GIT PULL] platform-drivers-x86 for v6.15-3
 2025-04-17 18:57 UTC  (2+ messages)

[PATCH v9 00/15] hwmon: (oxpsensors) Add devices, features, fix ABI and move to platform/x86
 2025-04-17 17:53 UTC  (16+ messages)
` [PATCH v9 01/15] hwmon: (oxp-sensors) Distinguish the X1 variants
` [PATCH v9 02/15] hwmon: (oxp-sensors) Add all OneXFly variants
` [PATCH v9 03/15] platform/x86: oxpec: Move hwmon/oxp-sensors to platform/x86
` [PATCH v9 04/15] ABI: testing: sysfs-class-oxp: add missing documentation
` [PATCH v9 05/15] ABI: testing: sysfs-class-oxp: add tt_led attribute documentation
` [PATCH v9 06/15] platform/x86: oxpec: Rename ec group to tt_toggle
` [PATCH v9 07/15] platform/x86: oxpec: Add turbo led support to X1 devices
` [PATCH v9 08/15] platform/x86: oxpec: Move pwm_enable read to its own function
` [PATCH v9 09/15] platform/x86: oxpec: Move pwm value read/write to separate functions
` [PATCH v9 10/15] platform/x86: oxpec: Move fan speed read to separate function
` [PATCH v9 11/15] platform/x86: oxpec: Adhere to sysfs-class-hwmon and enable pwm on 2
` [PATCH v9 12/15] platform/x86: oxpec: Follow reverse xmas convention for tt_toggle
` [PATCH v9 13/15] power: supply: add inhibit-charge-awake to charge_behaviour
` [PATCH v9 14/15] platform/x86: oxpec: Add charge threshold and behaviour to OneXPlayer
` [PATCH v9 15/15] platform/x86: oxpec: Rename rval to ret in tt_toggle

[PATCH 0/2] platform/x86: ISST: SST PP and TF revision 2
 2025-04-17 17:00 UTC  (3+ messages)
` [PATCH 1/2] platform/x86: ISST: Support SST-TF "
` [PATCH 2/2] platform/x86: ISST: Support SST-PP "

[PATCH v6] platform/x86: Add AMD ISP platform config for OV05C10
 2025-04-17 16:53 UTC  (5+ messages)

[v2 1/3] platform/x86/amd/hsmp: Use one DRIVER_VERSION
 2025-04-17 13:19 UTC  (7+ messages)
` [v2 2/3] platform/x86/amd/hsmp: Report power using hwmon sensors
` [v2 3/3] platform/x86/amd/hsmp: acpi: Add sysfs files to show HSMP telemetry

[PATCH v7 0/1] platform/x86/tuxedo: Add virtual LampArray for TUXEDO NB04 devices
 2025-04-17 12:04 UTC  (4+ messages)
` [PATCH v7 1/1] "

[PATCH v3 1/2] Input: Add a Kconfig to emulate KEY_SCREENLOCK with META + L
 2025-04-17 12:02 UTC  (3+ messages)

[PATCHv5] platform/x86: ideapad-laptop: added support for some new buttons
 2025-04-17 12:01 UTC  (2+ messages)

[PATCHv5] platform/x86: ideapad-laptop: added support for some new buttons
 2025-04-17 11:28 UTC  (2+ messages)

[PATCH v3] platform/x86/intel-uncore-freq: Fix missing uncore sysfs during CPU hotplug
 2025-04-17 11:18 UTC  (2+ messages)

[PATCH] platform/x86/amd: pmc: Require at least 2.5 seconds between HW sleep cycles
 2025-04-17 11:18 UTC  (2+ messages)

[PATCHv5] platform/x86: ideapad-laptop: added support for some new buttons
 2025-04-17 11:17 UTC  (3+ messages)

[PATCH v3 0/9] platform/x86: int3472: Add handshake pin support
 2025-04-17 10:56 UTC  (7+ messages)
` [PATCH v3 5/9] platform/x86: int3472: Make regulator supply name configurable
` [PATCH v3 8/9] platform/x86: int3472: Add handshake pin support

[PATCH v4] platform/x86: portwell-ec: Add GPIO and WDT driver for Portwell EC
 2025-04-17 10:18 UTC  (3+ messages)


This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox