X86 platform drivers
 help / color / mirror / Atom feed
From: Hans de Goede <hdegoede@redhat.com>
To: "Rafael J. Wysocki" <rafael@kernel.org>,
	Stefan Binding <sbinding@opensource.cirrus.com>
Cc: Mark Brown <broonie@kernel.org>, Len Brown <lenb@kernel.org>,
	Mark Gross <markgross@kernel.org>,
	Jaroslav Kysela <perex@perex.cz>, Takashi Iwai <tiwai@suse.com>,
	"moderated list:SOUND - SOC LAYER / DYNAMIC AUDIO POWER
	MANAGEM..."  <alsa-devel@alsa-project.org>,
	Linux Kernel Mailing List <linux-kernel@vger.kernel.org>,
	linux-spi <linux-spi@vger.kernel.org>,
	ACPI Devel Maling List <linux-acpi@vger.kernel.org>,
	Platform Driver <platform-driver-x86@vger.kernel.org>,
	patches@opensource.cirrus.com,
	Lucas Tanure <tanureal@opensource.cirrus.com>
Subject: Re: [PATCH v4 5/9] platform/x86: i2c-multi-instantiate: Rename it for a generic bus driver name
Date: Thu, 20 Jan 2022 19:39:25 +0100	[thread overview]
Message-ID: <c75198ce-8d59-d81c-8355-8beca7bc8136@redhat.com> (raw)
In-Reply-To: <CAJZ5v0hMdfnu5PUk3sPvzF_f+xvWaRkE=BUpSAFx_DJ9sB+JDw@mail.gmail.com>

Hi,

On 1/20/22 19:34, Rafael J. Wysocki wrote:
> On Thu, Jan 20, 2022 at 2:43 PM Stefan Binding
> <sbinding@opensource.cirrus.com> wrote:
>>
>> From: Lucas Tanure <tanureal@opensource.cirrus.com>
>>
>> Rename I2C multi instantiate driver to bus-multi-instantiate for
>> upcoming addition of SPI support
> 
> TBH, I don't particularly like the new naming.
> 
> Namely, the "bus" part seems overly generic (and the "bmi"
> abbreviation brings something totally different to mind).
> 
> AFAICS this can cover serial interfaces only and specifically the ones
> where serial links can be represented as resources returned by the
> ACPI _CRS object.
> 
> I would call it serial-multi-instance or similar.

serial-multi-instantiate works for me. That also nice matches
up with the ACPI_RESOURCE_TYPE_SERIAL_BUS which acpi/scan.c
uses to detect these kinda resources.

Regards,

Hans




  reply	other threads:[~2022-01-20 18:39 UTC|newest]

Thread overview: 27+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2022-01-20 13:43 [PATCH v4 0/9] Support Spi in i2c-multi-instantiate driver Stefan Binding
2022-01-20 13:43 ` [PATCH v4 1/9] spi: Make spi_alloc_device and spi_add_device public again Stefan Binding
2022-01-20 14:39   ` Hans de Goede
2022-01-20 13:43 ` [PATCH v4 2/9] spi: Create helper API to lookup ACPI info for spi device Stefan Binding
2022-01-20 14:37   ` Hans de Goede
2022-01-20 13:43 ` [PATCH v4 3/9] spi: Support selection of the index of the ACPI Spi Resource before alloc Stefan Binding
2022-01-20 15:03   ` Hans de Goede
2022-01-20 13:43 ` [PATCH v4 4/9] spi: Add API to count spi acpi resources Stefan Binding
2022-01-20 14:39   ` Hans de Goede
2022-01-20 15:04   ` Hans de Goede
2022-01-20 13:43 ` [PATCH v4 5/9] platform/x86: i2c-multi-instantiate: Rename it for a generic bus driver name Stefan Binding
2022-01-20 15:05   ` Hans de Goede
2022-01-20 18:34   ` Rafael J. Wysocki
2022-01-20 18:39     ` Hans de Goede [this message]
2022-01-20 13:43 ` [PATCH v4 6/9] platform/x86: bus-multi-instantiate: Reorganize I2C functions Stefan Binding
2022-01-20 15:13   ` Hans de Goede
2022-01-20 16:03   ` Hans de Goede
2022-01-20 16:17   ` Hans de Goede
2022-01-20 13:43 ` [PATCH v4 7/9] platform/x86: bus-multi-instantiate: Add SPI support Stefan Binding
2022-01-20 16:30   ` Hans de Goede
2022-01-20 13:43 ` [PATCH v4 8/9] ALSA: hda/realtek: Add support for HP Laptops Stefan Binding
2022-01-20 15:27   ` Takashi Iwai
2022-01-21 14:32     ` Stefan Binding
2022-01-21 14:39       ` Takashi Iwai
2022-01-20 13:43 ` [PATCH v4 9/9] ACPI / scan: Create platform device for CS35L41 Stefan Binding
2022-01-20 16:31   ` Hans de Goede
2022-01-20 16:34 ` [PATCH v4 0/9] Support Spi in i2c-multi-instantiate driver Hans de Goede

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=c75198ce-8d59-d81c-8355-8beca7bc8136@redhat.com \
    --to=hdegoede@redhat.com \
    --cc=alsa-devel@alsa-project.org \
    --cc=broonie@kernel.org \
    --cc=lenb@kernel.org \
    --cc=linux-acpi@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-spi@vger.kernel.org \
    --cc=markgross@kernel.org \
    --cc=patches@opensource.cirrus.com \
    --cc=perex@perex.cz \
    --cc=platform-driver-x86@vger.kernel.org \
    --cc=rafael@kernel.org \
    --cc=sbinding@opensource.cirrus.com \
    --cc=tanureal@opensource.cirrus.com \
    --cc=tiwai@suse.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox