From: "Ilpo Järvinen" <ilpo.jarvinen@linux.intel.com>
To: Andy Shevchenko <andriy.shevchenko@linux.intel.com>
Cc: LKML <linux-kernel@vger.kernel.org>,
platform-driver-x86@vger.kernel.org,
Mika Westerberg <mika.westerberg@linux.intel.com>,
Hans de Goede <hdegoede@redhat.com>,
Ferry Toth <fntoth@gmail.com>
Subject: Re: [PATCH v2 1/3] platform/x86: intel_scu_ipc: Replace workaround by 32-bit IO
Date: Mon, 21 Oct 2024 12:49:08 +0300 (EEST) [thread overview]
Message-ID: <d40d824e-1827-4030-794c-a7c7e15137e6@linux.intel.com> (raw)
In-Reply-To: <ZxYgZGYTzINm2lpz@smile.fi.intel.com>
[-- Attachment #1: Type: text/plain, Size: 2341 bytes --]
On Mon, 21 Oct 2024, Andy Shevchenko wrote:
> On Mon, Oct 21, 2024 at 12:24:57PM +0300, Ilpo Järvinen wrote:
> > On Mon, 21 Oct 2024, Andy Shevchenko wrote:
> >
> > > The theory is that the so called workaround in pwr_reg_rdwr() is
> > > the actual reader of the data in 32-bit chunks. For some reason
> > > the 8-bit IO won't fail after that. Replace the workaround by using
> > > 32-bit IO explicitly and then memcpy() as much data as was requested
> > > by the user. The same approach is already in use in
> > > intel_scu_ipc_dev_command_with_size().
>
> ...
>
> > > err = intel_scu_ipc_check_status(scu);
> > > - if (!err && id == IPC_CMD_PCNTRL_R) { /* Read rbuf */
> > > - /* Workaround: values are read as 0 without memcpy_fromio */
> > > - memcpy_fromio(cbuf, scu->ipc_base + 0x90, 16);
> > > - for (nc = 0; nc < count; nc++)
> > > - data[nc] = ipc_data_readb(scu, nc);
> > > + if (!err) { /* Read rbuf */
> >
> > What is the reason for the removal of that id check? This seems a clear
> > logic change but why? And if you remove want to remove that check, what
> > that comment then means?
>
> Let me split this to a separate change with better explanation then.
>
> > > + for (nc = 0, offset = 0; nc < 4; nc++, offset += 4)
> > > + wbuf[nc] = ipc_data_readl(scu, offset);
> > > + memcpy(data, wbuf, count);
> >
> > So do we actually need to read more than
> > DIV_ROUND_UP(min(count, 16U), sizeof(u32))? Because that's the approach
> > used in intel_scu_ipc_dev_command_with_size() which you referred to.
>
> I'm not sure I follow. We do IO for whole (16-bytes) buffer, but return only
> asked _bytes_ to the user.
So always reading 16 bytes is not part of the old workaround? Because it
has a "lets read enough" feel.
> > > }
> > > mutex_unlock(&ipclock);
> > > return err;
> >
> > FYI (unrelated to this patch), there seems to be some open-coded
> > FIELD_PREP()s in pwr_reg_rdwr(), some of which is common code between
> > those if branches too.
>
> This code is quite old and full of tricks that has to be tested. So, yes
> while it's possible to convert, I would like to do it in a small (baby)
> steps. This series is already quite intrusive from this perspective :-)
Yeah, no pressure, I just noted down what I saw. :-)
--
i.
next prev parent reply other threads:[~2024-10-21 9:49 UTC|newest]
Thread overview: 15+ messages / expand[flat|nested] mbox.gz Atom feed top
2024-10-21 8:38 [PATCH v2 0/3] platform/x86: intel_scu_ipc: Avoid working around IO and cleanups Andy Shevchenko
2024-10-21 8:38 ` [PATCH v2 1/3] platform/x86: intel_scu_ipc: Replace workaround by 32-bit IO Andy Shevchenko
2024-10-21 8:49 ` Mika Westerberg
2024-10-21 9:24 ` Ilpo Järvinen
2024-10-21 9:35 ` Andy Shevchenko
2024-10-21 9:49 ` Ilpo Järvinen [this message]
2024-10-21 9:54 ` Andy Shevchenko
2024-10-21 10:02 ` Andy Shevchenko
2024-10-21 10:14 ` Ilpo Järvinen
2024-10-21 8:38 ` [PATCH v2 2/3] platform/x86: intel_scu_ipc: Simplify code with cleanup helpers Andy Shevchenko
2024-10-21 8:50 ` Mika Westerberg
2024-10-21 9:32 ` Ilpo Järvinen
2024-10-21 9:42 ` Andy Shevchenko
2024-10-21 10:08 ` Ilpo Järvinen
2024-10-21 8:38 ` [PATCH v2 3/3] platform/x86: intel_scu_ipc: Save a copy of the entire struct intel_scu_ipc_data Andy Shevchenko
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=d40d824e-1827-4030-794c-a7c7e15137e6@linux.intel.com \
--to=ilpo.jarvinen@linux.intel.com \
--cc=andriy.shevchenko@linux.intel.com \
--cc=fntoth@gmail.com \
--cc=hdegoede@redhat.com \
--cc=linux-kernel@vger.kernel.org \
--cc=mika.westerberg@linux.intel.com \
--cc=platform-driver-x86@vger.kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox