From: Armin Wolf <W_Armin@gmx.de>
To: "Mark Pearson" <mpearson-lenovo@squebb.ca>,
"Ilpo Järvinen" <ilpo.jarvinen@linux.intel.com>,
"Limonciello, Mario" <mario.limonciello@amd.com>
Cc: "platform-driver-x86@vger.kernel.org"
<platform-driver-x86@vger.kernel.org>
Subject: Re: [PATCH v7 13/22] ACPI: platform_profile: Add profile attribute for class interface
Date: Thu, 21 Nov 2024 23:20:59 +0100 [thread overview]
Message-ID: <e01dfd1b-1981-47a3-a33f-5afa321b7a10@gmx.de> (raw)
In-Reply-To: <249d2e7d-e859-4344-8bf6-f73641b009b9@app.fastmail.com>
Am 21.11.24 um 15:27 schrieb Mark Pearson:
> On Thu, Nov 21, 2024, at 6:10 AM, Ilpo Järvinen wrote:
>> I don't know why you dropped Mario and the list, I reinstanstated those
>> two.
> Unintentional - sorry. Hit the reply button instead of reply-all and didn't notice. Doh.
>
>> On Wed, 20 Nov 2024, Mark Pearson wrote:
>>> On Wed, Nov 20, 2024, at 9:56 AM, Ilpo Järvinen wrote:
>>>> On Tue, 19 Nov 2024, Mario Limonciello wrote:
>>>>
>>>>> Reading and writing the `profile` sysfs file will use the callbacks for
>>>>> the platform profile handler to read or set the given profile.
>>>>>
>>>>> Tested-by: Mark Pearson <mpearson-lenovo@squebb.ca>
>>>>> Signed-off-by: Mario Limonciello <mario.limonciello@amd.com>
>>>>> ---
>>>>> v7:
>>>>> * Remove extra handler set
>>>>> * Remove err variable
>>>>> v6:
>>>>> * Fix return
>>>>> v5:
>>>>> * Drop recovery flow
>>>>> * Don't get profile before setting (not needed)
>>>>> * Simplify casting for call to _store_class_profile()
>>>>> * Only notify legacy interface of changes
>>>>> * Adjust mutex use
>>>>> ---
>>>>> drivers/acpi/platform_profile.c | 100 ++++++++++++++++++++++++++++++++
>>>>> 1 file changed, 100 insertions(+)
>>>>>
>>>>> diff --git a/drivers/acpi/platform_profile.c b/drivers/acpi/platform_profile.c
>>>>> index 9d6ead043994c..1530e6096cd39 100644
>>>>> --- a/drivers/acpi/platform_profile.c
>>>>> +++ b/drivers/acpi/platform_profile.c
>>>>> static struct attribute *profile_attrs[] = {
>>>>> &dev_attr_name.attr,
>>>>> &dev_attr_choices.attr,
>>>>> + &dev_attr_profile.attr,
>>>> I started to wonder if "choices" is good name for the other attribute as
>>>> it is the set of values "profile" accepts? Should they be bound by the
>>>> naming too like "profile_choices" or something along those lines so the
>>>> connection between the two is very evident?
>>>>
>>> Wouldn't it be weird to not have it in sync with the main sysfs entry
>>> (which I don't think we can change at that point without messing up
>>> userspace).
>>>
>>> I think it would be more confusing to have different naming as it would
>>> imply they're different things.
>> Ah, I didn't realize there's a pre-existing convention. Then just
>> disregard what I suggested.
>>
> No idea if it's a convention - I just would think it would be confusing for users.
>
> Thanks
> Mark
I personally would prefer the attribute name "choices", but i would also accept if the attribute was
named "profile_choices". I think adding the "profile" prefix to the attribute when it is already handled
by the platform-profile class is silly.
Either way:
Reviewed-by: Armin Wolf <W_Armin@gmx.de>
next prev parent reply other threads:[~2024-11-21 22:21 UTC|newest]
Thread overview: 38+ messages / expand[flat|nested] mbox.gz Atom feed top
2024-11-19 17:17 [PATCH v7 00/22] Add support for binding ACPI platform profile to multiple drivers Mario Limonciello
2024-11-19 17:17 ` [PATCH v7 01/22] ACPI: platform-profile: Add a name member to handlers Mario Limonciello
2024-11-19 17:17 ` [PATCH v7 02/22] platform/x86/dell: dell-pc: Create platform device Mario Limonciello
2024-11-21 22:01 ` Armin Wolf
2024-11-19 17:17 ` [PATCH v7 03/22] ACPI: platform_profile: Add device pointer into platform profile handler Mario Limonciello
2024-11-19 17:17 ` [PATCH v7 04/22] ACPI: platform_profile: Add platform handler argument to platform_profile_remove() Mario Limonciello
2024-11-19 17:17 ` [PATCH v7 05/22] ACPI: platform_profile: Pass the profile handler into platform_profile_notify() Mario Limonciello
2024-11-19 17:17 ` [PATCH v7 06/22] ACPI: platform_profile: Move sanity check out of the mutex Mario Limonciello
2024-11-19 17:17 ` [PATCH v7 07/22] ACPI: platform_profile: Move matching string for new profile out of mutex Mario Limonciello
2024-11-19 17:17 ` [PATCH v7 08/22] ACPI: platform_profile: Use guard(mutex) for register/unregister Mario Limonciello
2024-11-19 17:17 ` [PATCH v7 09/22] ACPI: platform_profile: Use `scoped_cond_guard` Mario Limonciello
2024-11-19 17:17 ` [PATCH v7 10/22] ACPI: platform_profile: Create class for ACPI platform profile Mario Limonciello
2024-11-20 14:37 ` Ilpo Järvinen
2024-11-19 17:17 ` [PATCH v7 11/22] ACPI: platform_profile: Add name attribute to class interface Mario Limonciello
2024-11-20 14:42 ` Ilpo Järvinen
2024-11-21 22:11 ` Armin Wolf
2024-11-19 17:17 ` [PATCH v7 12/22] ACPI: platform_profile: Add choices attribute for " Mario Limonciello
2024-11-20 14:47 ` Ilpo Järvinen
2024-11-21 22:12 ` Armin Wolf
2024-11-19 17:17 ` [PATCH v7 13/22] ACPI: platform_profile: Add profile " Mario Limonciello
2024-11-20 14:56 ` Ilpo Järvinen
[not found] ` <080ad77b-aa87-4541-8aec-bc74a6c2c0a7@app.fastmail.com>
2024-11-21 11:10 ` Ilpo Järvinen
2024-11-21 14:27 ` Mark Pearson
2024-11-21 22:20 ` Armin Wolf [this message]
2024-11-19 17:17 ` [PATCH v7 14/22] ACPI: platform_profile: Notify change events on register and unregister Mario Limonciello
2024-11-20 15:09 ` Ilpo Järvinen
2024-11-20 15:37 ` Mario Limonciello
2024-11-21 22:24 ` Armin Wolf
2024-11-19 17:17 ` [PATCH v7 15/22] ACPI: platform_profile: Only show profiles common for all handlers Mario Limonciello
2024-11-19 17:17 ` [PATCH v7 16/22] ACPI: platform_profile: Add concept of a "custom" profile Mario Limonciello
2024-11-19 17:17 ` [PATCH v7 17/22] ACPI: platform_profile: Make sure all profile handlers agree on profile Mario Limonciello
2024-11-19 17:17 ` [PATCH v7 18/22] ACPI: platform_profile: Check all profile handler to calculate next Mario Limonciello
2024-11-19 17:17 ` [PATCH v7 19/22] ACPI: platform_profile: Notify class device from platform_profile_notify() Mario Limonciello
2024-11-21 22:31 ` Armin Wolf
2024-11-19 17:17 ` [PATCH v7 20/22] ACPI: platform_profile: Allow multiple handlers Mario Limonciello
2024-11-19 17:17 ` [PATCH v7 21/22] platform/x86/amd: pmf: Drop all quirks Mario Limonciello
2024-11-19 17:17 ` [PATCH v7 22/22] Documentation: Add documentation about class interface for platform profiles Mario Limonciello
2024-11-20 18:17 ` [PATCH v7 00/22] Add support for binding ACPI platform profile to multiple drivers Mark Pearson
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=e01dfd1b-1981-47a3-a33f-5afa321b7a10@gmx.de \
--to=w_armin@gmx.de \
--cc=ilpo.jarvinen@linux.intel.com \
--cc=mario.limonciello@amd.com \
--cc=mpearson-lenovo@squebb.ca \
--cc=platform-driver-x86@vger.kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox