Linux RCU subsystem development
 help / color / mirror / Atom feed
From: "Paul E. McKenney" <paulmck@kernel.org>
To: "Uladzislau Rezki (Sony)" <urezki@gmail.com>
Cc: LKML <linux-kernel@vger.kernel.org>, RCU <rcu@vger.kernel.org>,
	Andrew Morton <akpm@linux-foundation.org>,
	Frederic Weisbecker <frederic@kernel.org>,
	Neeraj Upadhyay <neeraju@codeaurora.org>,
	Joel Fernandes <joel@joelfernandes.org>,
	Peter Zijlstra <peterz@infradead.org>,
	Michal Hocko <mhocko@suse.com>,
	Thomas Gleixner <tglx@linutronix.de>,
	"Theodore Y . Ts'o" <tytso@mit.edu>,
	Sebastian Andrzej Siewior <bigeasy@linutronix.de>,
	Oleksiy Avramchenko <oleksiy.avramchenko@sonymobile.com>
Subject: Re: [PATCH 2/2] rcu: eliminate the __kvfree_rcu() macro
Date: Tue, 24 Nov 2020 11:55:51 -0800	[thread overview]
Message-ID: <20201124195551.GL1437@paulmck-ThinkPad-P72> (raw)
In-Reply-To: <20201120114917.5263-2-urezki@gmail.com>

On Fri, Nov 20, 2020 at 12:49:17PM +0100, Uladzislau Rezki (Sony) wrote:
> Make the kvfree_rcu_arg_2() to be open-coded, so readability
> and review look better from the first glance. Moreover, that
> makes it clear that both kvfree_rcu_arg_1/2() use one single
> interface.
> 
> Signed-off-by: Uladzislau Rezki (Sony) <urezki@gmail.com>

I queued both with the usual editing, thank you!

							Thanx, Paul

> ---
>  include/linux/rcupdate.h | 18 ++++++------------
>  1 file changed, 6 insertions(+), 12 deletions(-)
> 
> diff --git a/include/linux/rcupdate.h b/include/linux/rcupdate.h
> index b1e75648d402..6d56dd7e6a30 100644
> --- a/include/linux/rcupdate.h
> +++ b/include/linux/rcupdate.h
> @@ -842,15 +842,6 @@ static inline notrace void rcu_read_unlock_sched_notrace(void)
>   */
>  #define __is_kvfree_rcu_offset(offset) ((offset) < 4096)
>  
> -/*
> - * Helper macro for kfree_rcu() to prevent argument-expansion eyestrain.
> - */
> -#define __kvfree_rcu(head, offset) \
> -	do { \
> -		BUILD_BUG_ON(!__is_kvfree_rcu_offset(offset)); \
> -		kvfree_call_rcu(head, (rcu_callback_t)(unsigned long)(offset)); \
> -	} while (0)
> -
>  /**
>   * kfree_rcu() - kfree an object after a grace period.
>   * @ptr: pointer to kfree(both for single argument and double one)
> @@ -868,7 +859,7 @@ static inline notrace void rcu_read_unlock_sched_notrace(void)
>   * Because the functions are not allowed in the low-order 4096 bytes of
>   * kernel virtual memory, offsets up to 4095 bytes can be accommodated.
>   * If the offset is larger than 4095 bytes, a compile-time error will
> - * be generated in __kvfree_rcu(). If this error is triggered, you can
> + * be generated in kvfree_rcu_arg_2(). If this error is triggered, you can
>   * either fall back to use of call_rcu() or rearrange the structure to
>   * position the rcu_head structure into the first 4096 bytes.
>   *
> @@ -914,8 +905,11 @@ static inline notrace void rcu_read_unlock_sched_notrace(void)
>  do {									\
>  	typeof (ptr) ___p = (ptr);					\
>  									\
> -	if (___p)							\
> -		__kvfree_rcu(&((___p)->rhf), offsetof(typeof(*(ptr)), rhf)); \
> +	if (___p) {									\
> +		BUILD_BUG_ON(!__is_kvfree_rcu_offset(offsetof(typeof(*(ptr)), rhf)));	\
> +		kvfree_call_rcu(&((___p)->rhf), (rcu_callback_t)(unsigned long)		\
> +			(offsetof(typeof(*(ptr)), rhf)));				\
> +	}										\
>  } while (0)
>  
>  #define kvfree_rcu_arg_1(ptr)					\
> -- 
> 2.20.1
> 

  reply	other threads:[~2020-11-24 19:55 UTC|newest]

Thread overview: 4+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2020-11-20 11:49 [PATCH 1/2] rcu: introduce kfree_rcu() single argument macro Uladzislau Rezki (Sony)
2020-11-20 11:49 ` [PATCH 2/2] rcu: eliminate the __kvfree_rcu() macro Uladzislau Rezki (Sony)
2020-11-24 19:55   ` Paul E. McKenney [this message]
2020-11-25 18:57     ` Uladzislau Rezki

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20201124195551.GL1437@paulmck-ThinkPad-P72 \
    --to=paulmck@kernel.org \
    --cc=akpm@linux-foundation.org \
    --cc=bigeasy@linutronix.de \
    --cc=frederic@kernel.org \
    --cc=joel@joelfernandes.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=mhocko@suse.com \
    --cc=neeraju@codeaurora.org \
    --cc=oleksiy.avramchenko@sonymobile.com \
    --cc=peterz@infradead.org \
    --cc=rcu@vger.kernel.org \
    --cc=tglx@linutronix.de \
    --cc=tytso@mit.edu \
    --cc=urezki@gmail.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox