From: Andreas Hindborg <a.hindborg@kernel.org>
To: FUJITA Tomonori <tomo@flapping.org>,
aliceryhl@google.com, arve@android.com, boqun@kernel.org,
brauner@kernel.org, cmllamas@google.com, gary@garyguo.net,
gregkh@linuxfoundation.org, ojeda@kernel.org, tkjos@android.com
Cc: acourbot@nvidia.com, anna-maria@linutronix.de,
bjorn3_gh@protonmail.com, dakr@kernel.org,
daniel.almeida@collabora.com, frederic@kernel.org,
jstultz@google.com, lossin@kernel.org, lyude@redhat.com,
sboyd@kernel.org, tamird@kernel.org, tglx@kernel.org,
tmgross@umich.edu, work@onurozkan.dev,
rust-for-linux@vger.kernel.org,
FUJITA Tomonori <fujita.tomonori@gmail.com>
Subject: Re: [PATCH v5 4/7] rust: time: add Delta::to_jiffies() for timeout conversion
Date: Thu, 06 Aug 2026 11:50:35 +0200 [thread overview]
Message-ID: <871pcb4lxw.fsf@t14s.mail-host-address-is-not-set> (raw)
In-Reply-To: <20260806073241.1024319-5-tomo@flapping.org>
FUJITA Tomonori <tomo@flapping.org> writes:
> From: FUJITA Tomonori <fujita.tomonori@gmail.com>
>
> Add Delta<Nsec>::to_jiffies() conversion that rounds up so the
> resulting timeout is never shorter than the requested span, clamps a
> negative span to an immediate timeout, and saturates an overlong span
> to the kernel's MAX_JIFFY_OFFSET "wait forever" value.
>
> Reviewed-by: Gary Guo <gary@garyguo.net>
> Signed-off-by: FUJITA Tomonori <fujita.tomonori@gmail.com>
> ---
> rust/kernel/time.rs | 21 +++++++++++++++++++++
> 1 file changed, 21 insertions(+)
>
> diff --git a/rust/kernel/time.rs b/rust/kernel/time.rs
> index 9d65a6c1992a..5844ee985a7b 100644
> --- a/rust/kernel/time.rs
> +++ b/rust/kernel/time.rs
> @@ -551,6 +551,27 @@ pub fn as_millis_ceil(self) -> i64 {
> }
> }
>
> + /// Convert this span to a [`Delta<Jiffy>`] suitable for use as a timeout.
> + ///
> + /// The value is rounded up to the next whole jiffy, so the resulting
> + /// timeout is never shorter than `self` (as `msecs_to_jiffies()` does).
> + /// A negative span clamps to zero jiffies (an immediate timeout).
Should we rename this to `to_jiffies_timeout` to indicate the clamping
logic more clearly? I would expect a function with this name to have a
negative `Delta<Nsec>` convert to a negative `Delta<Jiffy>`.
Best regards,
Andreas Hindborg
next prev parent reply other threads:[~2026-08-06 9:50 UTC|newest]
Thread overview: 18+ messages / expand[flat|nested] mbox.gz Atom feed top
2026-08-06 7:32 [PATCH v5 0/7] rust: use Delta instead of raw jiffies for timeouts and delays FUJITA Tomonori
2026-08-06 7:32 ` [PATCH v5 1/7] rust: time: make Delta generic over its time unit FUJITA Tomonori
2026-08-06 9:44 ` Andreas Hindborg
2026-08-07 12:10 ` FUJITA Tomonori
2026-08-06 7:32 ` [PATCH v5 2/7] rust: time: add jiffies time unit for Delta FUJITA Tomonori
2026-08-06 7:32 ` [PATCH v5 3/7] rust: time: add Delta::as_millis_ceil() FUJITA Tomonori
2026-08-06 9:47 ` Andreas Hindborg
2026-08-07 13:26 ` FUJITA Tomonori
2026-08-06 7:32 ` [PATCH v5 4/7] rust: time: add Delta::to_jiffies() for timeout conversion FUJITA Tomonori
2026-08-06 9:50 ` Andreas Hindborg [this message]
2026-08-07 12:15 ` FUJITA Tomonori
2026-08-06 11:50 ` Gary Guo
2026-08-07 12:38 ` FUJITA Tomonori
2026-08-07 12:59 ` Gary Guo
2026-08-07 13:13 ` FUJITA Tomonori
2026-08-06 7:32 ` [PATCH v5 5/7] rust: workqueue: take a Delta<Jiffy> for the enqueue delay FUJITA Tomonori
2026-08-06 7:32 ` [PATCH v5 6/7] rust: sync: condvar: use Delta<Jiffy> for timeout and result FUJITA Tomonori
2026-08-06 7:32 ` [PATCH v5 7/7] rust: time: remove unused Jiffies/Msecs helpers FUJITA Tomonori
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=871pcb4lxw.fsf@t14s.mail-host-address-is-not-set \
--to=a.hindborg@kernel.org \
--cc=acourbot@nvidia.com \
--cc=aliceryhl@google.com \
--cc=anna-maria@linutronix.de \
--cc=arve@android.com \
--cc=bjorn3_gh@protonmail.com \
--cc=boqun@kernel.org \
--cc=brauner@kernel.org \
--cc=cmllamas@google.com \
--cc=dakr@kernel.org \
--cc=daniel.almeida@collabora.com \
--cc=frederic@kernel.org \
--cc=fujita.tomonori@gmail.com \
--cc=gary@garyguo.net \
--cc=gregkh@linuxfoundation.org \
--cc=jstultz@google.com \
--cc=lossin@kernel.org \
--cc=lyude@redhat.com \
--cc=ojeda@kernel.org \
--cc=rust-for-linux@vger.kernel.org \
--cc=sboyd@kernel.org \
--cc=tamird@kernel.org \
--cc=tglx@kernel.org \
--cc=tkjos@android.com \
--cc=tmgross@umich.edu \
--cc=tomo@flapping.org \
--cc=work@onurozkan.dev \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox